Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





92 Towncar - turn signal inop need help

jtatmanjtatman Posts: 2
edited June 1 in Lincoln
I have a 92 Lincoln Towncar - Exec series. I am having a problem with the right rear turn signal not working.I replaced the multifunction switch on the column - ( wiper, hi beam, hazard, turn signal switch )since the hi beams wasnt working. The switch fixed this problem. The front turn signals work & so does the left rear signal, the brake lights work, the hazard lights work but no right rear turn signal. Here is what I have done to check things out,I checked the bulbs & replaced them, I checked for ground at the bulb socket, it has ground. I have replaced the turn signal & hazard flashers, checked the fuses.I do know that the right rear turnsignal wire is orange & blue but its not getting power from the switch for some reason. ( to double check to make sure the switch is working I bought another one, that did not fix the turn signal issue ).

I am not an electrical genius by no means but I need some help here. Any suggestions.

Comments

  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,328
    The turn signal bulb, the brake bulb and the hazard bulb are all the same bulb. There may be an electric "decyphyer" that determines where to channel the current for different purposes and perhaps that would be in the brake system, but guessing is what I do best when it comes to electrical connections.
  • nwraaanwraaa Posts: 161
    Test the wires leading to the socket. Push a small straight pin through each wire. Turn the right turn signal on an see if you get intermittent power. If not, go back to the switch at the steering wheel. Check the contacts in the connector to verify that they are touching when connected. Compare the contacts in the new one to the old one.
  • Its not getting power from the switch to the right rear, if I jump the left rear turn wire @ the switch/connector to the right rear turn wire in the connector the blinker works out back. That means the socket & wiring to the back of the car works. I have to check the connector again, it appears it could be worn out. I also had a guy tell me that their is a relay that controls each rear turn signal. I have to look into that as well.
This discussion has been closed.