Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Acura Legend

1161719212226

Comments

  • My 95 legend is overheating so, I had it checked at a reputed acura dealer who said the head gasket needs replacement and said it would cost between $3000.00 and $3500.00.
    I find the quote absolutely ridiculous and want to know if that is the normal price.

    Thanks a lot.
  • dagr8n8dagr8n8 Posts: 5
    REDicluSS!! i jsut blew a head gasket and they said it should cost about 1500$ to replace. but im gonan try to do it my self and it should be around 300 at the most because its a 90% labor job.

    dose any one have ne tips on replacing a head gasket?
  • patpat Posts: 10,421
    I'd also post this in the Got a Quick, Technical Question? discussion while you're waiting for some input here. Good luck with it.
  • thefuzzthefuzz Posts: 1
    I have the same problem with my 94 Legend. It does it daily. Any ideas?
  • baumbaum Posts: 15
    Hi! I am new to this site and I am hoping I can get some advice. My 1990 Acura Legend is having some shifting problems. :confuse: It has an automatic transmission. This happens totally randomly, usually when it is hot outside.... my car seems to be stuck in 3rd gear. When I accelerate from a stop, it lags, like I am starting in 2nd or 3rd gear. And when I am driving above 30 MPH, my RPM's don't go down, like I'm not shifting into a higher gear. Also, I notice on my dash that the "S3" light flashes.
    Could this be a transmission problem or something easier? PLEASE HELP ME!! =) THANK YOU anyone!!
  • lastwraithlastwraith Posts: 350
    If you have a transmission light flashing (S3 OR D4) then the TCU (Transmission Control Unit) has run into a problem and logged at least one fault code. Have the code read by either an independent shop, AutoZone, or a dealer to start addressing the problem.

    Also (regarding another poster who was responding to a message from 2000) not sure if you read the response to that 2000 message but......the D4 light does NOT flash for no reason. A fault code should be logged if the D4 light, or any similar light has flashed while driving. This may also be accompanied by "limp-home" behavior from the car.
  • Hey I have an Acura Legend 90, I am facing this heating problem for a while but I found an easier way to over come this issue, hope it works for u as well.

    Check for the FAN REGULATOR SWITCH & try to change it , its not a costly part & may solve ur problem,

    Joe
  • baumbaum Posts: 15
    Thank you lastwraith for responding. Hopefully its not expensive! I just spent $260 on some fluid changes and a Main Relay switch. :cry:
    Thanks again!
    :)
  • lastwraithlastwraith Posts: 350
    Yikes, that's a lot of money. You're welcome and I wish you luck.
  • baumbaum Posts: 15
    I was wondering if anyone else has had the same problem as me, and if so, what was the diagnosis of the Transmission Control Unit Faulty Code thingy.
    Thank You!
  • baumbaum Posts: 15
    Smithed-
    I have a 1990 Legend and the "S3" light flashes. Its like I get stuck in 3rd gear... Do you remember around how much it costs to get the speed sensor relaced? Does my problem sound the same as yours? (S3 light compared to D4 light)
    THANKS!!
  • lastwraithlastwraith Posts: 350
    I'd imagine your Acura is similar to my Honda, when my Accord detects a transmission related problem it defaults to 2nd gear only mode (limp-home mode) to save itself. This means you start out in second gear (not a fast start) and it will not shift out of it even if you try to travel at high speed.

    I replaced my vehicle's VSS (vehicle speed sensor) and it was under $70 for the part. It is pretty easily accessible in my car and it took me about 40 mins to change only because I had a hard time finding the right size tool for the job. I would not pay more than $200 to have this done. Anything higher is a severe rip off. At that point, get the part online and just have them charge you an hour's labor.
  • nupe1nupe1 Posts: 1
    Owned the car since is was new...always kept maintenance up. Lately, alarm goes off periodically for no apparent reason. Doesn't do it enough to pinpoint actually what triggers it...pretty sure it's not external factors. Any ideas? I want to disarm it until I can get the entire system checked out...can anyone tell me (how to disarm) and whether disarming it is fairly simple...i.e. disconnecting a wire or two or something I'm going to need a professional to do...thanks
  • Hello. I just recently purchased a 1991 Acura Legend and it did not have an owners manuel. I know I could spend some time and put in some effort to find out some things I am unsure of, but I dont have the time to do so. I was just wondering if anyone that does have a manuel would be interested in telling me some things that I would like to know? I would greatly appreciate it. Thanks
  • baumbaum Posts: 15
    -lastwraith
    thank you so much for your help. i'm going to try it next weekend....i'll keep my fingers crossed! Kinda weird though.......it hasn't done it since i posted the last message. :confuse:
    Thanks again :)
  • bucksbucks Posts: 3
    I just paid for new head gaskets, water pump and timing belt on my 1991 Legend Coupe. The car has 155000 plus miles and runs great. The only problem I have is the car shifts hard in 2nd and 3rd gear. Also, the car will shift hard when slowing down to stop. I took it back to the repair shop and they told me due to the car running so well, it will have a tendency to shift hard (ha!). I think the RPM needle is set to high. But again, the mechanic told me the RPM needle is set per specs. Any ideas???
  • Does anyone know where the headlights-on chime/alarm is located? I suspect that it was disabled and want to enable it. :confuse: Thanks in advance.

    1990 Legend LS Coupe
  • Did you solve this issue? I am having the exact same problem. :confuse:
  • I have a 86 Legend. The other day I twisted the switch to turn on the headlights. In the first position the dashboard light and running lights come one, but if I turn it to the next position the headlights come one but the dashboard lights and running lights go off. Brake lights not affected. I am not much of a diagnostician or mechanic so I am hoping someone can tell me what the problem is and if it is something a guy with a tool box the size of a lunch pail can fix. Appreciate any and all input. Thank You very much.
  • patpat Posts: 10,421
    You might want to also post this in our Electrical Problems discussion while you're waiting for some feedback here.
  • Anyone, I mean anyone, know what happend to Acura-Legend.com???
  • Do you have a service manual (pdf) that I can have
  • Hi,

    The airconditioning on my 91 Legend sometimes works fine and at times it doesn't blow cold (the radio display does this on/off thing too). I took it to the dealer, who found no leaks but topped off the refrigerant in the compressor, then thought the electrical relays might be at fault and now says that there is a problem with Electronic Control Unit's grounding.

    I haven't been able to get a clear answer from him about whether replacing the ECU is a safety concern or not. For example, does it control the transmission or the ABS or if all it does is control the compressor and maybe the radio display. It would be helpful if someone could shed light on what the ECU does and does not control or if there are several ECUs each with a different set of purposes.

    Thanks in advance!
  • puchopucho Posts: 1
    Clutch pedal sinks to floor and has no pressure to return to its normal postion. Has anyone had a similar problem? What should be done?

    My 1992 Acura Legend Coupe v6 engine with 5-speed manual transmission

    Any clues appreciated. TIA.

    PS. The mechanic wants to change clutch slate and master. He said "hydralic part has slow internal leak and needs to be changed." It is normal wear and tear of the part. Clutch and transmission have been already been changed 4 months ago.
  • There should be a TCU (transmission control unit) mounted right next to your ECU, I'll leave it up to you to figure out what that does ;) But as for the ECU...

    Straight from a reputable auto repair website:

    "Definition: The Electronic Control Unit (ECU) controls the fuel injection system, ignition timing, and the idle speed control system. The ECU also interrupts the operation of the air conditioning and EGR systems, and controls power to the fuel pump (through the control relay). The ECU consists of an 8-bit microprocessor, random access memory (RAM), read only memory (ROM), and an input/output interface.

    Based on information from the input sensors (engine coolant temperature, barometric pressure, air flow, etc.), the ECU determines optimum settings for the output actuators (injection, idle speed, ignition timing, etc.)."
  • sixfivesixfive Posts: 45
    Anyone care to comment on a 7900 Purhcase price for a car with 48k in excellent condition. This car should have 100k to go based on my experience with Honda and Acura but the pricing appraisals all come back in the 5000 -5500 range. Thanks
  • kyfdxkyfdx Posts: 28,635
    I'm definitely not an expert....

    But, I do own a '92 Legend L.. with around 40K on the clock...

    Before I bought it from my uncle, he had a few dealers tell him that they would put it on their lot for $8500, and probably get $7500 out of it... this was a couple years ago...

    The Legend is very popular, and the LS model even more so.... but, it seems prices have started to tail off a little, as it gets harder every year to find nice examples...

    Not sure if this is a dealer or private seller, but if the car is in good shape, in accord with the low miles, then I'd say it should probably bring $6500-$7500... The lower end from a private seller, and the upper end from a dealer...

    With that mileage, I can't see it going under $6K, unless it has some bad custom work or is an iffy color, or some other problem...

    Hopefully, some of our members will chime in with some recent pricing experiences.. (I got a family deal on mine).

    regards,
    kyfdx
    Host-Prices Paid Forums

    MODERATOR
    Prices Paid, Lease Questions, SUVs

  • sixfivesixfive Posts: 45
    Great Info - thanks kyfdx.

    What are the trouble areas I should look for? Isn't the tranny an issue for some years? Also, wasn't there a hefty HP increase for the last year or two on the 6 speed. I saw some information a while ago and can't find it now. Any help is appreciated.

    Also as an enthusiastic car person, what other great buys would you suggest. I like the idea of an old early 80's low miles supra. I saw one going for 14k. I love the idea of getting a car for 8K and selling it in 3 years for 7k. Grand National may not lose much value either but good ones tend to cost a tad more. Sorry to digress but Acura sure did a good job way back then and I'm wondering if anything can compete before I sell my G and have to decide.
  • hawks1hawks1 Posts: 57
    I have a 1990 Legend (L Series) with 188K miles. For some time, well over a couple of years, the yellow ABS warning light comes on after brief driving and remains on. A local mechanic has assured me nothing is wrong with the ABS system but nothing can be done to "turn off" the warning light. Does this sound reasonable and has anyone else had this problem? I'm getting ready to sell this car and I'm sure this question will arise with a perspective buyer.
  • hyiuhyiu Posts: 18
    I have a 93 Legend Coupe.
    leather seat, and driver side power seat. The leather on the front seats cracks pretty badly.

    I want to cover it with a seat cover. I'm using a t-shirt to cover it for now. But because of the bucket seat shape, the back doesn't fit well at all.

    Anyone uses a seat cover of some sort to cover their seat ??
    If so, can you tell me how good they fit, what brand, and what price ??

    Thanks,
    - Henry.
Sign In or Register to comment.