Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda MPV: Problems & Solutions

1124125127129130143

Comments

  • I have a 2002 LX with the factory installed radio/ single CD player. Lately the sound will shut off on its own then come back on. Any recommendations?
  • subearusubearu Posts: 3,613
    Does the radio/CD shut off, or just the volume cut out? Could be a connection issue at the back of the radio. And you are likely still under warranty.

     

    -Brian
  • New to the forum. We purchased a 2004 MPV back in July and have been having constant trouble with the hard shift between 2nd and 3rd. Van is currently at dealership for fourth time. Of course problem is not easily reproduced and has not been observed by the service dept. They have reflashed the TCM once and also have replaced a valve. Our van has only 8200 miles on it. We are currently waiting for dealership call to see what the "fix" is this time. Any new service bulletins that anyone knows of would be appreciated.
  • My '94 2WD MPV 6cyl seems to have a short. After running only a short distance with any accessory on the van will not restart without a boost. Have replaced the battery but the problem continues to exist. I notice that ewhen I press the brake pedal, even when turned off and the key removed, the instrument lights come on. The other day the ABS warnig light flicked on and off a few times but there does not seem to be anything wrong with the brakes.

    Any ideas of where I should start to look in the wiring maze.

    Thanks for any advice

    Bob Upshon

    Shediac, NB, Canada
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,893
    Just a couple of shopping days left until Christmas... avoid the holiday crush and join us for an evening of automotive chat and good cheer!

     

    PF Flyer

    Host

    Pickups & News & Views Message Boards


     

    The MAZDA MANIA chat is on TONIGHT. Stop in for a holiday visit! Check out the schedule

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • My '01 MPV with ~54K mi. has been paid off for 6 months and now I have my 1st big repair bill. I was driving for about a week with a "rough idle." Then the check engine light was flashing at me as I drove to work one day and took it to the mechanic that night. He said there were so many things wrong with it but listed 4 things to do immediately: 1) replace a cracked crank case 2) flush fuel injection 3) tune up 4) replace 3 bad tires. I chose to do 1-3. I have 3 new tires and am PO'ed that they look bad. Without the new tires, 1-3 is costing $1100 including diagnostics.

     

    Has anyone else had a problem with a cracked crank case? I've had several cars (actual cars, not minivans) and have never had a cracked crank case.
  • jipsterjipster Posts: 5,345
    I don't know about the crank case. But, it seems odd he would recommend replaceing 3 tires instead of all 4. Also, if you have 3 "new" tires that are looking bad...I would have the suspension and wheels inspected. Also again... flushing the fuel injection and tune up at only 54k is a little early.If you don't feel you can trust this mechanic I would consider a second opinion.
  • bob57bob57 Posts: 302
    Cracked crankcase? Where? That sounds a little odd unless you're racing the quater mile circuits turning 9000 RPMs. My only experience with a cracked crankcase (not MPV..) was when one of the pistons decided to go south during my "older racing days".

    Flushing the fuel system won't hurt especially if the fuel you are using comes from Fred's Fast Fuel Emporium @ 85 cents a gallon....

    I agree with Jipster - see another mechanic about the crankcase and take a look for yourself on that.
  • mattnjmattnj Posts: 3
    Stay away from any subsidary of the Ford Motor Company!
    Had the same problem and now I pay over $3000 at aamco!
    Anyone else wont to sign up?!
    Matt-New Jersey
  • edmanedman Posts: 1
    I have a 2000 MPV with the same sticky pedal problem. What is involved removing carbon build up on the throttle valve and pivots? How are they cleaned? Is this simple to do?
  • steverstever Viva Las CrucesPosts: 40,868
    Throttle body cleaning is easy to do on my Quest. Here's a link to a couple of posts that describe the process:

     

    steve_, "Nissan Quest/Mercury Villager problems" #1688, 27 Dec 2004 10:52 pm

     

    It should be easy enough to adapt to the MPV. There may be some Mazda specific posts in here too (try Search This Discussion).

     

    Steve, Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • dszkldszkl Posts: 6
    Does anyone know if there is anywhere I can get a second row aftermarket bench seat that can fit 3? I have 3 kids all in car seats and dont want them in the 3rd row. If I cant find a bench, I am going to have to lose out and buy a different vehicle and I love the MPV. Thanks for any help.
  • mkellymkelly Posts: 2
    I have a 2000 MPV with 24,000 on it. Bought it new. Never had any kind of problem, except for now. Sometimes when you drive it, there is this hum coming from the air box. If you pop open the top two clips to open the box, the hum get louder. It's defintely coming from there. Any ideas?
  • subearusubearu Posts: 3,613
    I checked mpvclub and found a TSB stating that it's likely the IAC - idle air control valve. Though, you're likely out of warranty now.

     

    -Brian
  • mkellymkelly Posts: 2
    thanks for the info.....where would i find that tsb? is that an emission control device? isn't that a 5yr/60,000 warranty?
  • New owner of a 2004 MVP. Have 5100 miles on it. When backing up first thing in the morning, get a squeaking noise from applying brakes. At first oil change, dealer said this is normal and the pads are damp with rust and to slightly put on E brake to get rid of squeak. Did not sound like a good answer for a $27,000 van that is waking up the neighborhood in the morning when backing up. Is there anyone who knows what to do beside the dealer's service manager? Thanks awscott4
  • subearusubearu Posts: 3,613
    there is a TSB to replace the brake pads for this particular symptom.

     

    -Brian
  • jaserbjaserb Posts: 858
    it's really freaking loud! The TSB number is 04-007/04. If your dealer won't perform the TSB find another dealer, or call Mazda customer service. My van is in the shop right now waiting for the parts. They've got me in a rental, which is always a joy. Last time I got a Ford Freestar, which was an unmitigated pile of junk. This time I got an enormous 15 passenger Ford van. Unbelievable. I'll probably go turn in the rental and just take my van back until the parts come in.

     

    -Jason
  • I have an 04 that I got in September. It's been making this noise for months. Haven't gotten it to the dealer yet - was hoping it would wear away somehow. Glad to know there's a solution. My 00 and 03 MPV's didn't have this problem ever.
  • jaserbjaserb Posts: 858
    I'm a little surprised they wouldn't have tested the pads for cold weather performance, but that explains why the problem didn't occur on '00-'03 models.

     

    -Jason
  • bob57bob57 Posts: 302
    My '01 started the "moose call" when the first cold snap hit two weeks ago. (OK, OK, a cold snap in Houston is between 50 & 60 degrees..).

    Anyway, it stops before I get out of the block but the neighborhood kids think it's cool and the family dog is scared of it. Aside from the noise I'm just going to let it call until I find time to fix it myself. At 73K miles this is the only "semi-problem" I've ever had with the MPV - and it passed the pollution inspection yesterday with no problems.
  • my dealers here have no spare brake pad and I had to bring the van in to order the part in. I guess there isn't any safty concern to leave the van in the shop. Anyone here has 04 that the engine makes a ticking noise after warm-up?
  • subearusubearu Posts: 3,613
    Anyone here has 04 that the engine makes a ticking noise after warm-up?

     

    There is a TSB for the '02+ 3.0L V6 that addresses a ticking noise from the left bank of cylinders. Should be a warranty fix.

     

    -Brian
  • jdzjdz Posts: 1
    Obviously I couldn't get away from these famous problems. My 04 MPV LX has just 1k on it and I have hard shift from 2nd to 3rd and brake noise when backing up. I think I should bring the car in ASAP, and here's my question. Is there any recall kind of stuff I should ask to repair? Although I don't have any other problem yet.
  • subearusubearu Posts: 3,613
    According to mpvclub, both are TSB's.

     

    -Brian
  • jaserbjaserb Posts: 858
    Check for a sticker on the underside of the hood to see if it's been done, or ask your dealer about any open recalls. FWIW, my van has had both the shift shock and the brake noise. Hopefully these are both just teething problems with the '04 refresh and the van will settle down and behave from now on.

     

    -Jason
  • Manual calls for 5w20, but my local garage only does 5w30 or 10w30. Is it absolutely necessary to go the 5w20 route? I live in a warm climate - Florida.
  • What is the TSB number? I tried to look it up at the U.S. Gov website, but there was no TSB number 04-007/04; there were sixteen other TSB's, though.
  • subearusubearu Posts: 3,613
    Mazda has a TSB out that states 5w-30 is acceptable for use in the 3.0L requiring 5w-20. I found the TSB at mpvclub.

     

    -Brian
  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,893
    It's Tuesday, so it's time to join us for our Mazda chat hour. Hope to see you there tonight!

     

    PF Flyer

    Host

    Pickups & News & Views Message Boards


     

    NOTE: The MAZDA MANIA Chat is every Tuesday evening at 9PM ET(6PM PT) Check out the schedule

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

This discussion has been closed.