Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda MPV: Problems & Solutions

1205206208210211214

Comments

  • I don't know if this is your problem or not. But I had something similar on my '03 MPV. Turned out to be a cracked PVC pipe, which was on recall. We went to one dealer who didn't have time to help, and I called another dealer who recognized the problem right away and had it running back to normal.
  • I have been noticing a hot smell from the front passenger side of the engine. Sometimes it smells like sulfur. Around the time it first occurred a week or so ago, the check engine light came on and has stayed on. Could this be a PCV or some other component?
  • nlsnls Posts: 65
    It is definitely a sulfur smell, and not a burning smell? If you are in the snow belt, there is a possibility that your alternator could be going bad, but I don't think that it will trigger a CEL. Did you get the code read at AutoZone?
  • It was only a sulfur smell once. Last night after driving from Columbus to Cincinnati (100 miles) it was just a burning smell on the front passenger side under the hood: the alternator is down under on that side. Hmmmm. No, I have not had the code read at Auto Zone. Do you mean the parts store?
  • nlsnls Posts: 65
    Yes, the parts store - they read codes for free and tell you what it is, so that you will buy any needed parts there. Other shops will charge you a lot for doing the same thing. My alternator lasted for about six months after the first episode of very bad electrical burning smell, but CEL usually does not come on with an alternator problem - mostly the battery light.
  • Thanks, I will have the code read and see if I can narrow the problem down.
  • Hello - I just experienced a problem with my '01 MPV, idling low and behaving as if it were misfiring, when stopped in drive gear or in park. Seemed to be just fine once it came off of idle. Turned out that the air intake manifold gaskets were leaking badly. I had these replaced and it took care of the problem. Also improved power and my highway gas mileage increased 4-5 mpg. I bought the van used and always thought the mileage was terrible. This explains why. However, it took awhile until the condition deteriorated to the point that if affected engine performance at idle.
  • I have had my MPV to the dealership six times for a P300 code. The first trip they diagnosed it as an ignition coil problem. They replaced and it ran fine for two weeks and then happened again. Checked it out and said the part they put in was faulty. Kept for two days and drove okay for another two weeks and then same problem. Today the pulled back the carpet on the passenger side, exposing the computer and wiring harness and indicated that there was a crimped/loose wire. Taped it up and sent us on our way. 30 minutes later, same problem. Has anyone else had a wiring issue related to the ignition system? Should this be a hard problem to resolve since they have indicated that they know exactly which wire it is?? Lastly, I believe that their original repair was not required, that it has been the intermittent wiring issue all along, but they don't seem to be listening to the logic of this. Any ammunition that can be provided??
  • swampdswampd Posts: 1
    Hi, lamc -

    Have you had any luck with your starting problem? I've been experiencing the same problem for the past few weeks - and, of course, at THE most inconvenient times! Have had the 2000 MPV at the dealer, but again, of course, the van started right up for them every time...

    :mad:

    Thanks!

    Marsh
  • avgeekavgeek Posts: 1
    My used 2001 MPV has an odd problem - after a heavy rain, you can hear a "sloshing" noise coming from under the seat area (the interior of the car stayed dry, though). After some heavy rain, late this summer, the sloshing sound didn't stop for quite some time & now the entire van smells like mold & mildew! It is at its worst under the back-most/roll down seats (when you open the hatch, you want to hold your breath!).

    Has anybody else come across this/does anybody have ANY idea how to fix it.

    Thanks!
  • nlsnls Posts: 65
    The problem is supposedly due to the blockage of drain holes causing water to accumulate, but I don't know all the details.
  • nlsnls Posts: 65
    See posts 2525, 2523, 2443, 2439, 2260 and 2047. They might help you in tracking down the problem.
  • I have a 2000 MAZDA MPV with 72k miles on it. This vehicle has the exhaust manifold integrated with the converter, the 2 can't be bought separately. It actually has 2 manifold/converter pipes, one onthe left one on the right. The one on the right has developed a hole (NOT a crack) in the pipe, in a wend near where the gas leaves the engine. 2 questions:
    1) Would this part be eligible for the 8 yr/80k emissions warranty? The converter box looks fine but you obviously can't replace the manifold pipe without pulling the converter
    2) How do I approach the dealer on this?
  • my 89' mazda mpv has 212k i pushed on the throttle and it had no power when i put it in drive or in reverse please help
  • dtownfbdtownfb Posts: 2,915
    I'm confused with your problem. If you are stopped at a traffic light with the engine running, yes you must keep your foot on the brake or the car will move forward. This is typical of any automatic transmission. It sounds like you are taking the car out of gear (putting it into Park) each time you stop at light. So it takes you longer to move once the light is green, thus all the horn blowing behind you. No need to do that. Your car is operating jsut fine.
  • My 05 Mazda MPV with only 1200 miles is getting about 16 mpg (equal mix of highway & city driving). Is this normal? Also, dealer punctured a hole in the headliner while installing the roof rack. The new headliner has been on order for 2 months now. Is the dealer playing games with me? :mad:
  • jipsterjipster Posts: 5,345
    I don't know if they are playing games with you...but it sounds as if they are fairly incompetent. I could paddle a canoe to Japan, pick up that headliner, and be back in 2 months. May want to try another dealer if possible.

    19 mpg is the average combined city/hwy. See if you can get a highway only mpg(should be around 25mpg)...your city driving may be bringing it way down. Check tire pressure and driving habits(i.e slow starts and stops, no speeding etc)
    Engine may still be breaking in, so should improve some with another 3-4k. Have dealership check if still no improvement(when they get that headliner in)
  • Re your gas mileage. I bought a used 2001 MPV about a year ago and always believed the mileage was poor, but since I didn't buy it new, really didn't have a good reference. It would typically get 18-19MPG on the highway, sometimes 16MPG in the city. The problem was eventually diagnosed as leaking air intake manifold gaskets. Once these were replaced and the leaking was stopped, our highway mileage went jumped to almost 23MPG and the city is now about 20MPG. Keep in mind that the vehicle seemed to be driving normally otherwise, but we have also gained additional power with the system tightened up, as you can imagine. And, this vehicle had been to a dealership with other issues and no one "discovered" the leaking air intake, was not setting a code. It just deteriorated to the point that it began affecting my low idle, so I knew I had a problem of some sort.
  • criledocriledo Posts: 27
    Our 03 LX with under 40K miles has never brought more than 15 MPG, city or highway. Now that winter has cooled us off a little (Houston, TX) it's gotten a bit better, but nothing major. Will definatelly never get more than 260 miles to a full tank. I check tire pressure routinely, I use synthetic oil only. We've been through about five returns to dealers, they insist this is the normal mileage for an MPV. I've given up, looking at a Tahoe....... roomier, safer and believe it or not, much better mileage (16/22) than the MPV. :lemon: ???
  • HELP! Any advice would be appreciated.
    PROBLEM #1 - Our 2005 MPV has right sliding passenger door that will not shut automatically by itself. You know the problem, it doesn't sit flush and opens itself up. It's been in the Mazda shop (under warranty) four times and they can't seem to fix it. Any success stories out there on how Mazda fixed it?

    PROBLEM #2
    This is the one that has my wife freaked out. Periodically, the right side door will attempt to open by itself while on the road. Actually, you can hear the motor cycle through, but the built-in safety features prevent it from opening up on the road. Mazda claims they have never seen this or heard of it, but there is no denying it, the motor cycles when driving down the road, which tells me it is trying to open.

    I think the problems are related, but as you can imagine, the Mazda repairman can't seem to replicate the problem, or see it/hear it happening. ANY similar instances out there?
This discussion has been closed.