Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Avalon 2004 and earlier

1111112113114116

Comments

  • yes sir... I bought a used relay... it usually doesn't matter if its used.. its an electronic part..

    did you get a chance to purchase one?
  • I Just ordered one...hope it works for me as well....will keep you updated on the progress.

    ~A
  • Bad news harry...it didn't work me :(

    I got those 3 lights again today within 2 days of installing the relay.

    Should I try replacing the other ABS relay 88263-24030 ?

    Since you have the ABS circuit diagram, is there any other relay which needs to be replaced ?

    Please advise

    ~A
  • hey I am sorry to hear that.

    did you get a diagnosis done through technician?
    what were the codes.

    Codes which I got were c0273,c1246,c1301.

    I only changed one abs relay. that was the blue one right adjacent to the radiator.

    First thing first.. what were the codes that you got?

    Harry
  • Nope I ordered the part solely on basis of your experience.

    Where can I get the diagnosis done and how much do they charge ? Would a normal OBDII scanner read ABS codes and will codes only be returned when the ABS light is on ?

    Anyways I've asked the seller for the green ABS relay as replacement since the blue didn't work for me.

    ~A
  • try the green one too.

    Did you try resetting the computer after you installed the blue relay?

    Just take off the battery terminals and hook them back after 5 mins.

    Your computer will be reset.

    As you have already ordered the Green Relay too, try that after you install that.

    If in case the lights do not go off, go to a technician and get the diagnosis done.

    Sometimes the abs switch/sensor might go bad at one of the wheels. To corner the issue, Diagnosis is the first step. I thought you were through this step.

    Diagnosis costed me about 50-70 bucks. ABS code readers are different. Regular OBD code readers do not read the abs codes.

    Did you get any recent brake/wheel bearing job done?
  • Yes Harry...all this started within a month or 2 after I got all the 4 rotors replaced....I had no trouble till then.

    The lights are not on all the time for me...once in a while they come on when i crank the car and if I shut the engine off and start it again they are gone. Do you think they will leave an error code if they are not on all the time ?

    I haven't really sent out the blue relay for replacement yet and no I didnot reset the computer by disconnecting the battery...the lights didn't come immediately after I switched the blue relay but may after 2 or 3 days and they went immediately after I shut off the car and restarted it. Do you think I should put the ordered blue relay back and try disconnecting the battery once before I send it back for exchanging with the green one ?

    ~A
  • hi, in a way its hard to find out the error code when the lights are not constantly ON.

    i had hard time getting those codes as the lights weren't ON all the time.

    Well if you are sure that the lights came ON after the rotors were changed, then make sure that the technician/whoever changed the brakes haven't clipped off any ABS related wires/connectors.

    Get the error codes first... we can corner the issue later.
  • njavalonguynjavalonguy Posts: 35
    Hello Folks,

    The trunk release switch on the dash stopped working all of sudden after I did my last oil change where the battery of the car was also inspected for my 2000 XLS.

    The switch on the key fob is working though.

    I checked the trunk switch in the glove box too and that didn't have any effect.

    Any clues what else do I need to check ?

    ~A
  • clydekclydek Posts: 4
    This is in regard to my 1997 avalon which has been drifting to the left and right while turning corners. It feels like you are on ice and you want to react. I read all about the suspension issues, but mine became a simple fix. The bolts holding the steering rack to the frame were loose. Forget about torque values and just tighten them as much as possible.

    clydek
  • Anyone have torque specs for all the bolts when doing a brake job? Rotors & pads...
  • mikecraigmikecraig Posts: 12
    The torque for the caliper bolts is 79 ft-lb. The torque for the wheels is 76 ft-lb.
  • Thanks Mike.
  • ok, i presume that is for the caliper bracket, how about the caliper itself?
  • mikecraigmikecraig Posts: 12
    edited July 2011
    79 ft-lb is for the caliper. I don't know what you are calling the caliper bracket. Once the two caliper bolts are removed the caliper will lift off the rotor disk and the pads can eaisly be replaced.

    I just saw in the manual that front and rear calipers have different torques. The rear is 34 ft-lb.

    Send me your email address and I'll send you a copy of the shop manual mpcraigatexcitedotcom
  • Thanks mike - email sent.
  • mikecraigmikecraig Posts: 12
    So, it looks like the front caliper bolts are attached to the torque plate with 25 ft-lb and the torque plate is attached to the front axle hub (? I'm not sure my terminology is accurate concerning the axle hub.) with two bolts at 79 ft-lb.

    The rear brake is different. There are both a disk brake and drum brake. The drum brake being the emergency brake. The rear brake caliper assembly is bolted on at 34 ft-lb. The rear does not seem to have a torque plate like the front.
  • Thanks again mike.
  • how do you replace the passenger side fog light, I do not see a screw on the front?
  • duke72duke72 Posts: 1
    Antifreeze on passenger side floor diagnosed as needing heater core replaced. I had previously, in vain, been adding and adding antifreeze to bring to level. Now, one month after replacing heater core, I am stiil seeing antifreeze stains on driveway and wetness on car floor.
    Is this just, as the dealer says, just the old antifreeze still leaking out of firewall? I know the stuff eventually has to come out somewhere, but how long can this go on?
    I don't seem to be losing any antifreeze from the radiator.
  • 5539655396 Posts: 529
    Well, the firewall is metal, so that's not leaking. It could be saturated sound deadening insulation on the inside of the firewall, but that's a vertical surface, so it would drain down in no time. If it drains down, it would go into the carpet padding and puddle on the floor - and stay there unless the drain plugs were loose or have a hole in them. I doubt it. If you still need to add fluid, I would guess you still have a leak, a leaking head gasket or frost plug, or radiator/heater hose.

    At any rate, you can pull the carpet back to see if it is wet there. If dry, it would point you elsewhere. If wet, you need to get that sticky antifreeze out of there.

    I purchased a BMW Z3 that had a back window leak. The carpet was dry, but when I reached under the carpet , the backing was saturated. It was a molded carpet with areas of heavy foam to fill the floor voids. I removed an ice cream pail of water from each side and it took 3 weeks to dry it completely. Fortunately I caught it soon enough. No smell, rust or mold. Better look at yours.
  • my girl friend just got a Toyota Avalon and boy that car needs so much work to be done to it i don't know why it makes so much noise after reading your post now i know what to do and i think selling the car will be the options because its not worth fixing all those little things on it. it a used one a 2009 and for that year your not so pose to be putting in so much work. :mad:

    10 Tips On Buying From An Auto Auction
    http://10tipsonautoaction.blogspot.com/
  • I bought this car new in 2001 (200k miles now) and have kept it well maintained, even repainting it a couple of times. This Avalon is BY FAR best car I have ever owned, and since I am 71, that is saying something.

    A couple of months ago, something developed and I (and my mechanic) are seeking advice.

    There is a "groan" that seems to come from the passenger front of the car, maybe the wheel area but hard to tell. Details:

    1) It is a low groan, intermittent; it is rather subtle;

    2) It does not occur until the car starts rolling; it happens whether rolling in neutral or in gear;

    3) It occurs only then the car has been sitting awhile;

    4) When outside temperature is below roughly 40 degrees, it does not occur at all;

    5) After about a minute of rolling, it goes away entirely and does not return until the car has been sitting for a while, maybe 15 minutes;

    6) There are no noticeable performance issues.

    My mechanic at first thought it might be the new premium disks and calipers, but he has now ruled that out. Also, using a stethoscope, he hears nothing in the drive train (wheel bearings on up). He cannot duplicate it on a lift.

    Any thoughts?

    Thanks!
  • My 2000 Avalon XLS has an intermittent noise coming from the driver's side of the center console approximately 8 inches off the floor and just to the right of the gas pedal. The sound is something like grrrrr, grrrrr. It make no difference if the HVAC is on or off. I think it may be an HVAC servo hunting for its zero position and the noise comes from a turning shaft that needs lubrication; but that is just a guess.

    As I said above, the noise is intermittent, sometimes absent for days and then recurring. It is not terribly loud but still annoying. A friend suggested I just turn the radio on louder. Have any of you experienced and solved this problem?
  • I have the 2003 XLS (120K), essentially the same model as your car. As we all know the actual source of groans and rattles can be deceiving, and what you believe is coming from the passenger front of the vehicle may, in fact, be from somewhere else. One clue, which you have identified, is that the noise is temperature-dependent.

    The Avalon dash is a fairly complicated assembly of components. I drove for several months with a penny jammed between two panels in order to eliminate a similar groan. I eventually had to disassemble the dash to change out a failed instrument bulb, and upon reassembly the noise went away.

    In spite of your mechanic's evaluation I would not rule out a wheel bearing going bad. Hopefully not - the typical cost of a replacement is an astounding $400 with labor.
  • 5539655396 Posts: 529
    We had a 97 Camry that would groan under 40 degrees. Maybe with a parts swap one would be silent and the other groan all the time. Our 93 now has a loose rattle in the rear on rougher surfaces at slower speeds. Guess I have to crawl under there. I'm wondering if worn sway bar bushings would cause it. I hope it's not strut mounts. Anyone experienced that and found a solution?
  • In an abundance of caution, I think that I will go ahead and replace that wheel bearing and see what happens, AFTER I swap that wheel/new high end tire to the back to see if it might be related to that.

    Some years ago, a guy hit me. Hard. Much of the front was replaced, but not the wheels. I have had a suspicion for a while that I may have a damaged wheel. If the sound moves to the back when I rotate, I will have my answer.

    Thanks!
  • My 2001 XLS, although in excellent shape, has 216,000 miles on it. I have never had a breakdown. But I am wondering is anyone knows of a sensible routine for preventive repairs other than regular servicing? For example, is there an intelligent method based upon statistics, that it is wise at this mileage to replace item #1, then item #2, etc?

    Although I understand the rationale for "if it ain't broke don't fix it," that begs the issue that breakdowns are no fun.

    Any thoughts?

    Thanks,

    Dave
Sign In or Register to comment.