Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Millenia

1184185186187189

Comments

  • please email me how to do this procedure lol dannytidwelljr@aol.com

    danny
  • bbarons1bbarons1 Posts: 1
    Just wondering about this one, I know the code is for EGR valve, my friend took this off and soaked it in cleaner but the check engine light came back on shortly after being reset. The exhaust smells a little worse than other vehicles, does that mean it's most likely a catalytic converter? How many are even on this vehicle? The vehicle seems to run fine but would like to correct the problem if it's not too expensive.
    thanks.
  • I just purchased a 2001 Mazda Millenium V6. with 100,000 miles. It ran good when purchased. Last week I began hearing heavy tapping noise coming from motor when I started the car. When I excellerate the tapping noice would go away or quiet at times. Other times the tapping would get worse. It has got to a point I cannot drive the car because of fear I will do permanent damage to the motor. Has anyone experienced this problem or have an idea of the what the issue could be?
  • krumtxkrumtx Posts: 5
    the 0170/73 are common. you have a couple of vacuum leaks. there are 3 actual "tees" and a bunch of "Y"s that connect about 21 feet of vacuum line. one or more of the tees are broke, and air is coming in. easy fix, but you gotta take off the whole intake to get to them rascals. lotsa labor, lotsa stuff has to come off. btdt. we have 2 99s'. if you cannot do the work yourself, the car will eat your lunch. get rid of it.

    p0303 is misfire on #3 cyl. most likely the coil is bad. the rt bank(rear) coils get way more heat than the fronts. and #3 is the middle one back there. also, because of the intense labor to get to the plugs, lotsa places you take the car to will charge you for the plug change, but never do it, because it takes a couple hours to get to them suckers. when i do it, i make sure i got new plugs, and i take a known good set of coils and replace them. you can switch the coils from the back to the front, because the front ones will outlast the rears. and if someone says to switch #3 coil with another and see if the miss follows, has NEVER done this job on a 2.3.

    p0431 is your post cat 02 sensor telling you the cat is dying. that, along with 1173(heated o2 sensor, same bank) tells me somehow you fubar'd the cat. you need to take care of the fuel problem, because if fuel fubar'd the sensor and the cat, if you just put another one on, it will kill them, too
  • krumtxkrumtx Posts: 5
    what motor do you have? the 2.5 has hydraulic lifters, and if they are stuck, they will make a racket. also, if the timing belt tensioner is bad, it will make a sound very much like a bad lifter, and the sound goes away when the motor is revved. the 2.3 has solid lash adjusters, so if they were bad, you would have noise all the time. however, the tensioner can make a lifter noise on the 2.3, too. if the knock is coming from deep inside the motor, you got BIIIIG problems
  • krumtxkrumtx Posts: 5
    most common is the motor is gummed up. you can take it out and clean it. next is the relay, it can go bad. to remove the motor, you pull the lower panel under the turn signal switch. you can then see the motor. it is held in by 4 screws, but 2 of them are covered by the panel right next to the one removed. i make 2 holes in the panel to access the screws, pull the motor, take it apart, clean, regrease, reinstall, and hope
  • I HAVE JUST REPLACED THE TIMING BELT ON MY 1998 mazda millenia. AND NOW AM HAVING TROUBLE GETTING IT TO START.. WHERE CAN I LOCATE THE DIAGRAM FOR THE TIMING MARKS TO MAKE SURE I HAVE IT TIMED CORRECTLY ?
  • JUST GOT A 2002 MILLENIA P. WHEN I DRIVE OVER A BUMPY ROAD THE CAR SWERVES AND I ALSO NOTICE A HUMMING SOUND(HOHOHOHO) THAT SEEMS TO GO WITH THE TYRE CYCLE FROM ABOUT 35MPH AND IT SOUNDS FASTER AS THE SPEED INCREASES, IT FEELS LIKE IT COMES FROM THE REAR WHEELS BUT SOMETIMES IT FEELS LIKE THE FRONT WHEELS. PLS HELP
  • Almost a year ago I posted about a grinding noise when I started my Millenia S.
    Had starter, flywheel, another starter, installed by my local mechanics. Finally,
    I talked with a Mazda mechanic and he said that he would recommend an OE Mazda starter. I did, and the problem seems to be fixed.
    I also get only OE Mazda brake pads since they do not shed an excessive amount of brake dust.
  • See my recent post about my starter problem being solved. About the flywheel,
    I had mine replaced (there were several teeth broken off) at a local, reputable,
    transmission shop.(Not AAMCO) Cost: $600. A dealer will charge in the range of $1700.
  • 2002 mazda millenia 2.5L base model got loud engine noise after start up or idling. the noise seems to almost dissappear or much less noticable when rpm above 2000rpm. Check engine light on with code 0300, 0350 and 0421. Changed all spark plugs recently. The local mechanics told me the noise seems from inside timing belt cover, front of oil pan, rear upper valve train and water pump. I read one post said bad timing belt tensioner could cause engine noise/knocking. Timing belt never replaced on this car. Can anyone kindly provide the advice or similar experience? Many thanks.
  • It seems I get the similar problems (post 4007). I just wonder if you have found the causes. Thanks.
  • Hello all.

    I have a 2002 P and the dealer and oil change shop have both told me that I have a leaking valve cover gasket. I guess this is the reason that I smell a burning smell after I drive for awhile. Is this a serious problem that needs immediate attention? Also, is this a difficult and expensive repair? Please note that I also need to replace my EGR valve(??) and would like to know if this is costly.

    Thanks!
  • gregg_vwgregg_vw Posts: 2,419
    You have the 2.5, so neither repair should be too pricey. Shop around if you don't already have a regular mechanic.
  • I just got a 165000 Miles Millenia 2001.I took it to Auto for diagnose and the engine reads the below codes. Can a knowledgeable one give me some advices.
    P1743
    P0750
    P0755

    The Engine runs fine expect the
  • I had this same noise and eventually timing belt sliped and engine died after replacing tensioner and new belt ran great.
  • Did you ever figure out what caused the tcs lights to come on and the car jerking? I am having the same problem. Brought it to a mechanic (not dealer) after $1500. He gave up and told me to go to the dealer. This is driving me crazy. I have to put the car in neutral and restart while driving. :cry: any help is greatly appreciated.
  • ristyristy Posts: 2
    I have the s type millenia 2002 model with 138000 miles on it, my problem is that the hand brake indicator and abs lights are on (got it this way!) and the TCS and TCS OFF lights are also on permanently, my cel is also on, any ideas?
    Pls any do-it-yourself approach will be appreciated....Thanks!
  • ristyristy Posts: 2
    I have the S type millenia 2002 model with 138k plus miles on it, could someone kindly tell me where the fuel filter and fuel pump is located. Thanks!
    Prompt responses will be highly appreciated as i need to check its present state ASAP.
  • 2002 MILLENIA 100K SMOKES AT START UP. NEED ENGINE OVERHAUL? HOW MUCH?
Sign In or Register to comment.