Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Kia Optima 2006 and earlier

12324252628

Comments

  • skalskal Posts: 5
    I have a 2003 Optima and I just put new plugs in it. I have about 90,000 miles on it and my plugs were almost completely gone it had started idling rough. With the new plugs it runs like new. I would try just the plugs first before the wires. I ordered my plugs from Kia and they are $15.00 each, but the parts guy said that if you just buy them at a parts place they don't work as well (they could just ge lying too). The plugs are not difficult to change you just have to take the cover off the top of the motor and they are down deep towards the engine. You will need a plug socket that has the rubber insert so you can pull them and and put them back in, it take a 13/16 socket for the plugs. I would buy them from the parts place and just try them before I tried to buy the Kia plugs. Hope this helps. This is the number for parts: 800-996-9491 I spoke with Danny and his was very helpful.
  • skalskal Posts: 5
    2003 Optima I have solved the problem to filling the gas tank. You will need to change the charcoal canister filter located in the finder well behind where you fill the tank. When the filter goes bad it releases the tiny pieces of charcoal and it get stuck in the filler valve located on top of the fuel tank. So to correct the problem you have to replace both items. You can change the filter it is just in a plastic cover, but the filler valve is on top of the gas tank. If you let down your back seat and look in the middle you will find a black cover that is covering the fuel pump. To the right of that is a small valve and next to that one is the filler valve. I decided that is was not worth $900.00 dollar to drop the tank so I took sheet metal cutter and cut an hole over the filler valve big enought to get it out and replaced it. It takes a little effort, but it works. I ordered the filter and valve from Kia the filter is $180.00 and the valve is $30.00 the number is 800-996-9491 it takes both of them to correct the problem. Anyone that has any mechanical experience should be able to do this. Good luck I hope this help.
  • Thanks for replying~

    I did have the mechanic replace the plugs, the back 3 were completely shot. But this morning it did the same thing again. It seems so far like it happens after sitting for about 8 hours or more. Once it "turns over" and starts, you can turn it off and then turn it back on and it will start right up. Not sure what it could be, could it be a bad battery? Seems like once it runs for alittle while it will start up with no problems.
  • skalskal Posts: 5
    I had to replace my battery but it just quit I didn't have any trouble before hand. You can have your battery checks to see if it is weak. It should have a sticker on it telling when it was purchased. They usually only last about 4 years. Have you check the gas filter. It sounds like you have to get the car to turn over before you are getting the gas for it to start. I would think if it was the wiring it would be constant. I am sending you a web site to go to that gives you the maintenance manuel on your car. I was going to buy the book but they were out so she gave me the web site to look up things. It is not very user friendly, but it does give you some good ideas if you are persistent. It has one place that will let you trouble shoot your problem and it will give you options as to what the problem might be. Good luck let me know if you figure it out in case I might have the same problem. Web site www.kiatechinfo.com.
  • capt4capt4 Posts: 32
    I had the same issue happen last week
    The car stalled in traffic , Thinking there was water in the tank
    I bought some gas line anti freeze.

    Then the car refused to start could not crank over
    Check engnie light goes on this is good so you can find the problem

    Towed the car to the repair shop the computer showed " Crankshaft Sensor"
    Kia Service says this is a usual at around 80k miles as well as the Front
    Motor Mount which had to be replaced also..... Check around for labor the
    cost to replace sensor is the same as timing belt because the genious" at Kia
    put it in the most inconvienent place. If you need a Timing belt do it at the same time. plugs were changed at 75K they last long
    I am going on 92K never did the fuel filter, it is another weird location with
    labor that is high,

    Hope this helps :sick: :surprise:
  • I took my car into Wal-mart to get the battery checked, when they hooked up the battery checker it said to replace battery, so I did that and they thought that that might just be the problem. But after they put in the new battery and did another battery check, the handheld computer gave them an error message that they thought had something to do with the wiring from the battery to the starter. They think that a wire somewhere there is getting grounded or is bad. They also checked the starter with the same handheld computer and the starter checked out fine. I'm taking it to the dealership beginning of next week to explain to them what has been happening and what has been done so far to the car, hopefully I will get this figured out with not alot of money involved the the process, I only have about $500 to spend to get this fixed.
  • clean the maf, mass air flow sensor, you have to use special cleaner for this, buy it at parts store, do not use carb cleaner, i just checked the maf on a 05 ford focus, hard to get to by the way, a small piece of a leaf was causing hard starting etc, also use throttle body cleaner on the throttle body, very important
  • capt4capt4 Posts: 32
    :) Thanks for the tip will do

    Ihave cleaned the Throttle Body with BG products bebfore
    How many miles should this be done?
  • my mechanic has replaced the crank sensor 3 times and it blows out within 10minutes each time...and everytime the check engine light pops up calling for the crank sensor...could it be the computer and where is the computer located at?? i am tired of spending money on this, please someone give me some great advise, i would really appreciate it!!
  • capt4capt4 Posts: 32
    The most experienced folks I know are in Fredericksburg VA
    Call to the service manager, Lee. they have techs who know the
    product and you will not get burned if you use the service dept.

    Like many other manufacturers, Not all Kia service is quality
    Richard at Fredericksburg runs tight ship and his techs are top shelf.
    Tommy is a Master ASE Technician with 16 years experience

    I also had the crankshaft sensor recently replace by an outside shop.
    They not only replace the sensor, but when I went to pick up the car
    it was vibrating beyond control. I was told I needed motors mounts.

    Replace the front and told I needed three more
    Thanks to the folks at Fredericksburg Kia they re did the
    timing belt and lined up the belt and so that the balance shaft ( real cause of
    vibration was back in sync)

    It pays to go to Kia most folks cannot fathom these are Mitsubishi
    engines that have been on the market for years. This is a huge shout out to the
    folks at Frederickburg :) Kia
  • capt4capt4 Posts: 32
    Anybody in this forum having trouble with the door locks

    There are a host of complaints going to the NHTSA site
    and it seems the acuators are not good on most Kia's

    Maybe its a re call item the doors locking is really dangerous.
    I hope Kia recongnizes this issue and does the correct thing
  • have a 2003 optima lx.2.7l v-6.all the sudden it is hard to start after sitting for more than 5minutes.It's my wife's daily driver.I thought maybe she got bad gas so I changed the fuel filter,and the pump while I was in the gas tank.Got no result to problem.I also changed the crank sensor because a mechanic said the harness on the sensor could be dry rotted.he was correct but still have same problem!The worst part is that the computer will not show any codes!strange!Any help would be great!thanks :confuse:
  • My 2004 Kia Optima LX V6 has had the recent problem of shutting off after I pump gas and most recently when I turned on the air conditioner.

    Problem #1
    Okay, I fill up then I start the car and nothing happens, it doesn't turn on. I do it again only this time I'm pushing the gas. VEROOOOM it's on! Then, foot off the gas pedal and the car shakes off. The only way to get through this problem is if i keep pushing the gas until you almost feel it not shake and it stays above one.
    This happened in december 2009 once before going home for the holidays. Once I was home, the rest of december it did not happen as dramatically. It would stubble but it would turn on. Now that I"m back from the holiday my car had it's dramatic scene again just like the first time. Help?!?

    Problem #2
    I did not use the A/C during the winter break. Why would I? However, I did use the heater and it worked perfect. Now Jan 2010, It got hot so i turned on the A/C and the car did exactly what it did at the gas station only this time it shook off while on and then gave me the trying to turn on problem.

    What could this be?
    What do i need?
    Where should i take it?

    I routinely get an oil change for specifically high mileage (Castrol) BUT i've never said yes when Wal Mart asks if i want to change out my air filter.
  • My daughter has an 03 Optima that the driver side door lock stopped working intermittently until if failled completely and had to be replaced.

    I have an 04 Optima and my driver door lock is beginning to fail. It has stopped locking/unlocking all the other doors, locks automatically when bumped or door shuts, etc.

    Eventually, I will buy a new mechanism and replace this one myself.
  • capt4capt4 Posts: 32
    This seems to happen to many of the 03 and 04 Optimas as well as seat belts that
    do not recoil back. It should be reported to the National Transportation Safety Board. If a lock does not work properly and you are in an accident this is a very
    serious safety issue
    I hope the people who are on this board and blog report this to the dealers and
    the government safety agency. You will also find left rear tail lamp bulbs burn out far to often on the 03/04's There are also many crankshaft sensors going bad on all Kia's 03/04 from low to higher miles. The lower mileage cars, are of course, warranteed.

    All in all the Kias are decent cars for the money. But the dealers are not as
    good as the cars. Find a reput
  • capt4capt4 Posts: 32
    " cont"

    A Reputable dealer of service center who knows the cars
    The 03 /04 seems to have the Mitsubishi engines in them
  • I was told this is a wiring problem and they can replace the wiring for 325 a headlight but it is the same wiring and it may go out again. That is what I was told.
  • Recently got an '01 Kia Optima V6, charge lite came on while driving, after a look under the hood, all connections seem to be good, battery is only 18 months old, BUT alternator has a heavy coating of power steering fluid on it, indicating a leak nearby. How hard, and how long should a alternator take to change, and how much should a used one cost, VS new? PS leak hopefully will be fixed before this repair is done, or at same time, assuming it too is not too costly or hard. OR, is this or both an item a shop should do? Thanks for any help offered. Jackson
  • Troops
    I have a 04 Magentis(optima in the us) EX with the 2.7 V-6 & 60,000 miles. The A/C blows ice cold air but when i am at a stop in gear at idle the car shakes badly & rpm,s fluctuate. If I turn off the A/C or out the car in drive or nuetral the idle smooths right out.
    Any ideas???
  • analyzerlxanalyzerlx Posts: 23
    My Optima has about 145,000 miles and I was told by an electric shop that the alternators on our optima was built very well, I asked about it when I went through the first and only service done on the car (except for oil changes 7500-10000+ miles) at 130000 miles. I changed out the timing belt, water pump and thermostat. Oh, at 75000 i changed out the struts, great car so far. Had the car lock receiver fixed under warranty and the only other issue is the driver door has to be manually unlocked with a key? I had the car tinted last year and noticed the defogger/deicer doesn't work, but the a/c defogs the car fairly quickly.
Sign In or Register to comment.