Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Kia Optima 2006 and earlier

1232425262729»

Comments

  • analyzerlxanalyzerlx Posts: 23
    take it to a shop, maybe the belt is slipping or the compressor is the problem, could be anything!
  • cmorgan11cmorgan11 Posts: 1
    My mom bought my car brand new, never used, in 2004. It was great up until about a year ago. When the problems first started my lights would stay on after the car was turned off (keys were out of ignition, doors locked and no one inside the car). Also, there was a buzzing noise coming from the little breaker box inside the car. We took it to a mechanic in town and they had it for two weeks and couldn't figure out what was wrong. They stopped the buzzing noise, thank god. It drove us up the wall & it would give you a headache. All they knew was something was making the lights stay on and a continuous cycle was running my battery down. Drained 2 new batteries! They called it the possessed KIA...lol. that was quite funny to us, and told us that if we take it to the dealer and found out what it was to please come by and tell them what was wrong just encase they had another possessed KIA come up there for help. After the two batteries being drained my dad made me start unhooking the battery cable if its parked for over an hour. My power door lock don't work, I have to lock all doors manually. My power windows don't work. However, my sunroof does. (: So when I go to school, you best believe that you would see me pull up and then pop my hood to unhook it. We don't want anybody to run into the back of me now do we at night, so there's something for that too... When I have to drive at night, I have to pop the hood and put the fuse in that controls the running lights. & when I park, have to take it out also. We haven't had the money to put it in the KIA shop because we all know they will charge out the behind! I was just wondering if anyone else had the same problems. Which most likely I know it would be hard to find someone with the same exact problems. My best friends boyfriend has also gave my car the nickname of "can't get right" from the movie Life. lol Who knew such a problem would bring us so many laughs. Other than all this, I love my can't get right, and I will drive it anywhere it enables me to do so. I still love my KIA!
  • I recently wrecked my 2005 LX V6 optima with just under 100k on it, but here are some experiences I would like to share.

    Affter years of continual check engine lights (with seemingly no stimulus) coming on once a quarter and the Kia service department insulting me by telling me I can't put on a gas cap correctly, Midas (no affiliation) told me it was a problem with my canister. After it was replaced, I never had a check engine light issue again.

    In addition, with rpm issues: I had several issues with the rpms going crazy and the car bucking including when coming to a stop. Kia told me that it was because the gear shift line was ran over the engine, and if it was too tight and the car approached a hill it would respond as if the car was shifting. That worked for a little while but then the issue increaded. Kia thought I was crazy. One day the car stalled and wouldn't move, so I towed it to a mechanic who replaced the engine coil. This happened a total of 3 times. Each time it helped for a while, but then eventually failed after about a year and a half. This also meant replacing saturated spark plugs and wiring, so not a cheap trip.

    I hope this helps anyone who may be having issues out there. ;)
  • capt4capt4 Posts: 32
    Okay
    I too also just recently lost my KIA due to a driver who decided to step on her brakes.
    instead of the gas into a merge lane. So be it, the Airbags released and the 2004 EX
    was not worth the repair. So I immediately set out to get a new KIA and found a 2009
    leftover zero miles.

    They are safe, they are great, you need to do the service as with other autos
    and do not let anyone tell you the value sucks. After 106K miles and a very clean car
    I recovered more than 50% of what I paid new..... Suck that up Lexus and Mercedes

    :)
  • Talk about irony, I lost mine the same exact way.
  • Hi,

    The driver side door ajar sensor surrounded by a small rubber cap (wrinkled cone shape) on the body frame is not working.

    So the warning signal on the instrument panel, the indoor lights on the ceiling and the reading lights (when in "Door" position), and the door light are not turned on, when the driver door is open.

    Would you please let me know the replacement part and how to fix it by myself?

    Thanks in advance.
  • Did you ever recieve an answer to your problem? I am currently experiencing the same issues only I am not using my AC or my Heater.
  • My son's 2003 4 cylinder kia has been to 4 sops for this problem. It begins to lose power and runs rough like only 2 cylinders are firing . It will run for a while then quit. you can let it sit and it will start back up in the 2 cylinder condition and run for 10 minutes and quit again. the computer has been replaced and 3 shops have fixed it only to have it return to rough running then quit. it is at a different shop and has been to the kia shop . no luck has 73000 miles on it. Help
  • geobluegeoblue Posts: 71
    Hello,

    We have a 2006 Kia Optima at around 68K miles. I am thinking of at least having a drain&refill for the transmission fluid.

    Kia, like Hyundai specifies SPIII ATF. Is that a must? Redline claims its D4 ATF can be used where SPIII is required.

    Has anyone had experiences with Redline D4 or any other ATF on the one hand and with SPIII on the other?

    Should I just have a drain&refill done or should I get a flush?
  • jim451jim451 Posts: 2
    I have an '03 and an '04 that had the same problem - its the fuel rail pressure regulator. Get it replaced. Mechanic did the first car for about 130.00 and I did the second one for the cost of the part - less than 30.00. it's easy.
  • I have 159,000 miles and so far I had to replace the battery at 5 years, replaced the timing belt and water pump at 130,000 miles. I looked at the belt and it was still in really good condition. At 75,000 miles I did put on 4 new struts. At about 140,000 miles I did change out the rotors front and back. Also had to replace the driver window regulator for about $200. I have noticed that the deicer doesn't work in the back window, but if it is foggy the front defogger tends to clear the back in minutes. I did get the key fob receiver fixed under warranty a long time ago, but now the only remaining key fob went out, may be the battery? Either way, just towed a medium sized Uhaul trailer from Las Vegas to Boston, then down to Western NC and back up to MA! Excellent value for what I paid for the car back in 2004. I recently out new tires on the car and it passed the struts diagnostic. Love this car and since it is paid off is even that much better!
  • dan_99503dan_99503 Posts: 1
    Hi,

    I have a 2003 KIA OPTIMA (101K miles) that ran very well and recently had it stop running on the road. It just stopped running, no noise or anything else. It was towed to the shop and they said the crankshaft sensor wasn't working. I had then replace the sensor and the timing belt at the same time.

    I got the car back and within 15 miles I was driving @ 65Mph and it started lurching violently back and forth. I thought that maybe the timing belt had a problem and pulled over and had the car towed to the shop again.

    Then they informed me that they used a used crankshaft sensor and they believe it quit working. They were able to start the car and drive it in their shop. They ordered a new one, three days later I pick up the car. They said that the crankshaft sensor was replaced then the car would start but it would die immediately afterward. They said the mass air flow sensor was bad and had to be replaced ($238).

    The car has vibration problems that weren't there before the initial repair and runs rougher as well. Even at idle there is vibration and when you rev it up it gets worse. After driving it 5 miles the check engine light came on.

    I'm planning on going back tomorrow and seeing what they say.

    I had a couple of questions:
    1. The crankshaft sensor obviously quit working and caused the car to stop violently the second time. Could that stop have caused any damage to the engine (valves?) or possibly the mass air flow sensor? It's just strange that it quit working at the same time, when it had been running to pull it into the shop.
    2. Considering they only worked on the sensor, timing belt, and MAFS what would be the likely culprits for causing the new vibrations?

    We had to cover 3 days rental car and an additional towing do to the second repair. The wife would just like to dump the car and move on do to it now running "completely different".

    Thanks in advance for your answer,

    Best,

    - Dan
  • gbrehenygbreheny Posts: 1
    I am having the exact same problem you are having with my 2002 kia optima. It started as a bad timing belt tensioner at 99,000 which led to the the timing belt to be replaced and the crank shaft shaft sensor. They then found a intermittant short in the extension wire that goes to the crank shaft sensor to the plug-in module. Then they changed the mass flow, tps sensor and plugs which it ran okay for about 400 miles but this morning the vibrations are back so its back to the auto shop. If they finally fixed yours please post
  • I had the same exact problem on my 2005 kia optima. This problem happened a year ago. The car stalled without any noise on the highway. I got the crankshaft sensor and the timing belt replaced. I got the new parts myself and got it installed by a mechanic. So far it has been working good.
  • geobluegeoblue Posts: 71
    Hello,

    Today on the freeway my wife's 2006 (early model) Kia Optima had a vibration, fluctuating RPM and then it stalled.When it stalled we saw al lights on the instrument panel light up. No check engine light stayed after staring it again.We drove for a few minutes and it died again.

    I opened the hood on the safety lane and checked the battery poles and belts.I could not see anything out of the ordinary. But my wife said a day before a bird flew in front of the car's grille and she found the bird's skeleton at the driveway that evening.

    We drove the car home without problem. 15 minutes or so. No check engine light.

    What could be the problem?

    :confuse: I am using Mobil 1 Extended Performance oil for almost 8,000 miles now. With synthetic oil my usual oil change interval is 7-8,000 miles usually.
  • Probably too little too late for your car.
    My 2002 Optima was shaking violently when at a stop in drive. It started about 66000. When I would go into the dealer for an oil change, I would mention it. He would give me answers like try a different gas. Next time he would say, "Oh, dont use Sams Club gas." Turns out he was trying to prolong it past my extended warranty of 75000, so he did not have to pay to fix the real problem which was all motor mounts were cracked. The shaking got progressively worse as each mount failed until a friend told me to change the mounts. By then, the damage was done. Violent shaking caused cracked refrigerant line, plus others. Cost $1800 total to fix.
    Maybe this may help someone.
Sign In or Register to comment.