Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Stratus

13468916

Comments

  • silveraesilverae Posts: 3
    Do the 2003 versions of the Stratus (either Sedan or Coupe) come with side airbags?
  • lngtonge18lngtonge18 Posts: 2,228
    They were offered as an option.
  • fisherfisher Posts: 1
    I am thinking of purchasing a 04' Stratus SE. Has anyone experienced any problems with theirs?
  • Hey everyone! I have a 2004 Dodge Stratus SXT sedan with 5700 miles on it. When the car is in gear with the brake applied, I hear a creaking noise from the front whenever I turn the steering wheel either to the left or right. If the car is in park WITHOUT the brake applied and I turn the wheel I hear nothing. I bought it with 4700 miles on it and it has been doing it ever since. I always hear it when I'm braking and turning into a driveway. I took it to the dealer and they said the noise was normal. Any info/help on this topic would be greatly appreciated. Thanks!
  • pfoskettpfoskett Posts: 1
    Can anyone help me? I have recently noticed that my two front tires are always dirty with a rust-like color on the hub caps. It seems like I remember that this indicates a problem with either the brakes or wheels, but I just had the brakes replaced less than a year ago. Right after I had them replaced, I started hearing a high-pitched noise that sounded like it came from my front tires. When I took it in, the guy at the shop just said that some tires do that on certain roads. It comes and goes. I'm about to make a big trip and don't know whether I should have this looked at or not. Can anyone help me?
  • a_l_hubcapsa_l_hubcaps Posts: 518
    pfoskett-

    If the dirt is black and can be rubbed off with your finger, it's normal; don't worry about it. If it is orange-colored, gritty and very hard to remove, you definitely have a brake problem of some kind. Good luck.

    -Andrew L
  • tomk17tomk17 Posts: 135
    I have an 01 Stratus (not ES but 16" wheels) with a strange vibration problem. Any comments would be appreciated. At highway speed, the car will be smooth then a chassis vibration will start and get worse in intensity. I have to stop the car fully, then proceed and things are typically OK. The problem has been getting worse and is at a lower level now almost constantly. It's not the tires / wheels! It did it with snow tires, older summer tires, and now with new tires. It's not a steering wheel vibration leading me to think it's not in the front end. Plus, I also had the front end fully checked out and no problem found. If it means anything, I shifted into neutral once when the problem happend on the highway at 60mph. That did not make the problem go away.
  • poppiepoppie Posts: 9
    Hello,

    I just had my oil changed on my 99 Stratus and the guy who did it told me that I had a very small crack in in one of the seals. I just wanted to know if anyone else have had this problem, and about how much would it cost to get fixed.

    Also my AC blows out hot air and I wanted to what could be the problem and around how much would it cost to get fixed.

    Thanks to all replys.
  • joe3891joe3891 Posts: 759
    of a 99 Stratus that had a head gasket leaking oil, cost $800 to repair.
  • poppiepoppie Posts: 9
    800? jeeez.

    So would this be a head gasket problem?

    I hope not.
  • joe3891joe3891 Posts: 759
    Hey i'm just telling you what I about 99 Stratus oil leaks, do a google search and then you will know what i'm talking about. The $800 was done at the dealer, the timing belt was also replaced. An experienced Stratus tech will tell you in a minute whats leaking , good luck.
  • erehwon2erehwon2 Posts: 1
    Hello,
    I've been looking into buying a 04 stratus R/T. I've done a price search on Edmunds and came up with a TMV price of $22,449. I've already received quotes from two dealers of 18,500 and 20,500 for identically equipped cars. How is it that the prices are so different and so much lower (nearly $4000) than the TMV suggested by Edmunds?
    Thanks.
  • itshemiitshemi Posts: 32
    Has anyone had any problems with suspension noise on this model, I its Limited Edition 4DR R/T, lot of ES, SE and 2Dr RT Coupes.

    Also, the 17" wheels need a lot of attention due the Brake dust and seem to attract rust.
  • lngtonge18lngtonge18 Posts: 2,228
    TMV price doesn't include any rebates. See what kind of rebates are being offered. I'm sure the prices you are being quoted include all rebates.
  • poppiepoppie Posts: 9
    Recently someone broke into my car and stole my radio out of it. The person who did it cut my wires and later on that day the power locks, power side view mirrors, and dome light stopped working. I have had the fuses checked and they check out ok.

    Any suggestions on what could be the problem. I intially thought the the guys who replaced the window had did something wrong but they took the door off and showed me that everything was hooked back up. I have had the radio replaced but they cannot find anything wrong either.

    Any help would be greatly appreciated.

    Also, while I am speaking about my car, when I am sitting still with my ac on the car starts to overheat. Could someone tell what may be the problem with this also.

    Thanks.
  • lngtonge18lngtonge18 Posts: 2,228
    Check to make sure both radiator fans are running when the AC is on. If either one of them isn't on when the AC is on, that can lead to overheating while the car is at idle. Another possibility is the water pump may be on its way out. The water pump could be weak and can't pump the water fast enough at idle.

    I don't know what to tell you about the power lock problem. It has to be either in the wiring that was cut behind the radio or in the door panel when the window was replaced. Good luck.
  • poppiepoppie Posts: 9
    Thanks for the reply. I have another question.

    I took the car to the shop to see if it was the water pump or the radiator fan and I was told that the radiator fan was working so I would probably need a new water pump and timing belt. The mechanic asked me if the car was leaking any antifreeze and it was not at the time. That was three days ago and today the car started leaking antifreeze.

     Is this because of the waterpump not working or is the water pump okay and this a whole different problem. If so, the leak would be causing the car to overheat correct?

    Do you know about how much it would cost to get the leak fixed at a shop and are there any leak sealants that I could use for the time being.

    Thanks.
  • lngtonge18lngtonge18 Posts: 2,228
    Leaks can come from anywhere but the overheating and now the leaking points to a failing/leaking water pump as a likely culprit, although you could have a leaking hose or a bad head gasket (certain Chrysler engines have common head gasket problems; which engine and year is your Stratus?). Water pumps have a weep hole at the bottom. As they get old, the seal cracks or fails completely and water leaks from that hole, alerting you to a failing pump. It usually starts as a drip and then becomes a bad water leak. I highly suggest not to put any kind of sealants in your water system. It should only be used in an extreme emergency as it gums up the entire system and can lead to other troubles later on. Take your car to a shop and have them inspect it and figure out where the leak is coming from. In the meantime, keep a close eye on your water level. Don't burn you motor up!
  • sesses Posts: 1
    Regards from Sweden!
    I am thinkng about a 1997 4 cylinder Stratus. I don't know yet if it's the 2.4 or not. I was wondering about the recalls on the headgasket and the balljoints.
    Will Chrysler pay for the recall work if it has not been done yet even if I am not the original owner? How does that work. The car has 77,000 kilometers or around 45,000 miles. The price for it here in Sweden is 8600 usd.
    A Volvo 850 or Toyota Camry from the same year and mileage is around 11,300 usd.

    Just for fun, you can see what the used car market is like here in Sweden by going to http://www.bytbil.com and looking around. When it says 7,000 mil, that's Swedish miles and what it really means is 70,000 kilometers. If you want to see what the prices are in uas, you divide the price in Swedish kronor by 7.5 to get the dollar price.
  • gamigami Posts: 4
    I just drained the manual transmission of my 2001 model 2.0-4 cylinder Stratus but could not find the fill port. The Haynes Repair Manual is of no help. Can someone lead me to find the fill port? Really appreciate the help.
  • zinnzinn Posts: 4
    i just bought a pre owned 2004 stratus with 23000 miles. the engine knocks, there is a whirring noise heard loudest at 55 mph. the car makes a popping noise when starting off from zero.

    have you had any similar complaints. the dealership is telling me the whirring noise is normal and heard on all 2004 stratus models.
  • empty2empty2 Posts: 1
    has someone done it,
    is it possible ,
    links would be appreciated
    would love to have my 2.4 standard......
    then some boost....hum srt4 territory
    smell burned rubber allready
    who has donne it
  • sdavriasdavria Posts: 1
    Today, out of the blue, my transmission goes right into second gear and the check engine light goes on. The speedometer is not working as well. After the closest place takes a look, they tell me I need to go to the Dodge Dealer tomorrow and turn in a form that states:

    CompterCK
    Scanned computer codes: P0500, P0700, P0731, P1790. Datastream was eratic, checked connections & Grounds, no problems found. Recommended new TCM.

    I didn't have time to ask too many questions but he says it'll run $250 on parts. What am I looking at here and is the estimate close? Is the dealer the best place to go. I've had very little problems with the car in the past four years.

    Thanks
  • I have the same noise on my 04 Stratus SXT. It sounds like a metal cable vibrating against another piece of metal. The noise only happens between 60-65 though. I have had the transmission replaced just to get rid of this noise and it still didn't help. Anybody have any ideas???
  • I, too, have had that creaking noise. The dealership relplaced the shocks and all the rubber parts of the suspension on the drivers side in the front and it still didn't fix it. Then they replaced the left tie rod and the noise went away for the most part but not totally. I still kind of hear it sometimes. Hope this helps...
  • mirde98mirde98 Posts: 95
    My friend is considering a 05' Dodge Stratus Coupe 2.4L 5 speed man trans. I know is basically a Mitsubishi Eclipse with a longer body. My experiences with Mitsubishis are always been positive but if anyone knows abouth this cars i'd apreciate the help. Do they get rebates too?
  • sigmamansigmaman Posts: 7
    Hello....I own a 2004 dodge stratus 2.7 V6 which currently has 22,000 miles on it. Every now and then when I am in stop and go traffic and I stop, my engine will cut off and the oil pressure light will come on. I use 5w- 30 motor oil. I'm guessing that 5w-30 oil doesn't have enough viscosity therefore the oil pressure light comes on. Should I switch to 10w-30 to eliminate this problem? Also....what is the deal with that creaking sound when i apply my brake and i turn the wheel when i am about to park?????? What should I do???
  • lngtonge18lngtonge18 Posts: 2,228
    I don't think you should be worrying about the oil pressure light. You need to look into why the engine is cutting off. And the oil viscosity has nothing to do with that. You have some other problem going on here.
  • bstrobstro Posts: 1
    I have a 2004 Dodge Stratus with approx 34K miles. The problem I have is that when it gets hot outside (above 90 deg. F.) the check engine light comes on. There is no indication that the engine is overheating because the thermostat reads normal. Even after the car has sat for awhile and cooled off, when restarted, the check engine light remains lit until driven for approx. 15 minutes, then it goes out.
    The last time the light came on I noticed power loss and hesitation when taking off after a red light.
    Anyone have ideas on what might be causing this problem???
13468916
Sign In or Register to comment.