Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Colorado and GMC Canyon ABS Fault Issues

2456719

Comments

  • lvfranklvfrank Posts: 7
    The Mechanic has reset the computer codes grom the diagnostic plug in. Again, if it acts up and I turn the car off and then restart, it seems to work fine. Any other Ideas? Thanks.
  • lvfranklvfrank Posts: 7
    The codes showed that the wheels were turning at different speeds. They have replaced both front hubs, the sensors twice, and the error still appears every once in awhile. That is what is so disturbing, that it does not happen all the time......HELP
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello Ivfrank,
    I would just take it back to your mechanic and tell him that the codes are still going off and the resetting of the computer didn't clear the codes. Have him just reset the computer and go from there. Thank you,
    Mariah GM Customer Service
  • frankv74frankv74 Posts: 2
    Already Had the work done > the Hub was about to go and when hae changed it he had to replace the wheel sensor. Also the next ISSUE ! with this dam truck is that I took the truck to GM service to fix the Ac Controls and pay close to 400.00 to repair A/c Controls now the same thing is happening. I have come to the conclution i will never ever buy a GM truck Again.
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello Franky74,
    I apologize that you still have a concern on your vehicle. Did you talk to the dealership and let them know the concern is still present? Thank you,
    Mariah GM Customer Service
  • abb1014abb1014 Posts: 1
    I'm recieving the same abs fault like and I can hear a noise coming from the abs hub and I took it to the dealership and the say they can not replicate the error and there are no codes in the computer my warrenty for this dealership runs out in 2 weeks and I need to find a way to replicate the error, it usually happens when I start the car every 3 or 4th interval and not shortly after you hear a humming coming from under the hood and then the brakes feel as if they can not grab anything then the fault like comes on please help someone
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello Abb1014,
    I apologize that you are having a concern with your vehicle. What does the code say on the DIC? The dealership may be able to put a code reader in your vehicle so when the problem arises it can read the code. Thank you,
    Mariah GM Customer Service
  • bpetuchbpetuch Posts: 1
    I'm having the same problem with the left front wheel sensor. After driving 5 miles, the ABS motor will activate on that side, followed by the ABS light. I clears after shutting off and restaring. I used an ABS tool to pull the code, which confirms left front ABS sensor.

    This truck seems to have a legacy of electrical ground problems. I'm wondering if the problem could be the ground pack mounted to the fender. I had a problem with the blower motor harness, where the connectors melted. Turns out it was the second harness, based on a repair report. Turns out this harness runs to the driver side ground pack.
  • lvfranklvfrank Posts: 7
    It seems that all you hear about is resetting the computer, but still the intermittant ABS fault will return with no ryme or reason, and then if you pull over, turn the vehicle off, and start it again, the error goes away. I am tired of this error. The mechanic tells me that it is not hurting the brakes or my safety, but I have had both hubs replaced at my cost, and have had the sensors replaced twice--again at my cost. Does anyone have a new Idea or is it just reset the computer. Tired of this--- It seems that this error effects more than me, maybe GM and Chevy should look at Customer Service and suggest a recall......
  • apg20apg20 Posts: 1
    my2005 chevy colorado has a abs fault displayed and every once in a while when I
    stop ,the brakes are locked up .If I turn off the key and restart they release. what to do???
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello apg20,
    I apologize that you are experiencing a concern on your vehicle. Have you had anyone diagnose your vehicle for the concern? Thank you,
    Mariah GM Customer Service
  • ECR223ECR223 Posts: 10
    Well at about 46,000 miles I was having the drivers window/lock/FOB problem, and that's when I found these forums... Now, at 56,000 miles, 2 days ago I hit the brakes, ABS kicks in(for no reason), and then "ABS FAULT" comes up... Much like my previous problem, it's good to see I'm not the only one... I haven't taken it to the deal yet, and probably won't for 2 more weeks at least(until I have time)... Can't wait to see how much this is going to cost!!! It's a real shame too, I love my truck... But I'm not going to want to keep it if it starts developing ALL of the problems listed in these forums!! :mad:
  • omaitaomaita Posts: 16
    Hi, now that I read the other posts, I don't feel alone. Here is the history.
    I bought my 4X4 Chevy Colorado 2006 in Oct'06 here in Gaithersburg MD (Criswell).
    It was cold and just after few months Nov-Dec the truck began with the problems.
    In cold weather the car just didn't move, it needed more than 10 minutes to get warm and be able to move, dealer just said something like the rotors were crystallized and it was normal, to be honest I didn't have time to go back to the dealer for the problem that today still persist.
    Then, I started to get problems to start the car every other week, and for the same problem I went back to the dealer about three times. First they said "We were unable to repeat the problem so we just reset the computer", then they said there was a loose cable, and at the end they just replace the igniter or starter. It was more than 1 year and I don't have THAT PROBLEM again.
    But as soon as that problem went out, it comes another one: THE BRAKES. Every time I push the brakes, the car showed something like a pulsation, so I went to the dealer and they said ok the "brakes are bad, something weird, because your car it has less than 20k miles, so we are gonna replaced all four for you at no cost".
    After they did that the problem went out for like 6 months and it came back again. Again, i didn't have time (IT'S ALL MY FAULT) and I didn't take care of that, but then started to show ABS FAULT and the pulsation was harder when that happened.
    My car has only 33K, but I bought it on Oct 2006 so I thought the warranty was expired, but checking all the papers given to me by the dealer when I bought the car (BECAUSE I'M TRYING TO SELL THE SCRAP ASAP) I found that there was an EXTENDED PREMIUM WARRANTY by Performace Fisrt that cost me $ 1,100, so I went to the dealer two days ago, dropped the car they called me yesterday morning to said "we could not duplicate the ABS FAULT, so we just tight the connectors; and regarding the noise every time I make a turn, front brake rotors needs to be cut or realigned and that will cost you around $ 345, but we do not guarantee that the noise will be gone", so I said, leave the noise that you do not guarantee will be gone and just fix the ABS FAULT, also I told him, about this forum and let him know that people here is talking about a bad sensor and loose bearing, and just said YEAH YEAH YEAH WE ALREADY CHECK THOSE THINGS.
    Honestly now, I don't trust those Chevy Techs that one of the times when I dropped the car gave me a check list detailing what was already checked, like lights, and as soon as I saw the car there was a turn light not working and they just said I'M SORRY WE'LL TAKE CARE OF THAT.
    Today I got the same problem with the ABS FAULT message. I took some pics of the message and I dropped the car. Hopefully, I am not gonna need to pay another $ 100 as deductible for the same problem they can't fix.
    Bad experience with Chevy, that's the reason one year ago I bought a new Nissan for my wife and I still have peace of mind with that car.
    I don't know if that extended warranty is transferable (even in the dealer nobody knows, and nobody give a paper where it says yes or not), but if I don't sell the scrap in the next month I will contact a lawyer for this nightmare.
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello Omaita,
    I apologize that you have had concerns with your vehicle. Did the dealership ever find the concern? Thank you,
    Mariah GM Customer Service
  • I stated on here a few months ago that my abs fault code was intermittent, but now it is happening almost every day. Here's what happens. In the morning I start the truck and the code clears. I drive to work, all is fine. I get done with work, go to leave and the first time I apply the brakes, the ABS activates. The brake pedal pulsates. (I'm on clear dry pavement) and the ABS fault pop's up in the DIC. I drive back home, park the truck for the night and everything is fine in the morning again.
    Seems to me that this is a safety issue, and GM needs to issue a recall. Especially considering that the Colorado has a history of electrical gremlins.
    Does anybody know of a phone number, or E-mail address to complain to GM about this problem. Maybe, if we all start making some noise about this, GM will fix these problems with a recall.
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello Tomtom231,
    I apologize that you are experiencing a concern. Have you had anyone diagnose your vehicle since the code is on all the time now? Can you email me your VIN and current mileage? You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • lvfranklvfrank Posts: 7
    Mariah,
    This is also happening to my truck. I have written in this thread before. I have had it to the mechanic, and they have replaced the sensors and both hubs. There is no ryhm or reason why it comes on. I agree that eventhough I have been told by the mechanic that my brakes will work, just the feel concerns me. If you want it my VIN Number is 1GCDT136958245113 and I have 75,000 on the truck. Had both hubs changed at 65,000 because they thought that would solve it. It seems that it is an electrical problem to me, especially with everyone that has discussed this issue on the thread. Don't expect anything out of this because I am becoming really dissatisfied with Chevy.
  • gmcustsvcgmcustsvc Posts: 4,055
    Hello Ivfrank,
    Do you still have your warning lamp coming but, there is nothing wrong with the ABS correct? The only thing I could do is set up a case with an agent for you. I would need you to email me your contact information, dealership and best time to contact you. You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • omaitaomaita Posts: 16
    Hi, thanks for reply, at least somebody from GM shows interest in my concern.
    I dropped the truck on Thursday, then Criswell call me on Friday to let me know that they were able to duplicate the message ABS FAULT and, like EVERYBODY is saying in this forum, the problem it was a BAD SENSOR and BAD BEARING (even tough they prefer to call it "HUB").
    The first call it was to tell me that my Performance First extended warranty should cover only labor and sensor, but the Bearing (350.00) should be covered by ME.
    Then they call me again, to let me know that the Dealer will cover everything.
    I was unable to pick up my truck until Tuesday because they found another Code in the testing drive, so they changed sensors and bearings in both wheels.
    Has been two days, and there is still no problems with the ABS FAULT.
    I still have the pulsation on the brake pedal that they said my PREMIUM Performance First doesn't cover.
    Anyway, thats something I live with until I sell it.
    Thanks again, last favor, how can I know what factory warranties my 2006 34K miles still have my truck and if the extended warranty is transferable???? Since I never received the Warranty Facts Book when I purchased the car.
  • I am having the same issue.. 2005 Colorado Z75 I5 - used to be intermittent ABS light that used to resolve itself every time I restarted the car.. now the ABS actually DOES kick in and pulse when going slow (~5mph) and the light is almost always illuminated.. I am just under 100k miles, brakes and rotors changed last year. nothing since.

    I dread going to the local dealers.. they gave me a hard time when I first bought the truck by telling me it was MD state inspected, only to find out it was metal on metal for my front brakes and needed new rear tires.. anything recommended by the posters here? can I pull ABS codes without going to a dealer to try to limit cost?
Sign In or Register to comment.