Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac DeVille

1114115117119120125

Comments

  • bremertongbremertong Posts: 436
    I also owned a 1998 Deville from 2001 to 2004. My 98
    Deville got an average of about 20 MPG in the city and 27 on the highway. Think your car may need some fine tuning. If you have a dealership you trust take the car in for your next oil change and bring this up to the service department, suspect they can put the car on computer diagnostic system and find out why your fuel economy is below average for your car.
  • bremertongbremertong Posts: 436
    Forgot to mention that i have used STP fuel injector cleaner fluid on my 1998 Deville. Never had any problems with the Northstar system using this product but can't say for sure that it helped. The cost is around 90 cents per container. The folks at STP claim that it helps fuel economy and keeps fuel injectors clean.
  • bolivarbolivar Posts: 2,316
    A lot depends on how agressive you drive, or the conditions you drive. If you have an easy foot on the gas, I think you can drop to mid-grade without any problems. You could probably drop to regular, and will hear some pinging, but still have no problems.

    But, it you accelerate quickly, or drive in mountainous roads, you may need to keep premium gas in to. When the motor is under heavy load is when premium is needed to eliminate pinging.

    I think if you drop the grade, your milage will probably also drop.

    And I agree, the 20mph should be what you can get with a mix of in-town and highway driving, and with constant highway driving, you should be able to get 25mgp or better. On premium.
  • lilballerlilballer Posts: 2
    Hey I jus got bought my first car and it a cadillac deville 2003 with a northstar engine It has a little over 75,000 miles but while driving today It started to give off a foul smell i smelt like a rotten egg I check the engine and seen nothin then I looked ubder the car and seen sumthing hangin down it was drippin fluid and giving off steam can anyone help me out by tellin me what this r what the problem may be?
  • bolivarbolivar Posts: 2,316
    Well, let's see. A Caddy has the following fluids:

    -Oil
    -Coolant (antifreeze)
    -Power Steering
    -Brake Fluid
    -Transmission Fluid
    -Gasoline
    -Windshield Washer
    -Battery Acid (the battery on your 2003 Deville is inside, under the rear seat)
    -Condensation from the Air Conditioner

    Each one of these has somewhat destinctive color and odour,But some are tough to determine.

    The only 'rotten egg' smell from an auto usually comes from the exhaust, and usually isn't anything to worry about. Oh, wait a minute. Battery acid has an acidic, somewhat rotten smell. You better hope this isn't a burst battery under the rear seat.

    Oh, I'm adding this in here. If you are running the Air Conditioner, it will condense water our of the inside air, and there is a drain where this comes out. All cars will drip water during the summer when it is condensing out. This is normal and nothing to worry about.

    In the hot summer, the first next to check is if it is coolant. Coolant will be reddish, brownish, maybe green if someone has put non-standard coolant in there, and has a sweetish smell and is slightly oily in texture.

    You are going to have to give us some help here. But really, if you can't determine what is leaking, you should get it to a repair shop pretty quickly.

    Leaking coolant will cause cause an error message to display when it leakes so much it is low, and when it gets even lower, the motor will overheat, displaying even more error conditions. Continuing to run the auto will ruin the motor.
  • efugateefugate Posts: 1
    How do you disable side impact airbags in a 1998 Cadillac Sedan deVille D'Elegance safely? We had a collison in which the driver's door was damaged and we are currently attempting to change the driver's door?
  • onelordonelord Posts: 9
    I have a 03 deville with 66000 miles on it. Im getting 21mpg on the highway and 19 in the city. I was wondering if I should add something to the fuel in hopes of cleaning the fuel injectors. Is this wise to do?
  • bremertongbremertong Posts: 436
    I owned a 1998 Deville and later a 2004 Deville for three years each and always used STP fuel injector cleaner fluid with each fill up. never had any problems.
    The 98 got about 27 MPG highway and around 20 in town. The 2004 around 29 MPG highway and 21 city.
    You may have other issues and may want to try a complete fuel system cleaner (STP has one as do other additive companies). Have you checked your air filter or replaced recently. Your MPG stats sound low
    so you may want to investigate further if my two suggestions don't improve your MPG performance. The 98 Deville had 39,000 miles on it at time of trade and the 2004 Deville had 36,000 miles on it. Both much lower mile cars than yours but still think you should be getting better results.
  • bolivarbolivar Posts: 2,316
    Unless you have been using very cheap unbranded gasoline, I wouldn't think you have injector problems.

    With that milage, i woujld be thinking about plug wires and plugs. Us only GM wires and the recommended plugs. The wires and plugs should be good up to 100,000, but expecially if you have had some mechanical work done near the wires, they could be messed up. If you live in extremely hot area, the wires might also have broked down early.
  • onelordonelord Posts: 9
    I was thinking of using a good brand of injector cleaner. I dont think its the plugss the car runs smooth and has great getup. I think it just needs some injector cleaner. Thanks for the info from both of you. Any info will help all of us.
  • bremertongbremertong Posts: 436
    Hope you ill let us know how the injector fluid works and if you would share the name of the specific brand you used. Hope it will give you the results you are hoping for. Best wishes.
  • How accurate are the warning dashboard lights? On my last long
    distance trip, it said: "service engine soon". A Cadillac dealership told me the computer points to transmission. After hearing the amount of $1250.- plus, just to find the problem, I have decided to drive home, hell or high water.
    After another 800 mls , I am home now, DeVille sounds perfect and the %#&^*(@ light is off. What is going on?
    Just in case: I did check my tr. oil and it is 100% full.
    Thanks.
  • bolivarbolivar Posts: 2,316
    Well, it could have just been an 'intermittent' error, and the dealer re-set the light, and the error did not happen again. Lucky you.

    The check engine lights are usually pretty valid. One thing that will set false errors, and usually will set a whole slew of them, is a bad battery, one with low voltage. Caddys do not like low voltage (and most modern autos are the same here), and if the voltage drops to 10 or 11 volts, this might be enough to start the car, but it may set a mess of codes, make 'strange' things appear on your digital dash, make certain components do strange things, etc, etc, etc.

    Your Cadillac has an extensive self diagnostic system which can easily be accessed by you. I'm not going into how to access or navigate thru this system. But, with the instructions, you can easily see the specific error 'codes' set. It will just be a number, but there are sites which will give you guidance as what general information is tied to each error code.

    IF it happens again, here is a link to a site with error codes and info on how to 'get into' the diagnostic system on cadillacs

    http://myweb.accessus.net/~090/dtcobd2.html

    Hosts: Please do not slap my hands about this. You told me a ciuple years ago, that if a question needed additional info found on another site, it was ok to post the link. I'm hoping that is all that I've done here.
  • Thanks, bolivar.
    I will try the site. However since my confidence in DeVille is now big fat zero, I am thinking to replace it with Toyota or Subaru.
  • dadstoydadstoy Posts: 1
    I have owend this car for 4 years and not really had a problem ..untill now.a new fuel pump and filter were installed a year ago.now it starts fine runs for about 5-10 min then dies and will not restart.the fuel pressure is at 20 pounds while running,but when it dies or you shut it off it will not hold pressure.but when you try to start it it goes right back up to 20 pound and wont start.
    any ideas?
  • Hi,
    I have the same blower motor problem could you tell me if you resolved yours and how.
    Thanks,
    John
  • bolivarbolivar Posts: 2,316
    Hummmmm,
    Not want to be mean, but are you aware you responded to a message 1 year and 7 months old?
  • I have not had any slipping or noise or problems with my transmission until today. While driving on the highway I lost it suddenly. It will only go into first gear. Will not reverse either. Any ideas? Bob
  • I am buying a used 1992 Sedan Deville w/46k miles. I want to replace the stock stereo with one that has Bluetooth and an iPod interface. Has anyone here done something like that? Can you suggest a model that would fir the car and if a new wiring harness is needed? Thanks very much in advance.
  • I'm new to Cadillac and don't have a whole lot of experience in mechanics....Can tear a car apart, but can't do diagnostics. I just purchased a 91 Deville Sedan that had an old battery in it. I drove it for a day, parked it and over night the battery was drained. Got it jumpstarted the next day, ran for the full day shutting it off and turning it on, went to Les Schwab because I'd picked up a roofing tack in my tire and needed it fixed. The battery was smelling like sulfur and they replaced it. Schwab tested the Alternator and said that it was running on the high side, but nothing that would cause a battery to explode. I've been pulling the cable at night to keep the battery from being drained. I noticed that someone has cut the wires to the battery and put a new terminal connector on it. There are three wires hooked into the positive and just one on the negative. I've been trying to get schematics to see if this is accurate or if someone has possibly put a negative wire on the positive post. Also i get a service air conditioner light, but was told not to worry about this when i'm driving it and these lights come on, it comes on with the coolant temp fan light and service soon light......sometimes it acts like the fan is trying to turn on and breifly acts like it's draining the battery.....i know it needs a tune up.......i got it from a parts and sales wrecking yard fairly dirt cheap. :cry:
Sign In or Register to comment.