Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Echo

1280281283285286

Comments

  • mcdawggmcdawgg Posts: 1,666
    Read in one advice column? Not a very good source of information. Was it engine mounts, or wheel bearings? You said engine mounts in title, but "wheel mounts" in the text. Long time owner, never replaced an engine mount, even with over 100,000 miles and over 10 years old. Wheel bearings? Yes, replaced one, but it was also the same one that I was forced to hit a curb with to avoid an accident. A few years later, I had to replace that wheel bearing, but probably due to hitting the curb.
  • kneisl1kneisl1 Posts: 1,683
    Never heard of problems with wheel bearing or engine mounts on Toyotas

    However...

    On the Yaris the water pumps are experiencing early failures. Which is strange because I never heard of an ECHO experiencing a wp failure and they have the exact same engine.

    Mine failed at 27k miles and was replaced under warranty.

    I suspect the percentage of cars affected is quite small but nevertheless this is unheard of in my experience with Toyotas.

    See Yarisworld.com for posts concerning this.
  • Engine mounts in a five or six year old Camry. Mechanic told the owner to replace them and the column writers agreed. I wish I had saved the article.
  • mcdawggmcdawgg Posts: 1,666
    Right, all I am saying is that you cannot judge anything for one report, one article, whatever. Maybe this was a salvage car, maybe it was used to race, who knows?? Bottom line is engine mounts are not something that is replaced often (mostly never) with under 200,000 miles in any Toyota that I know of. Check Toyotanation.com.
  • I have a 2000 Toyota Echo with automatic transmission. My transmission position indicator light in the center console no longer comes on consistently when I drive at night. I'd say it might be a light bulb out, but it does come on sometimes. I suppose it could be the light bulb, or it could be whatever switch that turns the light on when driving at night (which I assume is somehow wired to the headlights and other night running lights). Or a fuse. Has anyone else encountered this problem, and what's the best way to troubleshoot it? I'm not sure I can do it myself, but I'd like to try.
  • kneisl1kneisl1 Posts: 1,683
    It probably just a dirty lightbulb socket. Cant be a fuse or the bulb itself cause it works sometimes. If you take the plastic off the shift lever console perhaps you can get to the point where you can see the bulb. Removing and replacing it a few times should clean the socket up.

    I will check my ECHO service manual when I get home and see whats involved.
  • Thanks for the tip. Now, I just have to figure out how to get the console cover off.
  • kneisl1kneisl1 Posts: 1,683
    I have the picture of the assembly from the manual. There is a single screw holding the plastic cover surrounding the shift lever. It is under a piece of carpet trim all the way to the rear of the cover. It looks like a cup holder. If you can get it off you MIGHT be able to access the bulb. It looks like an old small flash bulb. There is a short wire harness with a connector at each end. Only four small bolts hold the shifter to the floor. I dont know if its necessary to remove it the bulb might be accessable as it sits.

    If you could give me your address i could make a copy of the diagrams and send it to you.

    But personally you know it might be the better part of discression to leave well enough alone.
  • You will never no if you can fix it if you do not try. I had cover off our 04 to ajust the E Brake. ;)
  • I'm the one who posted about the intermittent outage of the light that shows what gear you're in on the automatic transmission of my 2000 Echo. Well, I never did get around to figuring out how to get the console apart to check out the bulb and contacts, but I did take the car in to get a new battery today, and the light seems to be working fine now, when it pretty much stopped working altogether a couple of nights ago. The battery in the car was seven years old and I'd been meaning to replace it, anyway. While researching the light problem, I read that some people who owned various models of cars had interior lights fail, and then noticed the lights would work when they installed a new battery. It seems to have fixed my problem, thus far. Of course, since it was an intermittent outage, I'll have to wait and see. But it's something to consider when lights go wonky and the battery is old.
  • kneisl1kneisl1 Posts: 1,683
    Follow this link to a picture from the service manual of the disassembly of the shift lever to get to the bulb:

    http://www.yarisworld.com/forums/showthread.php?p=624601#post624601
  • Thanks for that. I knew there was a screw on the top side of the shift knob, but didn't know where the other screws were. It looks like the bulb is close to the top of the console. If and when the light stops working again I'll give it a try.
  • I have a 2000 Toyota Echo sedan automatic that is making an odd clicking noise when the engine is on. I can hear it when I am driving down the highway and when I am stopped at stop signs and when parked in my driveway. I'm not sure where to begin looking. No engine codes are currently showing up. (no light either but I have a reader that will show pending codes before the light goes on anyway) Last June my left front wheel baring was replaced. Last July the front brakes were replaced and the fuel vapor assembly was replaced. I have no trouble stopping when I brake. The clicking started in late August and has gotten louder. The local Toyota dealer wants to charge me $115 to check my engine codes. Since I already know there are no codes I need other options. :D
  • Does the clicking speed up as the engine is revved? If so, I'd look at the things that the belts are turning: the alternator, power steering pump, AC compressor, and water pump.

    Maybe one of the more knowledgeable people will chime in; I'm definitely not any kind of great mechanic...

    Also, if you ever need engine codes read, Auto Zone will do it free. And Harbor Freight has cheapo code readers for about $40
  • kneisl1kneisl1 Posts: 1,683
    I will think about it.

    Right off the bat though I have this advice.

    Stay away from the dealer unless you want to spend $$$$ for nothing.
  • I have an Android phone with an application on it for reading engine codes via a Bluetooth adapter that goes into my cars code reading port so I know for a fact that there are no engine codes. I had all the belts replaced last year. The car does not have a timing belt. It has a timing chain that is good for the life of the car. (I suspect this means when the chain goes the car is dead for good) The clicking noise is whenever the engine is on but doesn't speed up if I rev the engine and doesn't slow down if I am merrily at idle. It doesn't speed up or slow down in relation to the cars current speed either. Brakes still work fine and the car still has no pending or current engine codes.
  • kneisl1kneisl1 Posts: 1,683
    If the chain DOES go it can be replaced. But I have never heard of that happening. Possibly there are other issues by that time which would cause the car to be uneconomical to repair.

    I think its a good sign the noise doesnt get more or less frequent. Also that there are no engine codes. Its just one of those noises that dont mean trouble just drive you crazy.

    You will get used to it and it will become "normal".

    But its possible the cause will be revealed to you one day.

    If so post it here for others to benefit!
  • babyboomerbabyboomer Posts: 205
    Humming along like it's gonna live forever. :)
  • kneisl1kneisl1 Posts: 1,683
    How many miles now?
  • babyboomerbabyboomer Posts: 205
    135,000 miles, and hoping for at least another 135,000.
Sign In or Register to comment.