Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mercedes-Benz E-Class Sedans

1198199201203204218

Comments

  • mollymaxmollymax Posts: 25
    Could you explain how that works? I know what an i-pod is, but not familiar with Mp3 and what does that have to do with the CD player?
  • stevebc16stevebc16 Posts: 1
    I just ordered an E350 with the Bi-Xenon lights. Given the good halogen system on the E class, the dealer sales rep did not really think that I needed the Bi-xenon lights. I have until the first week in August to delete the lights from my order and would appreciate any comments, both pro and con, regarding these lights.

    Thanks,

    Steve

    P.S. After a 12 year hiatus, I am returning to Mercedes Benz. I looked at the Lexus GS 300, BMW 530 XI, Accura RL and Audi A6 and was impressed with the new E350. I hope I made the right decision and would again appreciate any feedback from this forum.
  • mollymaxmollymax Posts: 25
    If you want the most miles per gallon.........check out the CDI.
  • nedzelnedzel Posts: 787
    is a standard format for music files. While the Ipod can play MP3 files, the Ipod also supports its own proprietary music format called AAC. Many companies make MP3 players that function basically like an Ipod. Only Apple makes a player that supports AAC.
  • greasykid1greasykid1 Posts: 336
    Had 1999 E w/xenons. Very bright but sharp cutoff. Now have 2001 E which had regular lights. Changed bulbs to Sylvania BrightStars. Big improvement and have light further down the road. Dealer installed n/c. All this for $40.
  • mark156mark156 Posts: 1,992
    Steve, I have the Bi-Xenons on my 2002 ML500. I have the regular headlights on my 2000 E430 sport. I really like the bi-xenons as they seem to be brighter and more focused.

    For the xenons, the "brights" work on the same headlight. The shutter will be raised and lowered when you activate the high-beam lever. If you are outside the vehicle, you can hear the shutter click when it is activated.

    If your headlights are in the off position and you want to "flash" someone, there is another light in your headlight assembly that will come on for that purpose. The xenons will not flash unless they are fully activated. That's what the additional "high beam" light is for. That is the way it is on my ML500.

    I think you will like the xenons... so, go ahead and order them.

    Mark
  • pguptapgupta Posts: 6
    I have a 2005 E320.CD changer plays MP3s. No problems. The dash readout does not give names of the songs. Everything else is ok.
  • pguptapgupta Posts: 6
    I have a 4 month old E320 with 3200 miles on it. After the 3000 mile diagnostic check-up, for the first time, I got a Low Battery message. Went away in 2-3 mins. Everything was normal for a few days. Since last evening, I have recieved the same message like 5 time over a 60 min driving period. All of the convenience features stop working, AC fan turns to lowest speed possible.

    Can somebody help...What's going on?
  • mark156mark156 Posts: 1,992
    Looks like you have a defective battery. Take it in to the dealer for a replacement.

    Funny thing, my 2000 E430 is still on the original battery. I have 29,800 miles on it and I will have had the car for 6 years coming up in October. I probably should replace the battery just so that I'm not stuck somewhere when it finally goes out.

    Happy Motoring.. mark156
  • mollymaxmollymax Posts: 25
    I would replace it or carry a set of battery jumpers.
  • oceanmanoceanman Posts: 1
    I have the bi-xenon on my 05 E320 (standard with the appearance package)and are wonderful. I am 68 years old and need all the help I can get driving at night. They follow around curves and are great. I would not hesitate getting them.
  • Can any body tell me what the part number is and the model number is for the cd player that go's in my car.
    It is a 1995 E300D 4 dr sedan.
    It seem like the dealers where i am dont seem to know.
    And if any one knows what years fit.
    Thanks.
    Harold.
    warlock400.
  • greasykid1greasykid1 Posts: 336
    Looking for CD for 1999 E320. Any sellers other than dealers? They want $400 plus $200 for complete installation.
  • patpat Posts: 10,421
    Maybe someone can point you in the direction of a website or something, but no one can directly sell anything in our Forums. I know you've been around plenty long enough to know that, but I just don't want anyone to misunderstand the nature of your request. :blush:
  • acco20acco20 Posts: 208
    Pat..............you really can "spank" diplomatically. smile:
  • patpat Posts: 10,421
    I think that's a compliment :-) but no "spank" intended ... honest!! :shades:
  • scooby6scooby6 Posts: 9
    2006 E350 with the exact same problem. A/C in AUTO mode, the fan seems to never cycle down once the car gets cool, so you have to manually overide. Dealer says this is normal, but it didn't happen in the E500 loaner they gave me (which has the same A/C system). Today, it wasn't nearly as hot, so it started out at about the 3rd highest fan speed; however, it still never cycled down. Seems that whatever speed it starts at, it tends to stay on that speed. Extremely annoying as you start to get too cold and can't comfortably listen to the radio. Having the manually select settings should not be the solution. Class Action anyone?
  • pisciottapisciotta Posts: 54
    Maybe you have the temperature setting to low (65-67) just guessing here, also when you set the temperature low and the fan is running high speed, as you turn the temperature setting up does the fan slow down?
  • scooby6scooby6 Posts: 9
    No, it's set a 72, when you turn it to 74 (goes in 2 degree increments), it doesn't slow down. Move again to 76, and it still doesn't slow down but the air now starts coming out warmer. Either it doesn't function properly, or this is just how it works - in which case I never would have leased if I had any idea.

    Did I mention the dealer forgot to sign the lease! Couldn't I just take it back with no further obligation? Will check with an attorney.
  • pisciottapisciotta Posts: 54
    My friend just brought 06 E350 and just so you know the steering wheel controls for the radio dont play the preset stations, It scans from 87.1 to 108.5 that S*%*s !!!!!!!!!!!!!!
  • scooby6scooby6 Posts: 9
    Yes, I noticed that too. Another malfunction, or just plain poor design, that causes you to have to take your eyes off the road. It's also a bit strange not to have the radio contraols on the same side of the steering wheel (volume is on the right side, station changes on the left. CD changing in the 6-dc in dash changer is very clanky and noisy. I could probably live with all this, but the LOUD A/C fan is unbearable.
  • Hi just so you know there is a Lease Questions forum here you may want to check it out about your lease questions!!
  • acenjacenj Posts: 58
    Yes,

    IMO, the radio controls are PATHETIC, not even worthy of a design on a disposable car. You can not scan thru presets, just basically hit every freaking station as the up/down arrows take you to the next/previous strongest station.

    Also - since its a world car, for those with right hand drive cars, to choose a preset is a short reach, but for those of us on the left and here in the states, you absolutely can't do it w/o taking your eyes off the road, especially if you're tall in which case your seat is far back.

    I would give the chasis/suspension guys an A+ on design, and MB engineers who designed the damn radio/command and absolute "F" as they don't deserve to have jobs the design, IMO, is that poor.

    Aceman
  • scooby6scooby6 Posts: 9
    I agree. But that MUST be a sofware thing or something that can be fixed. No one can be that STUPID to design a radio that doesn't scan through the pre-sets, can they?? My e350 has the same issue, and it is extremely annoying, AND dangerous. I don't undertand why bother even having presets then. The system does all sorts of things, but the most basic function of sanning the preset channels - somebody pinch me, this can't be happening. Of course, that's not something you even check on a test drive, who would think to check that!? Again, there is no way MB can be this STUPID, this is just someone's idea of a cruel joke, right?
  • acenjacenj Posts: 58
    Hey Scooby,

    I of course didn't find this out till after i bought the car as well. It flat out kills my channel surfing. Unfortunately, as discussed on other MB forums, MBUSA has been aware of this for 3 model years now (starting with 2003), and still no fix. I wouldn't hold your breath. Just amazing they can give you 4 zone heating/cooling, courtesy lights that go on/off depending on ambient light, they can give you a car with active air suspension, etc. etc.....and they miss this :mad:

    Acenj
  • kennynmdkennynmd Posts: 424
    Fix? There's a "fix" for this. Don't think so. For all the engineers they got, there's something they can do. It's whether they want to or not!
  • bigrobnhbigrobnh Posts: 114
    Interesting. This probably is a software thing. I could have sworn that on my 2001 I can set the behavior of this through the settings menu (only accessable when stopped). I may be wrong, I'll check next time I'm in the car.

    Regards,
    BigRob.
  • wbreaux1wbreaux1 Posts: 55
    I have a 2000 E320 and I have had to override the fan speeds since I got the car. I've gotten used to it for the most part, but my wife's 2002 A6 is much better. On her car, you can change the temp setting a degree and notice the difference. In my E320, you have to change it by several degrees for anything to happen, then you usually overshoot the mark, so it's much easier to override.

    BTW, I haven't had problems with the radio settings.
  • scooby6scooby6 Posts: 9
    Well, you may be aware of my radio, clicking seats, and AC fan issues, but it's gotten much worse. The other day, teh CD player just died while driving and reset itself, a "clanking" sort of noise is now coming from somewhere in the passenger area, the steering is now noticeably out of alignment and TODAY guess what happened.....

    While merging onto 495 at 10:20 AM (at the infamous "mixing bowl" in Northern VA), the TRANSMISSION goes out !!!! In not making this up...two weeks old, 2006 E350 w/ less than 300 miles and I break down on one of the most dangerous roads in the U.S. Thank God I was in the far lane and had enough "roll" left to glide onto the shoulder. Put it in drive, hit the accelerator, and the engine just revs. I hate to think if this would have happened while my wife and 3 year old twin girls were in the car instead of just me. I call the dealer (5 minutes away) that they said push the help button in the car, that they can't help me (2 weeks earlier they were rolling out the red carpet) - MB then comes on line and says they'll be there in about an hour or so....so I wait on the side of 495, with cars and semis zooming by at speeds approxaching 80+ mph. The other day, someone got killed (hit) by a vehicle when he was on the side of the road in this same area.

    This car is not only a total LEMON, it is dangerous.

    Then, I take the loaner they give me (a Mazada 3) and drive over the Acura dealer to test drive the RL. Actually, a much more comfortable car to drive, but the Navigation system looks my kid drew the maps w/ a crayon, and the back seats have NO headroom. Dealer says he can get me out of the Benz deal, and will give me the RL at first month payment down, and $621 mo for 36 mo/12K miles a year. Very tempting, but the back seats and poor layout of hte Nav system I wasn't sure about. Aside from that, it's a comfortable care (nice big arm rest vs. mercedes).

    However, when its working, the e350 seems like a great car. Maybe I'm just the lucky one that picked out the LEMON on the lot, but it's scary to think they can put in in another one (which they are now offering to do) and the same thing could happen.
  • greasykid1greasykid1 Posts: 336
    Just had a new instrument cluster replaced--warranty. It works fine except that the MPG screen now starts off @ 7.9mpg.To finally get to a correct reading I have to drive about 100 miles. This also throws off my "distance to empty" reading
    I NEED YOUR INPUT!
    What is the starting mpg reading when you first start up in the morning? My service guy has no clue how to correct this. Is it adjustable?
    My wife has a 350SLK and it starts off @ 20mpg so readings are accurate almost immediately.
    HELP! Thanks for any help.
This discussion has been closed.