Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Oldsmobile Aurora

1171172174176177187

Comments

  • yes i thought so ,,thanks robert!
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,087
    Do you have this kind of knowledge about the 3800 engine used by other GM cars? I'd be interested in hearing about the differences between the 3800 and Series II, e.g.
  • HenryHenry Posts: 1,106
    Over the years I have noticed that the passenger side front tire always seems to be the one that loses air. This is true even when i rotate the tires. Today, the tire went flat. I am just curious if anyone else has experienced low tire pressure on the front right tire. I am not saying that this is a problem, I am just saying that over the years it is always this tire as opposed to any one of the others.
  • hammen2hammen2 Posts: 1,313
    Funny, I've had 3 sets of tires (the stock Michelin MXVs, then Dunlop SP Sport A2's, and now BF Goodrich Traction T/A's), rotated every 6-7k miles, and it's ALWAYS the driver's side front tire that gets low. I have to check the tire pressure every 2-3 days and pump it back up (thanks to the $20 portable compressor I bought due to this problem) about once a week.

     

    --Robert
  • I lose about 2 to 3 pounds per day in my left front tire. I have had the valve replaced as well as bead sealer put on. These are like new Michelin MXV4 Plus tires. Guess it needs to go into a dip tank soon.
  • gudgegudge Posts: 9
    In an earlier post I wrote that my 97 had voltage fluctuations which caused the alternator to operate erratically. I fixed the problem by going to alldatadiy.com and printing out the grounding points for the car. I tightened all of the grounding points and the problem is gone.
  • Anyone have an idea on the interchangeable of the front hubs? I mostly likely going to get one from car-part.com. I get a number of cars, LeSabre, Eldorados, and even a Pontiac TransPort lol.

     

    There was a NOS hub on ebay for 97-99s and the guy said they will not fit 95-96.
  • Do you think I made a mistake on trading in my '97 with only 73,000 miles, but was told the lower case half gasket or main seal was going out. There has been a oil leak from the front of the oil pan for some time. You could see the oil spray on the pan from underneath the car. I did not want to face the possiblity of having to put $$$ in it when I still owed plenty on it. I got totally raped in the trade, but that happens a lot.

     

    Yes, the car looked cool. But, in a lot of ways I don't miss it. Like the premium fuel, high cost of insurance and license fees. The new car is only a $30.00 more for insurance and less for license.
  • HenryHenry Posts: 1,106
    No.

     

    How much did u get on the trade? What did you get? What did it cost you?
  • You know what they put on paper is not actually what you got. But, I gave them $10K plus the car on which I owed $3400. They were asking $16,900. I went quite a bit smaller, but I thought the Aurora was a boat. I found it difficult to move and park. So I really don't miss that. Now, don't laugh when I say I got a 2004 Pontiac Grand Am SE2, bright red, chrome wheels. Same as the GT but without the Ram air. It had 3,800 miles, was registered to GM and was never in the public before I got it. I got the additional 3,000 mile warranty because it was certified along with 3.9%. Which was important because I did not want to spend $20K on a car. It has leather, sun roof, XM radio and all that good stuff. I really don't miss the tempurature or the direction read out, but i do miss the dimming rear view mirror and I can figure my gas mileage on paper.
  • sls002sls002 Posts: 2,788
    Yes, the dimming inside rear view mirror is nice, but on my 98 Aurora, I missed the dimming drivers side outside rear view mirror that my 95 Riviera had.
  • HenryHenry Posts: 1,106
    "I went quite a bit smaller, but I thought the Aurora was a boat."

     

    A BOAT! A BOAT!! aROARa is NOT a BOAT!

     

    Maybe a luxury liner, but NEVER a BOAT!

     

    Personally, I don't think the car is a boat. For a car its size and weight, its actually pretty agile.
  • Ok Ok. Luxury Liner it is. I prefer smaller liners I guess. Maybe I prefer more of a sporty suspension. I tried to make it beter with High Performance tires, but that did not help. Maybe the whole suspension was out of whack, cuz the reason I got new tires was that 2 rims were bent and 2 belts in the tires that were on it had slipped. I think something got taken for a real ride before I bought the car, which is weird becaue my aunt and uncle owned it before me, cant recall them saying anything was wrong. But of course they never pay attention to how their cars run anyway. They are driving a car now that has the steering wheel at a 90 degree angle and still have not figured out that the alignment is out of whack.

     

    Can we agree that it is a large body car ?
  • sls002sls002 Posts: 2,788
    The Aurora was not a sports sedan, but I think it did handle quite well. The original equipment tires were Goodyear Eagles. The Grand Am is not a BMW 325 either, but is small enough to be easier to park.
  • I have th eopportunity to buy an Aurora, and was wondering if i should.

      It is a 97, with 110K miles on it. It is a trade in at the dealer where my brother works. It seems to be in good shape. They ran it through the shop and put a tie rod in and recharged the AC and put new tires on it. I havent driven it yet, but i did check it out. The only thing that i noticed for sure was the the drivers side power window was non functional, have no idea why? I am not sure how this "twilight sentinel" functions. also, when started, the gas guage went all the way up to full..stayed there for about a minute, then dropped down to empty(which i am assuming it was, or quite low as most cars on lots are). Is that normal? Are the trannys in these cars reliable? Any other issues?

    Thanks.
  • I have a '97 with 117,000 miles. The gas gauge behavior reads like the same problem I had -- the sender was bad. It is located in the gas tank and is part of the same module that contains the fuel pump. List price for the module is about $500; the sender may be available separately. I decided to replace both since several list members have had their fuel pumps fail at 100,000+ miles. I purchased an ACDelco unit for about 1/2 of list from one of the internet GM suppliers (RockAuto, Van, ???, I don't remember). There is an access panel in the truck so you do not have to drop the tank to replace the module. Most list members will tell you to always use ACDelco replacement parts. Other brands may save you some $$$ upfront, but you will pay again later with short life.

     

    Hope this helps.

     

    Les
  • My '97 had an interesting problem last week. The "TRACTION OFF" light came on and I could not turn it off with the console button. After a restart, I noticed the light was not on, but it did reappear after 1 to 2 miles of driving; this was repeated several times consistently. I then restarted (no light) and let the car idle for about 5 minutes -- still no light. Drove away and the light came on after a short time. I checked for codes and there were none; ABS indicator never came on. Curious as to whether or not traction control was actually turned off or this was just a malfunction of the indicator, I did a full-throttle start. Sure enough, lots of wheel spin, so traction control was indeed not working. Then I turned off the motor, restarted, and tried another full-throttle start before the "TRACTION OFF" indicator came on. This time the "TRACTION ACTIVE" light came on and the traction control worked.

     

    Here's the strange part (knocking on wood): the problem has not happened since and that was 7 days ago with the car being driven every day. Anyone have an explanation?

     

    Les
  • sls002sls002 Posts: 2,788
    My 95 Riviera did this (shut down the traction control). The problem also may have flagged the service engine soon indicator. When I took it to the dealer, the computer was complaining about a fuel/air problem. They replaced the air mass sensor. Problem not fixed. Asked Buick headquarters for help and they said to replace the gasket between the supercharger and the intake manifold. That fixed it.

     

    Your Aurora does not have a supercharger, so that should not explain it. There should be codes stored if there is an engine malfunction.
  • Les,

    I had the same problem with my '95 a few years back. One of your front wheel speed sensors is on it's way out. They are part of the wheel bearing assembly, and I ended up replacing them on both sides within a short period of time.

    Problem solved!

     

    Hope this helps.

    Pete
  • 2k1olds2k1olds Posts: 98
    My mother in law gave us a 1990 Corsica that's really in pretty good shape. It's the LT with the 3.1 and only 58000 miles. I thought I would drive it for the winter and leave my 97 garaged. I drove it for two days and absolutely couldn't stand it anymore. I had to go back to the Roara!

    When you drive basic transportation like a Corsica, it really makes you appreciate the cars we all have here.
  • HenryHenry Posts: 1,106
    TRUE!

    However, I have always liked the Corscia. Fold down rear seats and decent power. Rented one once and liked it. I just thought the horn buttons were too small.
  • hammen2hammen2 Posts: 1,313
    ..back in the day, I had an '88 Corsica w/4-banger. Turn on the A/C, it could barely get out of its own way :-) It was a good, reliable car, though, until someone blew a red light in front of me and I T-boned 'em :-)

     

    --Robert

    happy his Aurora started at -9 this morning.
  • HenryHenry Posts: 1,106
    Sooooooooooooooooooooooo

     

    Is the Corsica the learner car for owning an aROARa?
  • rjs200240rjs200240 Posts: 1,277
    I had a 1987 Chevy Celebrity with the 2.5L "Iron Duke" I-4 pumping through a 3-speed hydromatic. I think it made 95 hp and 125 lb-ft or something from its one big throttle-body injector. My parents also had a 1983 Celebrity with the 2.5L also. The 1987 was much improved with more power, and monster 14" wheels (a big step up from the 13"ers the '83 had).

     

    The Corsica only wishes it had the class and style of the Celebrity. Anyone remember the Celebrity VR? I don't remember it when it came out, but I sure remember when I first saw one in person!! :O
  • I always wanted a Celebrity. I thought they were sooooo cool with their rally wheels. There is a 1982 model here in the area still running.

     

    If we are talking non-exsist horsepower, then I must tell you of the car I learned to drive a manual on. My mom had a 1978 Chevette. Talk about bottom of the barrel. 4-Speed, no air, am radio and sounded like an 747 taking off when you hit 55. Years and years later they replaced the rear brakes to learn that each of the rear coils had cracked. All eyes were on me.
  • 2k1olds2k1olds Posts: 98
    I used to think the the Celebrity Eurosport with the 2.8 was actually a pretty cool looking car. However, I think one of the best cars I had owned up until about 1990 was a Pontiac 6000 Touring sedan. It was maroon and gray, with the radio and climate control buttons on the steering wheel. I was only like 24 at the time and thought that car was great.
  • sls002sls002 Posts: 2,788
    I think that you are talking about the STE. It was a very nice Pontiac 6000 and a good car for the times. The Celebrity Eurosport was good too. There was an Oldsmobile Cutlass International that was good and the Buick Century T-type.

     

    I bought an 86 Electra T-type that I really liked.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,087
    Do you mean the Olds Ciera International that was the same body as the Century? Do I recall correctly that those are desirable to young guys? --There's something considered 'cool' about them?
  • sls002sls002 Posts: 2,788
    I had forgotten that the RWD was the Cutlass. Anyway, the International was a European style sedan. I don't know if it went over big with anyone or not.
  • 2k1olds2k1olds Posts: 98
    I was sitting in my Aurora last night waiting to pick up my daughter in a snowstorm, and the engine was idling about 650-700 rpm. I kicked on the rear defroster and it jumped up to between 1000-1100 rpm. As soon as I turned it off, back down to 650-700. Never noticed it before.
Sign In or Register to comment.