Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2005 and Earlier Chevrolet Impala

1366367369371372442

Comments

  • b4zb4z Posts: 3,372
    Mine was incredibly hard to remove. I was afraid I would break it. After trying I just pulled as hard as I could and pulled the filter out.
    Scratched my hands pretty good but got it done.

    Probably took a good 5 minutes before I figured out I wouldn't hurt anything.
  • patpat Posts: 10,421
    Sorry folks.

    The Membership Agreement forbids using the Town Hall to sell things.

    If you'd like, you can list it at Edmunds Used Power Shopper.

    Good luck!
  • jbk5jbk5 Posts: 26
    I have a 2002 Monte Carlo SS (same engine setup as Impala LS) and the air filter is ridiculously hard to replace. I wish they would have made it horizontal with a screw on cover like every other car I've owned. No squeezing and no fear of breaking something. The biggest thing I'm afraid of is tearing a hole in the new filter when trying to get it in and clamp the cover. That would be good...
  • atbearatbear Posts: 322
    I really don't know why y'all are having so much trouble... mine was rediculously easy.... are you sure you are unclipping all the clips?
  • According to the service manual, you remove the IAT sensor electrical connector, loosen the hose clamps, remote the duct, unclip the air cleaner cover clamps, remove the cover and replace the filter.

    I know what you mean about how hard it is. If you don't know how it is supposed to come off, you keep wondering that you missed something or you'll end up breaking something.
  • I just realized that I kind of covered this in a How-To article. Go to the How-To page and look for the article with the following caption: "Thinking about improving performance? You might want to look at the air intake system."

    I need to come up with better captions...
  • jbk5jbk5 Posts: 26
    Yeah that's how I eventually got it done. Removing the hose clamp and separating the air duct from the cover so that I could take the cover completely out. Problem is, I don't think that's what the owner's manual says. It says to simply unclip the cover and then push it toward the engine to get the old filter out and put the new one in. I don't think there's enough room to do that but I suppose it could be done. I also like to clean the box out because bugs and other crap can get in there and that would be very hard to do while trying to squeeze the cover over. Oh well, at least it doesn't have to be done all that often.
  • dcngodcngo Posts: 14
    Seems like some people had the same difficulty like I did in removing and installing the air filter. I had even tried one of the suggestions, which was loosening the accordion hose. Still, it was not that easy because there just wasn't much room to maneuver.

    But I appreciate all the postings and suggestions just the same.

    DN
  • dcngodcngo Posts: 14
    Recently, the instrument panel light in my 2000 Impala does not turn on immediately after I inserted the key and turned on the engine. I would drive the car anywhere from 1 - 5 minute in the dark, then the instrument light will suddenly come on. Has anyone experienced this problem? Do you know what was the problem? Could it be the weather? The temperature in my area in recent days is near 0 degreee F. I wonder if this is a built feature to save battery (being optimistic). My battery and charging system appear to be working fine. Or is this a sign that a sensor is going bad (being pessimistic)?

    DN
  • johnclineiijohnclineii Posts: 2,287
    I had the SAME exact problem. Turned out to be the headlight switch was failing. And yes, if not fixed, IF that is your problem, at some point your headlights could fail. Got mine fixed while at a dealer more than 1500 miles from home, with about 96,000 miles on the clock at the time. It was about $260, labor included, and that included the dealer going half way across Florida to get a switch while I waited.

    Courtesy Chevrolet in Orlando, part of the AutoNation group. I was very happy with them. I should probably add the car now has 111,500 miles, and this is the only unscheduled repair it has had! :)
  • rbb2rbb2 Posts: 70
    Perhaps this was mentioned but all the problems getting the air filter in is realted to the 3.4 or 3.8? I have the 3.4 in my Montana and it was a major pain to get it in. I ended up taking things apart. No way is it easy to do. The manual makes it sound that way but it's incorrect. Why would they engineer it to be so hard?

    If these discussions are centered around the 3.4 then how hard is the 3.8?
  • (2000LS 41K mi) Several times in the past few weeks, when I go to turn my turn signals on, they don't work !?!? No noise, no blinking light on the instrument cluster, no blinking lights outside the car either. Pretty weird. The last 2 times it happened, I turned on the emergency flashers for a second or 2, then turned them off, and the blinkers were working after that...
  • It sounds like your turn signal relay module is about to go south. The relay is located under the dashboard.
  • rbb2rbb2 Posts: 70
    Is it me or is RDS just a big waste? I live in metro. Detroit and of the 18 or so radio stations we have ony 4 offer information and those are just self promoting messages such as "This station rocks". None of them give the song names as they play.

    What's worse is they add a seek type button on the radio controls which is basically useless. First you need to select the seek type at the radio. Then you seek for something and no radio stations return because no radio stations use it. Why did the manufacturers add the seek type button when you have to manually change the seek type at the radio and worse yet they took away the ability to switch to cd from the steering wheel controls. It makes no sense to me.

    Does anyone know if you can reprogram the seek type button to switch to cd instead?
  • RDS by itself is not a waste. Actually this system was developed in Europe in the 1990's (To replace their previous alternate radio broadcast channel standard, ARI) and it is widely used there because motorists heavely rely on it when driving on dense European city traffic or in highway jaunts accross the continent. Also, radio stations there have justified the extra cost and expense of purchasing and supporting RDS broadcast equipment. If you go to London, RDS support is fantastic because the way the have it setup allows you to receive instant up to the minute traffic/weather bulletins that apply to your current location as you go...it is amazing.

    RDS has been embraced very slowly in North America and few radio stations seem to have a hard time making a case to purchase and maintain RDS equipment. Very few if any have alternate channels that support traffic/weather reports. RDS (Radio Data System) differs from the old ARI system in that ARI was strictly alternate radio broadcasts, while RDS in addition to alternate radio channels allows to transmit text based messages over the standard FM radio frequencies.

    My 2002 MINI Cooper's standard 6 speaker BMW/Alpine stereo CD system is RDS enabled as well. Most new cars today already offer RDS as standard equipment in their factory car stereos.

    With the ever growing satellite Radio (Sirius, XM, etc) I am not sure if RDS will ever be popular in North America. It seems to me that Satellite radio can do everything RDS does and much better with more reliable signal and digital sound quality.

    On the subject of the steering wheel mounted controls, the "Mode" button allows you to cycle from CD to AM or FM but not viceversa. You still need to press the "CD" button on the radio to go from either AM/FM to CD or Tape. The "Seek Type" button can not be re-programmed as you suggest. All the steering wheel audio buttons have hard coded function assignments.
  • otto42otto42 Posts: 33
    RDS is a cool idea, but radio stations need to implement it more. The only one I've found that includes song names is a station I ran across in Savannah, GA. But I've noticed more stations in my area at least starting to include their call letters to be displayed for their channel. So it is gaining some acceptance, to some extent. Just hope that acceptance lasts.

    It may be a dead issue, as I predict that FM stations will probably start switching to digital broadcasting as soon as there's a good standard for that. The reaosn being that they'll think they have to try something to compete with satellite radio (which I think will inevitably fail for several reasons, although it may take some time for it to happen).
  • bh0001bh0001 Posts: 340
    CHUM-FM in Toronto includes song title and artist, brief weather updates, and brief news updates. It's pretty cool, but they don't have very many different news items.
    Brad
  • reeferreefer Posts: 37
    The same thing happened once to my 2002 Impala LS. At about 3000 miles I pulled out of the garage one day and the instrument cluster failed to light up or activate. I drove for about 10 miles with no speedo or tach or any other guages working. The turn signals worked however. Then suddenly they all came on as I was driving. I took it into the dealer and they checked the computer. They said the computer registered an "event" on that date but they could not find the cause of the problem and therefore could not do a repair. I have 10000 miles on the Impala now and the event has never repeated itself. Go figure.
  • johnclineiijohnclineii Posts: 2,287
    I hate to be the bearer of bad news, but mine did that as well...burped if you will. Two or three times, then went about 10,000 more miles, then the switch failed to light the interior lights on the instrument panel or radio any more. Turned out the headlight switch had shorted out. Make sure you have a record of the first occurrence. Then, if it happens again later, it should be a warranty repair.
  • The LS is going to be 3 next month and I am thinking about getting the GM major guard extended warranty. We have 8,000 miles on the LS and I was looking at the 6 year / 50,000 mile for about $950 and peace of mind. We plan on keeping the car awhile.
  • Had the repair, $688 to replace the upper plenum. Bit more than I expected, but no antifreeze smell since. So far this service center has treated me right. Manager thought a recall was in works for this, but he couldn't swear to it.

    Next day, a nail in tire. Went to Goodyear dealer for repair, I have the Eagle LS tires, was surprised to see the LS as rated as most quiet tire they make. Hate to see what they think a noisey tire sounds like.

    Had to take care of these as now commuting from CT to PA to MA and back to CT for next 6 months. A 2001 LS with 44k miles, first time I made this loop I remembered why I liked it so much.
  • I had the same service performed on my 2001 LS with 26,800 miles. I was driving on the turnpike doing 70mph when I heard chimes and a message on the message center saying... "Low Coolent Level". I kept my eye on the temp guage, and never did it ever get near mid point on the scale. When I arrived at my destination, I checked the coolent level in the container, and it was empty, and I smelled anti freeze. I took it into the dealer the following morning where they showed me the anti freeze leaking from the upper plenum. They had the replacement part in stock, and was done replacing it within two hours under warranty. Other then this, I really have had good luck with my car, and love driving it all the time.
  • b4zb4z Posts: 3,372
    I guess that makes 4000 of us who have had the thermoplastic manifold warp and leak.
  • nosirrahgnosirrahg Little Rock, ARPosts: 872
    Also had mine replaced a week or so ago; my concern is if this is obviously a faulty part, how it replacing it with an exact replica of the bad part going to "install confidence" down the road? Much like my intermediate steering shaft which was replaced under warranty; 30k miles later, it's starting to do the same thing again. Granted, the "grease fitting" fix to the steering might actually cure the problem, but I see replacing the upper manifold with the same part as just delaying the problem.
  • txguytxguy Posts: 57
    If you have had the upper manifold replaced on your GM 3800, I urge you to file a complaint with the NHTSA via their website at http://www-odi.nhtsa.dot.gov/ivoq/
                                     or by phone at 888-DASH-2-DOT

      Only by reporting the thousands of these repairs can we hope to get it fixed. It may have been covered by warranty the first time... what about the second and third?
  • b4zb4z Posts: 3,372
    I just submitted my complaint and I urge everyone else who has had a problem to do the same.

    You will need your VIN#.
    I put the complaint down as an "ENGINE AND ENGINE COOLING" problem.
    Since their drop down box did not have an "INTAKE" section.
  • nosirrahgnosirrahg Little Rock, ARPosts: 872
    I posted my complaint with NHSTA a couple of days ago; I think there was a pull-down for "ENGINE AND ENGINE COOLING:ENGINE"; which was the closest match I could find.

    Was just reading an article in C&D from a few months ago about a souped-up VW, and they mentioned it had a plastic intake manifold, which was supposed to be a positive thing - if other auto makers are using these, are they having problems as well, or is it just a GM (or 3.8l) issue?
  • pluto5pluto5 Posts: 618
    I posted this before, but here it goes again: could be an assembly problem, i.e., Hal is overtightening the fasteners. If it was the thermoplastic the frequency of failure would likely be much higher, and you would see Lumina and Rendevous owners posting all over the place.
  • I had a coolant leak, my dealer replaced the throttlebody gasket. It stopped the leak. But before he changed the gasket, my low coolant level warning light came on when it was suppose to (when it leaked out the coolant and caused a low level). Now it is comming on maybe 1-2 times a week at start up, the chimes go off and it lights up for a second or two then goes back off. Its more annoying than anything else, but I'm sure its going to end up costing 200 bucks to change out the sensor.. does anyone know if its something I can get to and do myself? I think the part is 40 bucks. Sure would be nice if I could do it. Thanks.
  • Well, I got my '01 Impala LS back from the dealer today. They did a real nice job - even washed the car when done. When we first brought it in for them to check out the coolant leak and order necessary parts, we got the car back full of cigarette smoke odors and cigarette ashes on the door pull. We confronted the dealer and told them this was one of the triggers for my son's asthma and this was totally unacceptable. They were totally apologetic and detailed the inside of the car. Now getting back to the coolant leak, they did not change the plastic plenum. It looks like they just changed the gaskets, antifreeze then changed the oil and filter. The parts they used were as follows:

    12480830 Gasket Kit
    17113137 Gasket Kit
    12345382 Compound
    12346290 Coolant
    25010792 Filter

    I also had them perform the repair for the flickering lights and headlights per TSB 01-06-03-005. This involved installing a regulator bolt number 10316686.

    Finally, I asked them to take care of the clunking in the ISS and they greased it per TSB 01-02-32-001A. They used lubricant # 26098237 to take care of this.

    As I drove the car home, I swear I can still fell a little bit of clunking from the ISS. Have any other owners had this repair done and found it may still remain? Does it get better or worse with time? What's the next step?
Sign In or Register to comment.