Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Trooper Alternator Problems

2»

Comments

  • hi i have a 98 trooper 6cyl im haveing an issue with voltage spikes ,it spikes at 18 and above it blew the highbeams and put the tranny in limp mode . if i put the vehicle in park and turn off and on again its fine but will spike again it fluxuates alot and sometimes stays at 18v but will eventually drop and fluxuate more . i have put many new grounds all over the vehicle but hasnt helped ive cleaned all the plug connections i could find by tranny and engine . next is to replace the alt. but ive been told by many people that the alt regulator wont fluxuate like that its either good or bad no in between . if any one can help i would really appreciate it thank you, jason
  • atfdmikeatfdmike Posts: 414
    edited March 2011
    Most certainly a failing internal regulator will exhibit the behavior you are experiencing. It may be intermittent due to the different loads it is seeing, but should NEVER be above 13.6 (14) volts...if it is, the regulator/alt is bad.
    The only exception to this would be if you removed the battery and the alt was running the systems, in which case the regulator would spike all over the place as loads changed and it had no baseline 12 Volt signal from the battery. Never disconnect a battery from a running ECM controlled vehicle of any brand. It can have disastrous results.
    HTH One guys opinion.
  • trooper97trooper97 Posts: 3
    hi atfdmike,
    I'm experiencing pretty much what ostrander was with the voltage spiking to 16 but I also have the dash light all blinking on and off while it's spiking (I can here clicking as they do under the dash above my left knee) then it will return to normal but when I come to a stop the tranny starts like it's in third gear (very slow. it's an automatic) If I turn off the car and restart it, it drives normal for a while then will eventually Start all over again. Does this sound like the alt?? or Regulator??
    Anyone else Having this problem besides me and ostrander.
    Thanks
    Vince
  • atfdmikeatfdmike Posts: 414
    Based on the symptoms you describe, and knowing that Isuzu's are very voltage sensitive, you really need to check your connections and vehicle grounds to make sure they are good. If they are and the intermittent problems keep happening, then you may have a harness that has a broken conductor/wire or the problem is the alternator/regulator. You don't say what year and model you own, but if a 97 Trooper, then the regulator is internal to the alternator, and you may wish to get a new one. Use caution in buying one as the unique construction of the alternator and quality must be good to insure the voltage and circuits work properly. There are many horror stories about new alternator problems or failures (I am one of those that experienced it) due to bad rebuilt quality or parts.
    HTH One guys opinion
  • trooper97trooper97 Posts: 3
    Thank's atfdmike, I think this will help. I'm taking it in today and will leave it with the shop for a couple of days to see if they can determine the cause. I'll let you know what I find.
    Vince

    By the way it is a 97 3.2L Sorry about that.
  • trooper97trooper97 Posts: 3
    Ok I've had the Trooper back for a couple of weeks and everything is running great! So the alternator was the problem.
    Thanks for your quick response and help atfdmike.
    Vince
  • atfdmikeatfdmike Posts: 414
    Great news! Thanks for posting your results, as it helps others down the road too!
  • My 96 Trooper Se will not hold a charge. Mechanic replaced the alternator 3 times and none held a charge. This vehicle has been going through alternators every year and now none are working. Please help!!! It will indicate it is charged and shortly the battery is totally drained. :mad:
  • 1995 Trooper LS 3.2 has what feels to be some sort of miss/hesitation and when and if I pull my 4 wheeler the transmission seems to go into creep mode after a while not want to shift and transmission light goes crazy. Also my dash/dummie lights are on (brake) and sometimes others. Alternator? Seems to test ok.

  • Nevermind....seems just like the same thing that Trooper97 was dealing with. I am just gonna replace the alternator!

  • steverstever Viva Las CrucesPosts: 41,923

    @ynotnvme, good luck please let us know how it goes!

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

2»
Sign In or Register to comment.