Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Sienna Maintenance and Repair (2003 earlier)

1157158160162163179

Comments

  • I have a 2002 Toyota Sienna with 58,000 miles. The passenger side window intermittently fails to operate. It will go up about 1/3 and then won't go down or up even with manual assist. (yanking or pushing on it). This happens no matter which switch use; driver or passenger door switch. After it rests for a little while, it will work for one or two cycles and then stop part way up or down. I don't hear the motor running when the switch is engaged.
    Has anyone had this problem and found a solution?
    Thank you!
  • jasdmwjasdmw Posts: 118
    I've had/am having the same problem with my '01. Can't narrow it down, but it seems to be heat related. When the car is in the sun, shining on the passenger side, the window opens fine. When closing, acts just like yours, exactly; goes up a few inches, stops, wait a minute or 2, goes up a few more inches and stops; wait a few minutes and then it closes fully. Closing of course happens after we drive off, so I'm guessing it gets cooler with the passing air. May be a loose connection to the motor that breaks the cct when hot and makes again when cooler. I've had it looked at once, but the problem isn't easy replicated. Anyone else seeing this?
  • user777user777 Posts: 3,341
    its possible the motors themselves have some form of thermal-overload protection such that they will not operate when drawing too much current (because of some obstruction) or over-heated as jasdmw mentions.
  • warren_pawarren_pa Posts: 1
    Does anyone know where the Compressor Clutch relay is located on a US model 2000 sienna? Looked everywhere. Clutch won't engage and cant find the relay to test it. Started after had the windshield replaced, coinciednt???? Please help if any one knows. thanks

    Warren_PA
  • innksinnks Posts: 1
    I have a Sienna 98. I am trying to recharge my A/C, my kit says I have
    to recharge from L side. I could not find out where should I connect
    my kit.

    Can you please help me.
  • paul6paul6 Posts: 14
    zeebra: Installed a Toyota brand harness onto my 2000LE.

    Had to remove the panel behind the car's jack to gain access to the wires, and used crimp type splicers to add the connector for the wiring harness. The harness plugs into the connector. My car did not have a connection for the harness prewired. Was time consuming to remove panels etc., but not difficult.

    I placed the connection in the jacks compartment rather than behind the panel for ease of diagnosing any problems that may arise.
  • wmkwmk Posts: 1
    I have the same problem with my 2001 LE driver window is scratched in the same spot. Have you found out what has caused it?
  • dbfinallydbfinally Posts: 1
    I am also having issues with the passenger side door in my 2000 Sienna XL. The window would go down without a problem but would only inch up a bit at a time. I thought it was heat related for a while but it was happening EVERY time. Of course, it didn't start until AFTER the warranty was up and Toyota said it the motor was gone and wanted more than $400 to fix it. I took it in last week and had a local mechanic fix the motor for about half the cost. However, a week later, the window won't go up AT ALL. I took it back this afternoon and the mechanic says that it's a faulty window motor and is going to replace it AGAIN first thing tomorrow. (at no charge)

    My minivan is also having problems with batteries not staying charged. Battery died shortly after the 36,000 mile warranty coverage and ate up the alternator...had to replace the alternator at 37,000+ miles. Since then, I've had to either replace or recharge the battery 4 times. Each time, the battery lasts less and less time. (first it was 13 months, then 8 months, then ONE month and the latest was TWO WEEKS) Diagnostic tests aren't showing anything and everyone (dealer service dept AND local mechanic) are saying 'it's just the battery'. This is extremely frustrating, not knowing whether or not the vehicle will once again need to be jumped. I know this is not good for the alternator but I'm at a loss as to what else to do. The latest mechanic said that "MAYBE" the dome lights are staying on a bit too long when you close the doors. But, IMO, this can't possibly drain a brand new battery in 2 wks to a month. :(

    Anyone else having battery issues??
  • santacruz1santacruz1 Posts: 11
    The Low side is way back in the engine bay. I am fairly sure that most kit hoses are not long enough to reach it. I think you have to go to a dealer to get it done. Not sure if this is a design intent that ensure a dealer will get your AC charging business.
  • don105

    Same same here only after full warm-up??? Our's is like a clatter/clunck sounds. I think it may be the valves but all I read so far is that the valves never need adjustment. The other thing it may be carbon build up. We really baby the car and it has 65,000 mile on it. Your car has only 11,000? My is due for the tune up so I will try to post back later. Hopefully it needs a good old tune.
  • mcnmcn Posts: 1
    My 2000 Toyota Sienna sat in my driveway for two weeks while I was away. On my return, I noticed a moldy smell inside the car. I couldn't locate the source and took it to my dealer. The pad under the carpet was covered with mold. A leak in the rear side window seal was finally discovered. Has anyone else had or heard of a similar problem? This is my first time on any forum & I have not yet read everything in the Sienna Pre-2003 section. If anyone could direct me to anything they think is appropriate reading and anything I have missed, I would be very grateful.
  • njguy2njguy2 Posts: 1
    This is what my 02 Sienna did this morning: The engine turns over fine, it sounds like it is starting, but when I let go of the key it does not idle. It just stops, as if I had shut it off.

    But if I turn the key on and rest my foot against the gas, it will run fine, no unusual sounds or anything, just when I let go of the gas, it dies. It does not idle at all, not even close. It does not sound like a stall, it just shuts off.

    Does anyone know what's happening before I have it towed to the mechanic?
  • loucapriloucapri Posts: 214
    I see the same problem on my 97 Camry. But it only happens when it's hot and sunny outside. It will not keep idle or sound like it's going to shut off. I can press the gas but as soon as I let go, it will die.

    Most of the time the engine will run between 400-500 rpm (want to die range) and suddenly it will go back to normal. I am thinking it's something related to the injector or fuel system. I tried to use premium gas for a while and problem goes away (for a short time) but it's coming back. I don't know what's going on either.

    Hope someone can help us on this problem.
  • abe8abe8 Posts: 5
    I bought the 2002 Sienna van in August 2001, it has only 28950 miles. Today, the Check Engine sign is on. Is it a common problem ? How much it cost to fix it ?

    Thanks
    Abe
  • deepandeepan Posts: 342
    it could be many things, Did you tighten the gas cup properly hearring a series of clicks while doing so. try reseting the light (by disconnecting your battery making sure there ae no anti theft codes on the radio !) and if it comes on after it might be a genuine issue.
  • jprocjproc Posts: 133
    When ours came on it turned out to be a sensor of some type.Cost about $ 550 to replace it.
  • van123van123 Posts: 14
    We just got back from driving form Pa. to Colorado. Our 2002 Sienna preformed flawlessly. We averaged 23 miles/gallon on premium fuel. The van was gasping for air over some of the higher passes, but did real well.
    We put on Goodyear Assuance Triple Treads 4000 miles ago, these tire are awesome. We drove with confidence through downpours. They are quiet and grip the road through any conditions.
    We have three teenagers and all their attitudes and we all had a great time.
    Can't say enough good things about the van.
    Thanks Toyota!!
  • slevyslevy Posts: 5
    Hello,
    I have a really annoying problem...
    My Sienna 2000 headlight sometime work and sometimes not. The problem appears on both sides (left and right) at the same time. The low "running lights" are working fine, but the low beam lights sometimes turns off during driving and sometimes they never turn on. The high beam lights NEVER work. It seems like when the car is "cold" the low beam lights will turn on, and after driving for a while, they will switch off and stay off for the rest of the drive, which force me to drive with the low "running lights" which are very poor in their intensity and not very safe at night.
    All other lights (indicators, tail, break, reverse etc.) are working fine.
    I have checked the fuse/relay box and couldn't see any problem. I replaced the headlights fuses (15A each) and problem remains.
    Help!

    Thanks,
  • user777user777 Posts: 3,341
    i suppose i would check to see if there is a relay associated with the headlights, and make sure that it was well seated in its socket (pull it and re-insert it).

    now if you found a relay and it was well seated but the problem remained, i'd look to see if a few functions in your vehicle might use the same (identical part number) type of relay, and i'd swap the relays to see if it was the relay itself. if the swap test worked, i'd know what relay to replace and i'd see if the local car parts store had a replacement.

    if there wasn't another to perform the swap test, then i'd probably go ahead and proceed to a car parts store to- purchase a replacement and check the operation of the high/low beams.

    if none of this worked, then i'd report my work to a dealer tech, as probably it's a switch (is it on the stalk? - or does your DRLs have another switch on the dash?) that might need replacement.
  • palspals Posts: 1
    the inside sliding door handle button will not open the door. Is there an adjustment, the outside handle works fine,

    thanks
Sign In or Register to comment.