Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2011 Hyundai Elantra

11415161719

Comments

  • roger_proger_p Posts: 1
    I have a 2011 Elantra Limited and have experienced the exact same thing! On two occasions, once at about 14K and just today and just under 20K. I've been around cars my whole life and am pretty sure I can differentiate between burned oil and carbon. This is definitely oil, blue/whitish smoke. I have two concerns that I'm going to take to the dealership. One, this is just plain unacceptable from a new car (less than a year old). I'm wondering if one of the dealership personnel had this problem how it would be handled? The second is the legal implications if this plume of smoke causes an accident. Today's episode filled 4 lanes of a busy city thoroughfare with so much smoke that the cars behind me disappeared from view. I'm taking the car in on Monday and sincerely hope that I don't get blown off with "nothing we can do for you". Please let me know if anyone gets an answer that makes sense....
  • flyingv82flyingv82 Posts: 5
    If you get a good answer to this issue, please post it on here. The 2 dealers I have visited blew me off with the "no error code means no problem" answer. I too have thought of the legal issues if the exhaust smoke from my car causes a wreck. I
  • blade14blade14 Posts: 2
    Did anyone at the dealerships check to see where your oil level was at? I took mine in for an oil change at Nashua, N.H. hyundai 2 weeks ago and it started to blow white smoke on acceleration. It turned out they had put too much oil in the crankcase at the last change. Oil leeks into the cylinder and burns off out the tail pipe. run your finger inside the tail pipe when it's cool and see if you get a oily-greasy blackness on your finger. Good indication your burning oil!
  • backybacky Twin CitiesPosts: 18,759
    Looks like it's time to find another place to get oil changes! A Hyundai dealer that doesn't know/care how much oil to put into one of their own cars wouldn't get any of my service business, that is for sure. Who knows what else they would mess up on?
  • elantra_ownerelantra_owner Posts: 2
    edited June 2012
    I have the exact same problem with my wife's 2011 Elantra with 28K miles on the clock. The first time i saw the smoke was when it had about 5K on the clock, . It happened last Saturday again. Filled a 4 lane freeway up with smoke when I tried to get into the fast lane, I am going to make sure to have a video camera in the car when this happens again. I see the last post said to check the oil level. I checked the oil level after this happened and it was good. The first time it happened I accelerated at a traffic light when it turned green, I thought I blew the engine. On the way home i tried to accelerate and gear the car back and could not make happen again. Maybe the Catalytic converter gets an oil buildup and burn it when there is more flow through the exhaust? I took it to Hyundai this morning
    and the guy at the service department seemed like he didn't believe me.
    Does anyone have an answer yet?
  • ivan_99ivan_99 Posts: 1,676
    Not being a mechanic...I don't think your catalytic converter is burning oil. If oil gets in there I think you have huge problems.
  • joltmanjoltman Posts: 2
    I took mine in today for blue smoke out back when passing.It doesn't do it all the time. Only 11,000 miles.They took a compression test and found one of the cyclinders is not up to par.They drained the oil and filtered it for metal and found none.They called hyundai and they said to replace the block.The block has been ordered.All under warranty.I had no problems with the dealership at all.
  • Joltman, I wonder if there is a way that I can use your information, maybe a case number or a job number from your Hyundai dealer that I can give to Hyundai customer services so they can look at your diagnosis and maybe get my dealership to do a compression test on my car. When I took my car in they drove it, could not see any smoke , checked the tires and bluntly refused to do a compression test. Merced Hyundai sucks!!
  • joltmanjoltman Posts: 2
    My tech line case#4901339.If you are not satisfied with their answer their is a procedure you can request in the manuals you got with the car.I would demand that they do a compression test.That car has the best warranty on the market and it doesn't cost them a thing to do this test.The other choice is take it to another hyundai dealership.
  • blade14blade14 Posts: 2
    Did you all know that the 2011 elantra's engine crank case only takes 4.23 quarts of oil. I had trouble blowing smoke out my tail pipe and discovered that every time I went for an oil change they were putting in 5 qts which would be too much. this even happened at the hyundai dealership as well as Jiffy lube. None of them realize this. Look at your dip stick and the oil level should not be over the "F" in the grid on the stick. Mine was showing at the very top of the orange. Can't hurt to check...
  • Happened again couple of days ago. This will be another trip to the dealer to have them check it out. On the phone, they practically told me not to bring it in, that the issue is large amounts of ethanol in the gas. I'm taking it in anyway and having the compression test done on it. Will post back when I get the diagnosis.
  • :cry: :cry: I think this is a problem that Hyundai needs to look into further. I have had the white smoke, loss of acceleration and rough running motor on three different occassions. I called the dealership the first time and they said to watch it. The second time I took it in and they said that the plug was loose and they tighted it....should be OK. The third time, they are blaming it on a pour oil change and said I needed to have my valves cleaned. They are in denial of the problem. I will keep taking it back until they fix it. I have had three different Hyundai cars and have NEVER had problems! Love my car, but this is a problem that they do not want to fix....don't know why they don't want to fix it, but they don't. :cry: :cry:

    Yes, this is happening in traffic when I am driving slowly for a bit and then need to accelerate. Same problem as others. Hyundai.......you have a problem!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  • I have hand this problem too. I had two incidents that really scared me because there was so much smoke. I thought they would cause an accident. They both happened with than 20K and I’m generally an easy driver. I took it into the dealership I bought it from, which is not very convenient to me. I was given a loaner and was told it was ‘stuck oil rings’. At the time, this has supposedly happened only one other time, per my svc mgr. Then, I took it for oil change at another place and an oil leak was discovered. It went back to the dealer again to fix upper oil pan. I had a loaner for over a week this time. Then just two days ago, with about 7K on this new block, the smoke happened again. My husband was driving and I though he was kidding, but I looked back and saw the huge plume. In between leak and latest smoke incident, I had the left rear strut replaced, but I think the problem is the right rear, since that is where I hear the noise. When I was there having that repaired, the svc. mgr. asked me if I had any other smoke problems and I said no. That should have told me then that something major was going on. According to Hyundai-Forums.com, the supplier Hyundai uses is putting in these faulty oil rings, others on that forum have also mentioned stuck oil rings. I have not called the svc dept. about this latest smoke incident; I’m contemplating what to do next. I have never had a minute’s trouble out of my dealer, but it’s so inconvenient for me to get it to them. I am almost at wits end with this car. I really like the way it looks; I have had window tinted, new wheels (I kept my old ones), it get looks and compliments. It’s my first and will be my last Hyundai. I drove Hondas for 15 years before and should have kept driving those. I have been exploring Lemon Laws; I live in S.C. and have the lawyer referral # handy. According to the law in S.C., the car has to be non-repairable for three times or out of commission 30 days (nonconsecutive). Neither of those has happened yet. I also saw where BBB can offer some help, but the stories on this TownHall Talk mention being alone during arbitration. Sometimes I just think I should trade it, but I’m sure I have negative equity and if I try to sell privately, I’m sure the issues would show up on CarFax. What are your opinions of what I should do? I’m apologize for rambling… :mad:
  • adlindsayadlindsay Posts: 1
    edited January 2013
    I'm not familiar with your state's lemon law so you should examine it and take full advantage of it. I have done so under MA lemon law in the past and found it to be equitable. Likely you will get a new car and have to pay a use charge for mileage on your current car. Bring it back for the third time.
  • penizepenize Posts: 6
    I have a 2011 elantra that has stranded me 3 times this week. Wont start !!!! Had it towed to dealer today and it started up fine and they said nothing is wrong with it and no error codes. Called hyundai and they gave me a case number said on third visit to dealer if they cant fix it they will escalate the case. Just looked on You Tube and there is video of the elantra not starting. Has anybody found out what the problem is?
  • hyundai12hyundai12 Posts: 3
    How many miles are on the car and does it have push button start?
  • penizepenize Posts: 6
    13,500 I love the car , but disapointed! Hyundai said I only get 2 Tows a year.
  • penizepenize Posts: 6
    Its not a push button start.
  • eng4244eng4244 Posts: 1
    My 2012 GLS just did this for the first time at 27,000 km. Huge cloud of white smoke during downshift & acceleration. Oil level is correct, no engine fault codes but I can see that the coolant expansion bottle is empty (the radiator is still full).

    Have booked the car in to a local dealer for inspection but I am not comfortable with their initial responses.

    I suspect a cylinder head gasket problem or worse.

    Although it's too early yet, I'd like to understand the root cause of this problem so that the correct long term solution is applied.
  • lhwang78lhwang78 Posts: 1
    I had this same problem twice too!! definitely something hyundai needs to look into. Anyone know if Hyundai has been looking into this??
  • penizepenize Posts: 6
    Just had my 2011 elantra in to dealer again for starting issues. This time they said a code was in system saying transmission relay switch needs to be replaced. Dealer ordered part. I sure hope this is the problem and that its fixed once and for all. They told me its a relay to the starter and it might show its in a different gear when infact its in park and that would cause the car to not start. Ill update as soon as i can...
  • Same problem happened 2X on my 2011, they replaced a defective PCV valve we shall see if this makes a differance
  • nlunanluna Posts: 5
    I have the same car..About 5 months ago I was getting my car started to go to work ( I always like to warm up my car before I drive it).. Car was parked in the garage. Well, I tried turning on the car and the car would not start.. It gave me a clicking sound the radio did turn on).. so I made sure that the steering wheel was not locked before attempted to turn it on again. No luck. so I thought, could it be the battery? but it had been 2 years since I bought it (brand new with 24miles)and I have never had to change a battery this soon on my past vehicles. They usually last 4-5 years until the battery needs to be replaced. So I had my uncle look at it right there and then.. and for some reason the car just turned on.

    So I called the dealer up spoke with my service rep and told him what had happened. He advised me that next time I should video tape it and have it towed to the dealer. (However that was not the first time it had happened to me. The first time it happened I did not pay too much attention to it because it started right after the third time I tried turning on the ignition, this was like months before this incident)

    Well, today. I started my car ( started perfectly) let it warm up for about two mins, drove to the bank turned my car off and less than 5 mins tried to turn on my car and it would not start.. tried it several times. Again, I made sure the steering wheel was not locked. So I did what the Hyundai service rep advised me to do. Video tape, called the Hyundai road service to tow it to the dealer. Unfortunately he had to turn it on by jumpstarting it(which I did not want him to do that, and I told him not to because that way the dealer can see the issue them selves ) BECAUSE he said that the last time a man tried to tow the car (for what ever reason) got injured while trying to put the car on his tow truck. He said that the hook the car had in the back got detached from the vehicle and cause the car to roll down, injuring the poor man.

    So I called my service rep from Hyundai and told him he needed to start the car as he did not want to take any chances. Which I understand, but unfortunately for me they don't get to see the issue themselves.. I'm going to the dealer in a few minutes to show them the videos I have.. but I thought I would reply to you before I go. I will keep you posted on what they say...
  • nlunanluna Posts: 5
    Please keep me posted.. I had a similar issue.. I seriously think its a vehicle defect.
  • nlunanluna Posts: 5
    So you and I seem to have the same issue. you should look at my post #585 ( I am not about to retype.. But here is the out come..
    I went to the dealer to show them the video. The car had not been worked on yet.. so I was like great maybe the video can help them determine more less the problem.
    Well I after talking with my Rep., explaining to him the who scenario, telling him how I don't think it has to do with the battery AND showed him the video. He tells me "I think it might be a battery problem". So I tell him about the second time it happened to me and I took it in to him to have I looked at and he told me at that time that the battery was good and there was no problem wit the car. I explained to him how I think this was such an inconvenience, I bought the car brand new and I'm already having problems, well we argued a bit more.. I even told him about your situation and printed your blog and he said Hyundai does not use Blogs as a part of a technician diagnostic. I said "ok, that's fine, Im just telling you that someone else had the same problem. I will just make sure that the manufacture and corporate know about this." So I leave the car in to find out the issue.. about two hours later they call me back and tell me that it is not the batter its a problem with the fuse box and that it is covered under warranty. Since they didn't have the part they needed they provided me with a car rental and told me I will be picking up my car Tuesday or Wednesday. NOW LISTEN TO THIS...I leave the dealer to go pick up the car rental and I'm driving home.. Forgot I forgot my school permit was in the car.. this was around a bit after 5.. so I called them up and spoke with the receptionist and told her I needed to go back to pick up the permit she said that was fine.. I go back and my rep helps he and tells me that the he will take me back to my car so I can get that myself.. the garage doors to the service facility had been closed and no one around the inside of the garage. Well as I go see my car I see that the car is battery is turned ON ( the radio light and clock were on)!!.. I grab my pass and tell my rep. I don't think its normal for my car to be on.. so he goes in takes the key of the ignition and closes the car.. I am totally calling corporate Tomorrow as I tried to do it today and it was closed!.. Ill keep you posted on what happens,, But If I were you I would definitely fight for any extra towing expenses you have paid for..
  • nlunanluna Posts: 5
    My reply to : Re: 2012 Elantra White Smoke 22,000 miles was a mistake.. I'm not having this problem I'm having electrical problems... I tried to delete it but I don't know how...
  • penizepenize Posts: 6
    Hi there had the same issues had car to dealer 2 times towed once. Third time,they told me a code was in the system saying that it needed a transmission inhibitor switch, this switch tells the ignition what gear the car is in, so you might have it in park and it is telling the inhibitor switch is telling ignition that car is in drive and it wont start. They found this code only on 3rd visit. The part was ordered and installed and i have not had any issues with the car not starting so I feel confident it is fixed for now. Its been about 3 month since repair. Hope this helps.
  • nlunanluna Posts: 5
    Hi. Thank you so much for the reply, It is helpful. I'm glad t hear that your problem has been fixed. I did call corporate today and advised them of the issue jus so they can keep that in record incase more people have the same issue then they can do a recall for it, or something. I'm not sure if I mention this but we have the same year and model vehicle. Well, I hope my car comes back to me with the issue resolved, because I love it and I would not want to trade it in. I hate car payment.

    Keep me posted if anything. Lets hope we don't have to come back to this site again a research for anyone with similar issues.

    Thank you again and take care,

    N
Sign In or Register to comment.