Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2005 Mercury Grand Marquis Rough Idle

lemkolemko Posts: 15,196
edited July 19 in Mercury
I have a 2005 Mercury Grand Marquis that starts with a fast idle and then settles to a rough idle after 30 seconds and then smooths out after the engine warms up. Still, it isn't very smooth when the car is stopped in traffic. Occassionally, the car will stall out when stopped at a traffic light for an extended period.

There are no check engine lights on the instrument panel. I use Sunoco Ultra 93 fuel in it and a periodic injector cleaner/fuel additive. What's happening?

Comments

  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,333
    Without knowing the mileage or being there, hard to say.
  • lemkolemko Posts: 15,196
    The car has approximately 86,200 miles on it. The fuel filter was changed back on July 31 as far as I can recall.
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,333
    Without illuminating the CEL, but with 86k, it would not surprise me if it needed new plugs and wires.
  • jmsmeierjmsmeier Posts: 2
    Sounds like one of two things. Either a COP (coil on plug), or a fuel or head temp. sensor. When the car stalls do you have to let it sit for a while (cool off time)? if so its probably the head temp. sensor. If not a dwnld of ecm will show a bad coil, or fuel temp. sensor. Auto zone will dwnld. for free. These sensors don`t always set off the check engine light, so don`t rely on that. Hope this helps, Jim.
This discussion has been closed.