Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Radio confusion...on a 1995 Grand Plymonth SE 3.3LV6

pa356228pa356228 Posts: 34
edited 1:21AM in Chrysler
Ever since I brought the van, the radio, well, it's a AM/FM Cass player and has somekind of shorting out problem. Just brought fuses yesterday, haven't replaced them yet. Can't tell if that's the problem or if the Antenna needs replace or the radio.

Any suggestions?

Also, just brought the van about 4 months ago, it runs smooth but do need some TLC, the guy who sold the van to me, didn't took care of the van that much. Surprizing he replaced the exhust and muffler.

Comments

  • sayr811sayr811 Posts: 1
    I had the same problem with my 95 voyager. Then one day I left my lights on and my battery died and I removed the battery and charged it for about an hour and when I reconnected it....the radio worked perfectly and has worked ever since.

    Give it a try
  • pa356228pa356228 Posts: 34
    What size Fuse Amp does your van use for your radio?

    All the fuses in my van are good, for some reason most of the fuses ar 15 amps, but the advance auto parts gave me 10 amps. Not sure if that will make a difference or even safe to use smaller amps than recommended.

    I haven't tried your way yet, might have to just do that. There is some corrosion on the termnials, so I would have to disconnect the battery, clean the termnials and reconnect the battery and see what happens. The battery is only about a year old.
This discussion has been closed.