Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





CEL Codes P0715 and U0155

tlewis3tlewis3 Posts: 1
2006 Mazda3 just under 33k Automatic Transmission - The CEL and AT are on. The diagnostic "temporarily" pulled P0715 and U0155. I say temporarily because the mechanic reset and could not reproduce the issue, and insisted that everything was fine. He told me to "just keep driving it" and to bring it back if it happened again.

I parked it over the weekend and on the way home from work the CEL and AT are back on, and it didn't want to come out of 3rd. What is recommended? Should the Speed sensors be replaced? I can't afford costly repairs and since I don't know anything about cars I want to at least know what to expect to pay. (I've been badly ripped off with repairs before, and I don't have that much money)

Another mechanic that I talked to implied that it would be very costly and suggested that I try to utilize the Fed Emissions Warranty. I'm not even sure that one thing has to do with the other, but I'll try it!

Any suggestions or advice will be very welcome. Thanks in advance.

Comments

  • autonomousautonomous Posts: 1,769
    P0715 = Input/Turbine Speed Sensor Circuit Malfunction
    U0155 = I could not find a listing for this OBD code

    I would first confirm that the same codes appear. If you fix one problem and not the other, you may not be further ahead.

    Regarding P0715 (speed sensor problem), PartsTrain.com quoted a price under $50 for the part. In terms of labor costs, I don't know how difficult it would be to replace it. Based on what I've gleaned, the engine speed sensor affects your car's cruise control and ABS functions.

    Personally, I would bite the bullet and bring it into the shop and get the news, it may not be as bad as you think.

    Good luck!
Sign In or Register to comment.