Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Maxima Maintenance and Repair

1106107109111112136

Comments

  • dmaljunkdmaljunk Posts: 160
    many people get ECM replaced, it's just another part. If you don't get it replaced then you can't really drive. ECM is responsible for air-fuel mixture based on inputs from a couple of dozen sensors. And you can't sell the car like this either. I'd say you should try to get it replaced under warranty and make sure they program it with latest updates.
  • rafarafa Posts: 35
    I we have a 2005 nissan maxima se with 9500 miles and we ran over some road tar on sunday and now the car is vibrating really bad called dealer and said they cant help us. They said we need a new tire can someone please help thank you
  • dmaljunkdmaljunk Posts: 160
    Is there something stuck on the tire thread or did you damage your suspension? If it's tar on the tire then take the tire off and clean it, you can use tar remover sold in any parts store.
  • terraboiterraboi Posts: 2
    I have a 2001 Maxima, and when the car is stitting in park or drive the a/c blows normal cold air, but when I accelerate the air gets HOT. Any suggesstions on what the problem might be?
  • my check engine light just came on ,onmy 97 maxima se with 104,891miles any ideas
  • I wish I was writing with an answer. I have the same exact thing. It is making me crazy and costing a lot of money. Did you ever find the problem? I don't see many answers but I seem to see a recurring theme with the same frustration. I replace the crankshaft sensor but still have the problem- two starters later- and Nissan can't locate the problem. Please let me know if you have any info, ideas, help.
    thanks
  • gtwgtw Posts: 46
    sounds like a knock sensor. Run the diagnostic code test to see which number it is.
  • kposty007kposty007 Posts: 5
    I RECENTLY BOUGHT A '02 MAXIMA 6 SPEED AND I'M GETTING A CLUNKING NOISE FROM WHAT SOUNDS LIKE MY TRANNY. IT'S NOT HAPPENING IN 1ST GEAR JUST 2ND 3RD AND 4TH, AND ONLY AT LOW RPM LEVELS. I KNOW IT'S NOT FROM MY DRIVING I'VE NEVER OWNED ANYTHING BUT A MANUAL TRANS. IS THE FLUID GETTING LOW OR IS IT SOMETHING SERIOUS?
  • grady3grady3 Posts: 1
    I have a 2001 Maxima with high mileage 160,000 that is doing the same exact thing with respect to the A/C. I had the radiator coolant & the thermostat replaced but it hasn't improved. also my fans are running fine & the A/C is blowing at 40 degrees but within 5-10 minutes of use it starts to over heat & when I turn the A/C off it goes back down. If I find something out on the Web I will post again.
  • dahuberdahuber Posts: 53
    Check tightness of gas cap. Otherwise, hook up a code reader to get the error code. I own my own reader, but I've heard Autozone will do this service for free.
  • THANK YOU ,NOW THAT YOU MENTION IT. IJUST FILLED UP
  • pnouranipnourani Posts: 2
    I have a 2000 maxima SE with 74,000 miles on it and I got a check engine light on. I took it to autozone and scanned it and it read that it was an 02 heater circuit malfunction (bank 1 sensor 2). I bought the sensor at another store because i can get it wholesale, and gave it to a mechanic to replace it, and after everything, the mechanic said the light came on again and that problem is not the sensor itself. The next day he told me he spoke to a nissan dealer mechanic and they said it might have to do with the ignition coils? Is this true? Can anyone tell me what is going on with this sensor?
  • kposty007kposty007 Posts: 5
    I HAVE AN '02 MAXIMA AND HAVE RAN SOME 87 GRADE GAS AND A SERVICE MANAGER TOLD ME MY NOISE WAS COMING FROM RUNNING THE 87 GAS. SOME TYPE OF FIRING PROBLEM? ANYONE ELSE HAD THIS PROBLEM OR IS HE WRONG?
  • dmaljunkdmaljunk Posts: 160
    bad gas can cause pinging, when you step on the gas you hear a metallic ping ping ping as the car accelerates.
  • dmaljunkdmaljunk Posts: 160
    Generally, ignition coils are bad if you get code P1320 with or without cylinder misfire codes P1301 through P1306. So, no, it's not your coils and you will spend less money if you listen less to Nissan mechanics. Replacing coils is the type of repair where it's "good" for your car and you can never prove that you didn't need it and just an FYI, each coil is $75 at the dealer and they usually insist that you "must" also replace the spark plugs and you end up spending $800. It looks like you got another code for oxygen sensor. Why don't you post the code you got and let people here share some opinions on your specific code.
  • pnouranipnourani Posts: 2
    The code that my 2000 maxima is giving is (P0141) 02 heater circuit malfunction bank 1 sensor 2. So now they told me that after they replaced that sensor, now it is giving an error for bank 1 sensor 1, and after they replaced that, it gives an error back to the first sensor again. So now they figured the problem is not the sensors and they want to take the car to a nissan dealer and have them erase everything from the computer memory and re-program everything again, and that might make the errors go away. Oh ya, they want to charge me $175 to do that and if that does not work, then I lose money!
  • wasa02wasa02 Posts: 3
    It could be the gas but more importanly you need to check the oil. My problem started exaclty like that but I always put 91 in my 02 Maxima. I took the car to the dealership over 10 months ago and they told me it didn't have any oil. The oil was changed on schedule. Long story short the "clinking noise" would occur every two months followed by the check engine light. As a female, the dealership fought me every step of the way but the engine was consuming to much oil. The ONLY way to fix is to replace the engine. After 10 months the new engine was ordered and covered under my warranty. I was getting it put in on Tuesday but the car was totalled :sick: (not my fault)on Saturday. Check to oil regularly and DEMAND a new engine if it is consuming to much! :mad:
  • wally9mmwally9mm Posts: 3
    I just brought my 2K SE Max to get it inspected.

    They put it on the lift and told me that it needs front and rear struts for $1100 plus 4 wheel alignment and tax. Total around $1300.

    I declined the service saying I'll have to bring it back when I have more time.

    Should I think about replacing the struts? I think the car rides and handles just fine.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,804
    And how, pray tell, did they determine this while the car was on a lift?

    MODERATOR

  • wally9mmwally9mm Posts: 3
    They lifted it, poked and proded. shook this grabbed that and determined it needed all new struts.

    During past inspections, they would replace things like the wipers, highbeam or a fan belt. They make a lot of profit replacing small items that may be hard to dispute.

    But over a grand is a bit much for me to swallow.

    I always dread inspections because if business is slow, they can always find something to service.

    Last year it was inspected by a tire distributor. Guess what...they sold me two new tires because they said one of the rear tire treads had a cut and would only pass it if I replaced both. Thats why I hate inspection time, whoever they are, their in the business to mo' money.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,804
    No, I don't THINK so!

    A strut can only be tested by either showing you where it is leaking badly, or by driving the car. If your struts are really bad, the car will POUND on hard bumps and feel very squirrely going around turns or while hard braking.

    The symptoms of bad struts are not subtle.

    MODERATOR

  • tobinaztobinaz Posts: 4
    CAN ANYONE HELP ME LOCATE BLOWER RELAY THAT IS STUCK ON HIGH SPEED. I ALREADY FOUND ONE BELOW GLOBE COMPARTMENT BUT EVEN IF I DISCONECT IT BLOWER IS STILL RUNNING.

    ALSO, ANY OTHER SITES WHERE I CAN FIND VALUABLE INFORMATION FOR MAX REPAIRS

    THS.

    :cry:
  • WENT TO AUTOZONE FOR DIAGNOSTIC.CAME UP WITH SPARK PLUGS AND KNOCK SENSOR.JUST MORE REGULAR MAINTENANCE.CHANGED PLUGS .THE KNOCKSENSOR WAS EXPENSIVE COST FOR PART $135 AND A LOT OF WORK .CAR BACK RUNNING IN TOP SHAPE . CHANGED OIL AND AIR FILTER AT SAME TIME AS LONG AS WAS DOING WORK
  • trey1013trey1013 Posts: 1
    Allright i know this seems crazy,but i've seen plenty of posts about about starting issues in the cold. i have the opposite problem. My 98 Max with 140,000 miles wont start in the warm weather, i can turn the key and all of my lights come on but i'll get nothing (doesn't even attempt to turn over or crank at all). It always eventually starts which may mean 2-3 tries later or as much as 20-30 tries later.I do nothing different to make it start, it just seems that all of a sudden a small miracle occurs and it cranks right up as though nothing is wrong.I do not have this problem at all i the winter. This car has been a dream for me with very few problems since i purchased it in 99 other than regular maintainence.however I'm getting a little tired of sitting in my car for 15 minutes soaked in sweat waiting for my daily miracle.Any suggestions???
  • coommcoomm Posts: 1
    There could be two reasons in addition to what others may have mentioned.

    1) Mass Airflow Sensor (Approx $200)
    2) Engine Knock Sensor (Aprrox $500)
  • holmes12holmes12 Posts: 3
    I have a 1991 maxima Coming off the interstate it dieded,Batt good i try jumping it still on go. when i turn the key nothing not a sound. light,horn, radio and all other power work. please help!!!!
  • holmes12holmes12 Posts: 3
    I have a 1991 maxima Coming off the interstate it dieded,Batt good i try jumping it still on go. when i turn the key nothing not a sound. light,horn, radio and all other power work. please help!!!!
  • jason2005jason2005 Posts: 1
    99 MAxima GLE, 5 speed. 145K miles. have being running fine until yesterday. the car won't start in a hot day after I refilled at gas station (#89 gas). towed to a mechanic, the mechanic checked and told me: fuel, spark and air all looks fine. the car cranks like normal. the mechanics suspect and order a the remanufactured ECM ( engine control module or called ECU) for $800, however the car still won't start.
    and mechanics is out of idea what's the problems

    so I'm going to have it towed a nissan dealer. what should I check
    the make sure the dealer do it right this time? what if dealer want to
    replace ECM again? thanks.
  • lntlnt Posts: 189
    My son has a 99 maxima. He bought it used and has no book. Does anyone know if it has a timing chain or a belt and when does it need to be changed? He has 115K on his car.
  • DAVID VS GOLIATH
    2002 NISSAN MAXIMA
    I’ve had my headlights stolen three times, the stolen headlights are only part of the problem the real problem is how easy it is to get into the Nissan Maxima. Due to the design of how the door handle is attached to the door, with a flat head screwdriver the thieves pop out the driver side door handle to get to the electronics which allows them to lower your windows, unlock your doors and disarm the factory alarm so they can get into your vehicle and pop open the hood to get to the headlights without damaging them and taking what ever else you may have in your vehicle. This is more then a headlight problem, it is a flaw in the design of this vehicle. And Nissan is unwilling to except responsibility. Shame on you Nissan, you have lost one more loyal customer.

    I urge everyone that has or had this problem to call Nissan and file a complaint 1-800-647-7261 and just don’t stop there file a complaint with the Consumer Reports www.consumerreports.org and the Better Business Burrow www.bbb.com anyone you think that can help us little guys with this problem.
Sign In or Register to comment.