Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Maxima Maintenance and Repair

1145146148150151204

Comments

  • I just put a cat back high performance exhaust on a 1997 I30. Now the car is suffering in MPG and does not seem as powerful as the OEM system. Releaving backpressure should have the opposite effect. Any thoughts?
  • I just replaced my original rims with new ones, and I am willing to sell them to anyone who might need them. Three of the rims are in good shape and the fourth has a small dent. Let me know if anyone is interested.
    Thanks
  • I have a similar problem. It appears to occur more often in the winter months. Maxima 2000 115K miles

    Has anyone given advice?
  • rodjrodj Posts: 2
    I have a strange problem with my '02 maxima,the check engine light comes on at various times but will always go off if I fill the fuel tank, the dealer has scanned the computer twice the first time they said I need one of four o2 sensors at almost two hundred dollars, the second time I was told it was the mass air sensor,I am reluctant to purchase either part with out knowing for sure which if ether part will fix, it.has anyone else had this problem and if so what is the real fix ?
  • rodjrodj Posts: 2
    some auto parts stores will connect a code scanner to your car and tell you what sensor made the light come on then you can buy the part and install it yourself,have a friend install it or at least know whats going on before you take it to a repair shop, when they find out that you have some knowledge of whats wrong with your car you will have a better chance at getting a fair deal .
  • Thank you very much, I will copy your message and take it to the dealership.

    I went to the dealership again this afternoon and the owner of the dealership told me that one of the many owner with this problem traded his car because of this problem.

    Thanks again, have a great Holiday season and a great New Year.

    Wayne12
  • My 1999 Maxima had a check engine light coming on periodically. Usually it came on after a rough start – felt like a cylinder was not firing for a minute.

    The mechanic we use, who is a magician with Japanese imports, knew right off it was a problem with the ignition coils. Since the problem was not serious at first, we put it off for a while. Eventually the problem got worse and gas mileage went down, so we had him replace the coils at 100k miles. Cost was about $670. Problem seems to be gone.
  • I have a 92 Maxima that has not been used for about 1 year. When I try to start it the engine turns over normally, but will not fire. Once I have tried and then leave it for about 1 hour it will fire and run but then cuts out. Assume that it is running on 'fumes'.
    Any suggestions to the problem. One has been the fuel pump but if that is the case why would there be fumes?
    Thanks for any thoughts.
  • rln1rln1 Posts: 11
    The crimped (upper) fitting of the power-steering-pump high-pressure hose leaked, so I had it replaced. The system was bled according to the service manual, by raising the front end and slowing adding fluid. (Note: there is no bleed-screw.) Now, a soft humming sound comes from the pump and changes pitch slightly when the steering wheel is turned to its limits. This probably indicates air in the system. The fluid level in the reservoir goes down very slightly every few days. But there is no visible sign of leakage. The power steering works perfectly. Any ideas?
  • Thanks again dmaljunk, I went back to the Nissan dealership today with your information and lo and behold went they went to the 2004 Maxima FSM, K and LS the directions were right there just like you said. The service manager wanted to charge me for the correction since I' in the 13th month, but the owner said 'no charge, you have been here 5 or 6 times' over the past year with this problem.

    I still can not believe that a dealership would not know how to aim headlights and start an urban legend that 'they can not be adjusted'. Owner was embarrassed over this and offered an apology.

    Wonder if they will contact the other owners who need their lamps adjusted? Bet they don't.
  • One additional question,dmaljunk the dealer thinks he can use the wall instead of the screen. Can you tell me something about the screen and if it is necessary or not, thanks. wayne12
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,404
    It's probably running on spoiled rotten gas for one thing. You might try draining your tank or at least putting in fresh gas and some water-absorbing chemical. Also change out your fuel filter.

    MODERATOR

  • I was driving today and my car stalled twice. The battery had recently been replaced. The radio and everything didnt die as if the battery had gone dead but the gas pedal basically locked and the power steering went out. I basically just pulled over and put the car in park and restarted and it started and drove fine again. Then about 10 minutes later it did it again. This time while i began to accelerate it just went dead as it did earlier and i had to restart again. Any ideas on the cause of this??? After those 2 times the rest of the drive home from work went fine.
  • Thanks. That was one thing that I had thought about. Thanks for confirming for me. I'll certainly give that a try.
  • Did you find a solution to this problem? I have the exact same thing going on with my 2000 maxima SE. I have been removing the eng cont 2 fuse everytime I stop somewhere to shut the damn thing up. How could an engine mount be the issue? Im just trying to find some logic in that. Please let me know if replacing the motor mounts fixed the issue before I do the same. Thanks
  • Hi All
    I have a 92 Maxima GXE auto trans. The problem is when I step on the gas to accelerate, the rpm will climb all the way up to 4k or even 5k (depending on how hard I step on the gas) but the car will NOT move. Nothing! The speed remains the same. This had landed me in quite a few close calls when I needed to accelerate away from traffic but couldn't. I have replaced TPS, fuel injectors, distributor & coil wires, air filter. I don't know what else to do. Any input is greatly appreciated. Thanks.
  • dmaljunkdmaljunk Posts: 160
    I am not sure about that. I can send you the diagram on how the screen should be used via email. I am not making much sense of it myself. Your email is not listed, send me an email and I will reply with the diagram.
  • I tried to send you my email but the site pulled my email address, I clicked on your name but no email, when I go to send an email I need to know your email address in order to send an email....I don't know how to get your email or for you to get my email address....help.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,404
    he can just click on your name. It shows up, I checked. We ask people not to post their e-mail addresses publically because "spiders" crawl the site from spammers and you don't want that.

    Or, you can just ask him online to click on your name and send you an e-mail with his address.

    MODERATOR

  • dmaljunkdmaljunk Posts: 160
    Ye, both of our emails show up as private. Without spelling out mny email address, it is my user name at this form and just attach @yahoo.com
Sign In or Register to comment.