Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Maxima Maintenance and Repair

1172173175177178204

Comments

  • Hi, I'm having similar problems and am considering re-keying but I'm worried I will have the same problems as you. What ended up being the final diagnosis?
  • My '91 maxima ,w/202k, speedometer stops working sometimes.The needle just pegs out and the odometer stops working.Any ideas on what could be wrong and the location of the part that needs to be replaced.Thanks
  • cowanscowans Posts: 4
    Update: When my son's dealership diagnosed a MAF, they said he had a lean condition, and promptly stated he better change out the MAF, before the lean condition killed his CAT! He called looking for help;, I sent him a good MAF, and instructions on changing it out, (cleaning the throttle body, etc)! He succeeded, and drove back to the dealership to reprogram the idle, etc. (I'm told that it probably wasn't neccesary, but advised him to 'kiss' the stealership's [non-permissible content removed] and do it! (that way there is NO excuse!). Well....The codes are still there!!!!
    On another forum, a member stated that those 2 codes actually percieve that the engine is running rich!!! WTF! Spoke with my son this am. Still the same codes (P0132,P0152) and uneven idle (possible stumble) after MAF replacement and re-program. I suppose running rich would probably be fouling plugs at idle and therefore creating a stumble at times..... He also stated that his gas milage is down, a little better after Maf replacement, but still below his norm! Anyone with suggestions on why this 03Max is running rich??? What else can I check/verify??? Any guesses???
    thanks, Sandy
  • kwk1kwk1 Posts: 39
    Sorry to hear the MAF didn't solve too much Sandy.
    Coils and O2 sensors come to mind with a rough idle and poor gas mileage. they are known problem parts on 02/03
    Maximas along with the MAF. The Idle Air Control (IAC) valve can also cause an unsteady/rough idle.
    Good luck and keep us posted. :)
  • Dirty injectors can also cause this symptom as well. Frequently driving the vehicle with less than 1/4 of a tank and especially less can cause rough idling as well. It's something which most people neglect to think of plus it's a cheap alternative to buying pricey sensors. The best product on the market is called Guaranteed To Pass (G2P). You can get it at O'reilly auto parts or autozone. Not only does it clean your injectors but also dirty valves. Of all the b/s fuel injector products on the market, this stuff actually works. Besides, for $10 you might as well give it a try and even if it doesn't work at least you'll have cleaner valves and injectors. And btw, don't let the dealership trick you into spending $400 on an injector flush, it's a scam and only needed in SEVERE circumstances. Good luck
  • mitechmitech Posts: 3
    I have a 93 max dohc with the sonar II suspension. and right now the left side is all the way down, but this morning the front end was all the way down. is it possible there is a bad relay? I really don;t know where to begin.
  • tb4metb4me Posts: 41
    How in the [sam hill]do you get to the back 3 plugs? Front 3 are very easy. All help appreciated!! :confuse:
  • I have an `04 maxima, I took to dlrshp for oil chng. They clld and adv the sprk plg needed chngd also. I don't know the lifetime of them,so told them to go ahead. When I picked up the car, I was told they may hv splld some oil in the sprk plg and there was smoke burning off. Well, there was smoke, but it was coming from the exhaust. Two weeks later, I checked the oil bcs the car was still smoking. I had no oil at that point. I added and since still smoking 2-3wks later, chkd oil level again. Mch sd that since I was late on an oil chng there was a lot of sludge and needed to have the car flushed every 500ml. I did NOT do that! It sounded ridiculous. I took to another mech and started the car for him (by now there was a rattle in the engine)He said sounded like there was something dropped in the spark plug (chamber?) Anyway, now the engine cylinder is blown and dlrshp still telling me due to dirty oil.....help I don't think that it is possible that a car with 16,000 miles should have a blown cylinder just from missing an oil change! Thanks.......badmax :sick:
  • patpat Posts: 10,421
    Welcome to CarSpace! I hope we can help. And I really hope that our knowledgeable members are better at deciphering your shorthand than I am!! :sick:
  • ytimytim Posts: 1
    I have 1996/Nissan Maxima/GLE/V6/3.0 Automatic Transmission/100K mileage.

    Recently I am getting problem with My vehicle code error "P0500" (Vehicle Speed Sensor). 1st time my mechanic got in his meter codes are P0500 and P0600.At that time he changed my Vehicle speed sensor with new VSS .

    After I drove my car for 3 days again I got check engine light. My mechanic checked again on his meter and got P0500 again.He Said he will findout solution. But He did get solution.

    Please Auto Professionals help me on this.

    When he was checked my car, meter has reading 1700RPM and 0 MPH
  • I have a 2000 Max SE 5 speed with 102.5 k miles on it and the car was exhibiting the same symptoms that you are describing. The car needed a new clutch assembly.

    Today I had my mechanic change the retainer, clutch disc, bearing and clutch cover (approx $ 300 worth of parts from the dealer) and now the car drives like new. The dealer here in NYC wanted to charge $ 660 in labor plus parts and tax, but I got a local guy to do it for much less.

    Its also a good idea to have the flywheel reconditioned once you have the transmission torn down and that can be done for fifty to seventy five dollars.
  • Had same problem with 95 Maxima, MAF fixed the problem. I am still left with the tachometer jumping when getting past 2500 rpm, it just jumps up and down 2500-2900-2500 continuosly, speed is not changing just RPMs. Any ideas?
    Before replacing the MAF the tachometer was not getting pass 2000 RPMs even though the car was going 70MPH it just hit the 2000 rpm ceiling and stayed there. After the MAF it goes smoothly to 2200 shifts smoothly down but when you reach 2500 it stars jumping, jumping. Does not bother me that much but would like to fix it if it is cheap. If not then I'll just put black tape over the tach and forget about it.

    Thanks
  • I would like to know how many people have had trouble with their 04 & up front Struts? I have 9 pages right now from the NHTSA website (www.nhtsa.dot.gov) of complaints about them. I baby my Maxima. I bought it a month after they came out in 2003. I only have 23,900 miles on it and for the last 8 months have had a rattling noise from the front. Now I am having a clucking noise. Had my husband checked them out and the left side is going. Took it to the dealership where I purchased the car three weeks ago and they claimed they couldn't hear the noise. Supposily they put it on the rack and said they were fine. Well, now my left one is just about gone. After reading forums of people complaining and the NHTSA website complaints, I am wondering why NISSAN has not recalled these pieces of junk struts. Also, these cars have the crappiest rotors and brakes!

    MACPHERSON STRUTS STINK! :lemon:
  • I baby my 04 Maxima SE with only 21000 miles on it and have had new struts, rotors, brakes and tires(original tires pretty much disintegrated). I also had a big problem with the antilock brakes that kept disengaging whenever I applied the regular brakes. That took 3 trips to the dealer (3 days,7 days and 1 day)to fix that problem. Struts and ABS covered under warranty but that is up in a month so I'm not sure what I'm going to do. Anyone else have problems with their ABS--seems to be triggered by the cold weather?
  • my bose radio display light does not work
    anything i cant do beside replacing the radio?
  • is there a way to disable the security feature of the chip in the key. the one that starts the car? Per the dealer, my keys need to be "reprogrammed" (even though it starts up fine). Now that it is 7 years old, I'm not too worried about it getting stolen. Is there a way to disable this security feature? Thanks.
  • It's not an easy task but here's what i found on the maxima.org web site. it's step-by-step with photos: http://www.greghome.com/Greg%27s%20Garage/2002MaxSE/SparkPlugReplacement.htm
    Also, remember not to put in cheap plugs; stick with NGK platinum (~$10 each).
  • Ihave 210,000 miles on it. Never had a problem with it till the other morning i went to start it and it wouldn't. I put a new battery in it and still nothing. My lights, radio work. It'll atempt to start then dies right away. Any ideas? :confuse:
  • I thought I read about the ABS problems also on the government website www.nhtsa.gov. Go to the site and see if you find it?
    I took my car back to Nissan and they supposily didn't hear the clunking noise, even though my husband saw the left strut leaking and four people have ridden with me heard it, the service manager is really nice though and call NISSAN and asked since I am such a good customer and the car has only 23,900 on it at almost four years old would they do a "good will" service on the struts. Nissan refused. So, I did a complaint to the goverment website on this problem and also I am writing Nissan a nasty letter with information I found on 10 pages of complaints on the struts, brakes and rotors and mailing it to them and saying I will never buy a NISSAN again. By the way my husband went to an out of town Nissan dealership and bought the struts for it, put them on and I have not more clunking noise or the steering wheel does not shimmy!
  • I posted this but did not see it go up on the screen so i'm doing it again i have a 2005 maxima i have been getting a average of 17.5 mpg. I just had 22,500 mile service they also gave me a fuel and oil additive, since that service i have been averaging 13.4 mpg. The dealer said to change my octane it can't be anything he has done. Any ideas out there
Sign In or Register to comment.