Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Impala "REDUCED ENGINE POWER" message

1131416181927

Comments

  • behrcubbehrcub Posts: 1
    edited February 2013
    :sick:
    I always research a problem to find the best solution. I have read page after page of posts from people who are experiencing the exact same problem and are finding little to no help from GM unless they hand over hundreds of dollars to their local Chevy dealer. This can't be good for the Impala brand. My car is also experiencing frequent engine lights, service stabilitrak, and reduced engine power messages. This causes rough shifting and very poor performance. I have a 2011 Impala LT with 67,500 miles on it. This car is too new to act this old. My old Toyota had fewer problems at 333,000 miles.
  • I have a 2008 Chevy Impala and my car just started giving me the same issues. Did you get a solution from the dealers?
  • Not yet, they diagnosed it as a bad throttle positioning sensor, and have ordered the part (and the corresponding gasket), but can't get it until Monday. I will hopefully pick up the car on Monday and have no more issues, we'll see. I will keep everyone posted on the cost and if it happens again.
  • gmcustsvcgmcustsvc Posts: 4,003
    Looking forward to hearing an update from you on how everything works after the sensor replacement, annoyed10.
    Sarah, GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,003
    behrcub,
    We're sorry to hear that you're having troubles with your Impala. Are you planning on getting this checked into with a dealership?
    Sarah, GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,003
    frenchy79,
    If you want for us to check into this further with you, please don't hesitate to contact us via email. We ask that you include your name and contact information, the last 8 digits of your VIN and mileage, and a summary of the situation.
    Sarah, GM Customer Service
  • I purchased my 2011 Chevy Impala Lt. with 31,000 miles on it. I was on my way to work when the Reduce Engine Light/Servce Stabilization Trac/Engine light came on. When you turn the car on , it sounds like a vacuum is on. I went to Advanced Auto where they ran a diagnostic on the car and told me that the (Throttle Position Sensor) was going bad (Codes-P20/21) and that this was a dealer part. I then went to Grays Chevy dealership and they told me that I would have to buy the whole Throttle assembly which would be ($399.00 plus tax) and with the labor, it would come out to $500 plus. I have a 100,000 powertrain warranty which I thought would be covered only to be informed that it wasn't.

    I purchased the part and had it installed and for (1) day, the car sounded fine. The next day on the way to work, going up a hill the Reduce Engine Light/Servce Stabilization Trac/Engine light came on again.

    I would really like to here what GM is doing about this problem that thousands of people are having with there chevy impala's. I figured if I bought a fairly new car, that I would not have to deal with these problems. I guess I was wrong
  • I just had this happen to me also. Took it to my buddy that has a dealership. He said this is a common problem. It was a throttle positioning sensor kit. It was $110 for the kit. They installed the kit and cleaned up the throttle body and works great. No problems so far. I would hope that GM does do something about this so I can recover the money I spent but we will see.
  • gmcustsvcgmcustsvc Posts: 4,003
    txh0032,

    If you would like for us to look into this further with you, please email us at socialmedia@gm.com with more details (including your name and contact information, the last 8 digits of your VIN and mileage, and a summary of the situation).

    Sarah, GM Customer Service
  • Ok is Chevy planning to own up to this???
    This is way to common issue for chevy to give a blind eye.
    I have a 2010 Chevy Impala and basically its falling apart like seriously 58000 its got so much electrical issues starting from airbag right to rear window defrost which was livable but now this Stability Trak that runs like I'm on a motor cross track and loss of power.
    I've always liked chevy but now I can't even stand to drive by a lot.
  • gmcustsvcgmcustsvc Posts: 4,003
    We're sorry to hear that your Impala is having some difficulties, maine2013. If you would like for us to check into this further with you, please don't hesitate to email us at socialmedia@gm.com with more information (include your name and contact information, the lasdt 8 digits of your VIN and mileage, and a summary of the situation).
    Sarah, GM Customer Service
  • Today as I was driving to work, I too saw a message on my cars dashboard that said "Low Engine Power" at that point my car started to drag and the engine light symbol stayed on.

    After reading the several messages surrounding this issue. It appears that GM should insist upon a recall for this situation so that the consumer does not have to pay to get this corrected.
  • gmcustsvcgmcustsvc Posts: 4,003
    recallpls,
    We're sorry that you've encountered this difficulty with your Impala. If you would like for us to check into this situation further with you, please email us at socialmedia@gm.com with more details (include your name and contact information, the last 8 digits of your VIN and mileage, and a summary of the situation).
    Sarah, GM Customer Service
  • Hi, it's annoyed10 with an update. (see posts 311 and 314) Last time we met, the part was supposed to be in on Monday (throttle position sensor) and the service guy said they would look into having the job covered by chevy. Well, it is now Wednesday. The part has to be ordered from the manufacturer and I was told would not be in until Thursday, so I would not get the car back until Friday at the earliest. But, I could PAY EXTRA to have it overnighted, and have the car back for Wednesday. The cost (since it is NOT Covered) of this and Everything else would run between 300.00 and 350.00 depending on shipping charges for this small part. So, I call on Wednesday, NO PART, it is backordered and now they have to find one at another dealer who is willing to give it up. (Only God knows what that will cost me). Hmm, a small sensor, from a manufacturer that makes 10s of thousand of them, and they can't keep up with demand? Does anyone else see a problem with this defective system? Chevrolet/GM evidently doesn't see the problem, even though the messages on this board keep adding up, and this is just one forum on this. Supposedly, the part will be here on Friday, and the car will be fixed then. Tune in on Friday for the next installment of this soap opera.
  • I own a 2009 Chevy Impala and I am having the EXACT same issues as you are. My car was just in the shop yesterday (Chevy Dealer) and I paid around $700 total to fix this supposed issue.(Harness broken in left pedal & air bags were bad) The strange and fishy thing is that almost EVERY post I read has the same issues. My car left me stuck 2 times and also almost caused an accident. I have two children that also are in my car on a daily basis. I called GM they could care less. They try to smooze you with B/S. I am going to attempt to take this further. I thought I was buying a reliable car that would last me for the price I paid. ENTIRELY WRONG. My suggestion to anyone is GET RID OF IT NOW IF YOU CAN.
  • I have a 2007 Chevy Impala LS and after my REDUCE ENGINE POWER light came on I came to this forum to get some feedback. I saw that this has been an ongoing problem for what looks like hundreds of Chevy owners. I've since had my sensor replaced for $25 by a mechanic I know. I paid $104.00 for the sensor (from dealer) but saw it online for about $70 (didn't have time to wait for deliver). I was told two different things about the throttle systems. One was that the whole thing had to be replaced and the other was that I needed to know if my system was one that allows you to remove the sensor separately. I decided to go to my guy in the end. Car running fine so far...had it done about a month ago and it took less than 15 minutes for him to do the work. Nevertheless, I'm a bit upset that it has not been a recall on this. Just saw a Ford vehichle problem just like this and a recall is expected. PLEASE POST RECALL IF IT HAPPENS SO I CAN GO GET MY MONEY BACK FOR THE PART! THANKS
  • kdh12389kdh12389 Posts: 5
    Ive called GMs customer service multiple times reguarding the issues with my car. They have done absolutely NOTHING to work with me to fix the problem. I asked why they werent doing a recall since so many people on here have the exact same issue, I was informed that this was most likely a false forum because if that many people were complaining there would be a recall issued.. So apparently GM thinks we are all crazy and could care less if (God forbid) anyone were killed or seriously injured in their vehicle. One thing for sure I will NEVER buy a Chevrolet again.
  • gmcustsvcgmcustsvc Posts: 4,003
    We're glad to hear that everything's running well after the replacement, detroitgirl313! Keep us posted on this if anything should change (although we hope that everything's resolved for good!).

    Sarah, GM Customer Service
  • Really Sara,

    How many times in the last two years you are going to investigate these claims?? the same Request over and over from GM is asked every time, after a 10000 or so complaints don't you think its time for GM to do something?? or maybe Sara you need to really stop feeding us this useless BS.

    I too have this problem I replaced the pedal, the Trottle body the wheel sensors re seated all of the connections and every now and the the car goes into reduced power... My belief is there is a software problem that you guys cannot fix because its a expensive recall, I do know one thing If my family gets hurt in this car that you say does have problems.. I'll be sure to fire you first when I own it...
  • French79, just got my impala back, they replaced the throttle positioning sensor, $340.00, (live in central PA, don't know what it will cost around the country) and it appears to be working, but it is only day one. I'll let you know if something happens. PS I ran the scenario through with my wife,(there are TOO many posts where this fix didn't work) so if it happens again with her, she will know what to expect/do.
Sign In or Register to comment.