Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2009 Rogue AWD disengaging automatically

I purchased a new 2009 Rogue from the dealer in July 2010. It now has about 3,000 mi. on it. When I've been driving it on logging roads with the AWD lock on, it will automatically disengage after a few minutes for apparently no reason. Is that normal? I couldn't find anything about it in these posts, the instructional DVD or the manual.

Comments

  • Hi
    yes that is normal...junk!
    I have a 2009AWD Rogue the lock button is only to be used if you are stuck going approx 5 miles MPH it is not an engaging system that locks
    It was misrepresented to me by my dealership and it is a costly feature that only works for a split second....the AWD is an enhance traction contol ...
  • Thx for the reply. I finally figured that out by a reference in the quick reference guide. What I've discovered that is even more depressing is that on steep grades the car does not shift down low enough to where you don't have to ride the brake almost the entire time--even when I engaged the manual transmission. The road was a pretty good logging road but a steep grade to a hike in the North Cascades. My VW Passat would have handled the down much better!

    Other than that, I am enjoying the car and now know not to take it to areas that have lots of elevation gain. Bummer. Should have swallowed the poor gas mileage and gotten the X-Terra that I test drove.
  • sorry to hear that but i feel the same way about my pathfinder....would rather pay higher gas prices than over pay for junk......
Sign In or Register to comment.