Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Impreza 2.5i: Check Engine light + Traction Cont. + Cruise ???

mamamia2mamamia2 ChicagoPosts: 700
edited August 15 in Subaru
Car is a 2009 hatchback model. The THREE lights are on (Cruise Control is flashing), and the service agent is claiming they are all connected.... I tend not to believe him...

.....The car was at the dealership last week for the front discs to be shaven after the steering wheel was shaking when braking. Could they have disconnected something?

Comments

  • xwesxxwesx Fairbanks, AlaskaPosts: 8,524
    Yes, they are likely all related, and yes, they could have disconnected something. Namely, a wheel sensor! All four of the wheel assemblies have a wheel speed sensor on them for the AWD and ABS systems. When a reading comes back haywire (out of sync) from the others, it will cause those symptoms.
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • mamamia2mamamia2 ChicagoPosts: 700
    OK, thanks. Once I tighten that gas cap -- would it clear the error code, or at least turn off those 3 lights? Or do I need to take the car to the dealership?
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,524
    Once the problem is corrected, it will usually clear itself within three cycles (meaning starting the car cold, driving it a little while, then shutting off).
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • mamamia2mamamia2 ChicagoPosts: 700
    Thanks...........
This discussion has been closed.