Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Saturn Vue Loss of Power/Check Engine Light

We have a 2004 Saturn Vue that has been in the shop FOUR times for a loss of power issue. The check engine light will come on and almost simultaneously the loss of power light will come on and the car will pretty much come to a stop. So far they have replaced the computer, gas pedal, wiring to the computer, cat converter...it is still doing it! I don't know what to do!

I have googled around and have seen that other people have the same problem, but nobody has an answer as to what it is...thanks for any help you might have!

Comments

  • Have you replaced the body control module?
  • I have a 2005 Saturn vue when i drive it it stalls. I have to pull off the road turn it off then restart it. It stalls at different times i drove 20 miles and it stalled 7 times then i drove 20 miles and only stalled once. I have replaced the ignition control module. When the the engine light was on i had the codes read and they say nothing is wrong with it...Please help me
  • CheriLyn- Mine is doing the same thing. I called Saturn and they want me to pay out of pocket again for a Saturn mechanic to look into it at $190 an hour. If you find anything out, please share!
  • I will and please if you find anything out please let me know.. Thank you
  • Hello! So, I traded in my beloved VW Rabbit for a larger, more practical car, a 2008 AWD Saturn Vue, in Aug 2010. My check engine light keeps going on and off. I went to AutoZone and they troubleshooted the issue and this is the result: APP sensor 1 and sensor 2 signal voltage fault; Explanation: The ECM has detected the APP sensor signal 1 and 2 do not agree; Probable cause: Poor electrical connection and/or failed APP sensor. Is this something that may be covered under the powertrain warranty? If not, how much is this going to cost me? Is this something I can fix myself (somewhat car savy)? Is it OK that I keep driving the car? And just a note....I hate the power engine down function!!! So, I thought that once the check engine light was on, I would not have to deal with this happening (bc before the power engine down function was only happening when the check engine light initially came on)...now it happens even when the light is on. I can go days with the check engine light off, but it will always come back on! Please help!!!
  • It's the ECU. You'll have to find a new one and get it reprogrammed with a Saturn mechanic. Hope it helps. I'll let you know if everything is resolved once mine is done.
  • 2001 Ford Taurus check eng light on with a DTC P0402.This happens about every 2.5 years and I replace the Backpressure sensor and that will take care of it. Is this normal on this year? We brought it new and now has 58,000 + miles (wife car) I have had 2 other Taurus a 1996 with over 200,000 miles and a 2003 with 170,000 miles and have never replace that part. Purchase the part at Advance Auto Parts should I get Ford parts?
    Brownboot
  • gmcustsvcgmcustsvc Posts: 4,130
    alwaysumthn,
    I would definitely recommend working with a GM dealer. I apologize I do not have pricing information. The dealer will be able to assist you in pricing the cost of the repairs. Please keep me updated on your progress.
    Christina
    GM Customer Service
  • I seem to be having the same problem with my Vue. It stalls and loses power frequently. Have had it in to the GM dealer 3 times and they keep telling me that there is nothing wrong with it and that "it's not happening for them". They say the only code stored in the computer is a "minor misfire". I now have it at a "mom and pop" garage to see if they can figure it out. It has less than 60,000 miles on it. Has anyone come up with an absolute fix for this problem because I'm into this problem for about $1000 between having to rent a car (while the dealer does nothing) and mechanic/labor fees.
    I am considering trying to get rid of it and buy something new, but how exactly does one sell a car that is a lemon????
  • We actually did get this figured out after about 5 times in the shop!! They knew it somehow centered around the computer but couldn't figure it out. This is how they explained to me what they did. The computer has a bunch of pins in it, that sort of fit into different slots. Each pin has to have a certain pressure to it. If the pressure is not correct it can misfire and cause the car to stall. They had to take apart every single pin and test the pressure and fix where the pressure was wrong, put it all back together and it worked!!

    Ours was also around 50,000 miles and now we are at 62,000 and it has given us no problems since. See if you can explain this to the mom and pop garage, or return it to the place where you spent the $1,000 and make them do it, and maybe even try to get them to refund you for all the things they did that didn't work. Good luck!!! This is the most frustrating thing ever!! We had all but given up hope..
  • gmcustsvcgmcustsvc Posts: 4,130
    04saturnproblm,

    Glad to hear your vehicle is fixed and you are no longer experiencing any issues!

    Thank you,
    Caron, GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,130
    jen131,

    I apologize for the problems you are experiencing with your vehicle. By chance, have you been in contact with GM Customer Assistance? If so, could you please email me your case number and VIN? I would like to look further into your situation.

    You can get my email by clicking on gmcustsvc.

    Thank you,
    Caron, GM Customer Service
  • This vehicle which belongs to my spouse has preformed without any faults for the past 66,000 miles BUT it's electronic connection from the computer to the accelerator faulted just after we coasted out of our driveway and though the engine was still functioning the accelerator would not accelerate the engine past 900 rpm...
    It's a freezing evening here in Northwest Louisiana and I called ONSTAR for a diagnosis but they simply said the engine computer was displaying code 23 faults and they were unaware what was causing the faults...
    They suggested turning the key off and removing it from it's ignition several times and restarting to see if the fault would reset itself but this was to no avail...
    After summoning a $85.00 tow to a local repair center I awaited the grim reapers report the next day from the maintenance foreman...
    Two days later he finally called and said that other than the battery was totally stoned dead and the computer code was showing a history of a code 23 they could find nothing wrong with the vehicle at this visit...
    They simply recharged the battery and sent me a bill for $95.00!
    The battery was just replaced last Spring and if this vehicle is starting to EAT batteries I gotta dump it or keep it on charge continually...
    Does anyone have any suggestions regarding this issue?
    If so I'm a listening...leehhiltoniii@bellsouth.net
    :>/
  • I can understand your frustration. I wanted to clarify a few things, just for my understanding: what brand of battery did you have installed in your Vue last spring? Do you still have documentation on this? There are, depending on the brand, battery warranties. Also, was this diagnosis done at a GM Dealership? If so, we can follow up on this.

    Please send us an email with more information at your convenience if we can be of service.

    Sarah
    GM Customer Service
  • jess2224jess2224 Posts: 1
    I recently bought my 2003 Saturn Vue V6 6cylinder. I bought it from a private owner, a woman I know very well. She kept regular maintenance on the car such as making sure the oil was changed exactly every 3000 miles. I registered my vehicle on april 11, 2012. I test drove it about a month before purchasing the exact vehicle and it ran perfect. Two days ago, upon driving my car, when I would hit the gas pedal, I would reach 20 or 30 mph and the power would shut off. The car sat for about 7 months as a result of the owner being in an accident and buying a new car in the process. The power will shut off about every other time i attempt to drive. One theory is that there was sediment in my gas tank from it sitting so long and it is clogging my fuel filter. But, upon doing some research, am wondering if it is more than that. Anyone have any ideas?
  • No, the ECM will probably not resolve your problem, and it will cost you a lot of money. I did that, and still had the same problem afterwards. Recently though, I took my Saturn Vue to the Kuni Chevy dealer here in Sacramento. They did a diagnostic, and the engine was fine. What they did find was that the negative ground to body was broken. It cost about $300 for the repair, and I no longer have the electrical problem.
    Be careful who you take it to though, because since that repair, I have new problems with my Vue that I didn't have prior to taking it in. Like suddenly all my engine mounts are worn out and my car vibrates like crazy, Had to take it back in to find out why this was happening, because it wasn't doing that before they worked on it, and they only want $1175 to fix that, and also they claim that they have discovered a blue liquid in my brake fluid, which has contaminated my brake system, and they only want $3500 to fix that. I hate to point fingers, and make accusations, but I had none of these problems prior to taking my car to them regarding the electrical problem. But I have no way of proving that they are responsible, so I will just warn people about these possible shady activities to force people to let them work on their cars. We've all hear the saying, Despirate times.
  • 442dude442dude Posts: 373
    When you say the power shuts off what do you mean? Does the engine shut off or is there just no power? Check engine light? any dash warning lights?

    I'm not sure I buy the sediment explanation...fortunately replacing the fuel filter on the 2003 model is very easy as it is external from the fuel tank. You should just replace it so you know that its not your issue. Cheap repair.

    I will keep an eye out - post back...
  • End of June 2013, Both Lights came on and immediately went to Advance Auto Parts who said it was a Throttle Sensor and part may need to be programmed by Chevy Dealer

    Took the car to the Tallahassee, FL Chevy Dealer and was advised they would charge me 95.00 to confirm and an about $175.00 to replace part. I choose to just have the repair done.

    About 2 weeks later, both lights came on AGAIN. Took the car back to Chevy and this time was told it needed an ECM – Almost $700.00.

    About 10 weeks later , both lights came on AGAIN. Took the car back to Chevy and was told the history shows the lights having come on, but they could not find anything wrong.

    In the past 2 weeks, the lights have come on twice. About 200 miles in between. When the lights come on, I pull to the side of the road, turn off engine and re-start and the reduced light goes out, but the service light stays on. After I park the car for a while, and later start it up, both lights are off.

    Can not afford to keep taking it to the Chevy Dealer. I am afraid, first it was a sensor, then they said, ECM, I am afriad, next they may say, Engine needs to be changed.........
  • treece1treece1 Posts: 2

    Bought our 2009 Saturn Vue Hybrid just shy of 6 months with low mileage. Did not have any problems with it until we took it in for an oil change at CO-OP in my local town. First the air conditioner started blowing hot air and not like normal hot air, like a breeze from Hell and at the same time where the base of the air conditioner is, you could feel heat on both sides of the base. After that corrected itself, the "stability tracking" "service hybrid engine" warning came on along with the check engine light. My hybrid would power down to 50% and it did this off and on for about a few weeks. Now it has escalated into water in my oil, using coolant, and leaking something. It has died on me twice and I couldn't restart it right away. I had to sit for at least 5 minutes before it would start again. It also has a surge to it, like when it is in gear, the RPM's will go up slightly then back down. I wish I would have read the reviews on these pieces of crap. I can't afford to be sinking money into this automobile. Did anyone have anything like this happen to them?

  • 2003 Saturn Vue Reduced power/ Service engine soon light problem solved Bought my 16 yo daughter 2003 vue. It did this a few times. Found these videos. Hope it solves your problems. I'm replacing mine this week. Hope it works.
  • Forgot to say the 2003 vue we have has got 168,000 miles on it and had the transmission replaced at 132,000
  • treece1treece1 Posts: 2

    UPDATE!!! Ours turned out to be the throttle body sensor and had to be replaced with the computer reset for a total of 500.00. I don't have that kind of money just laying around but I'm so glad it's nothing like 3000.00 like we thought it would be. Make sure you know your mechanic and you trust him with your life!!!!

  • I'm having power loss with my Saturn Vue, 2003 V6 AWD Automatic. When driving the engine/transmission kind of jerks and the service light comes on. Then it goes into a "mode" where the gas peddle seems to deliver no fuel but it will drive slowly while accelerating but then smooth out when it reaches a certain speed (maybe 40 or so). When you shift down into Low gear it engages again and drives normally but it won't in drive. Can you tell me what's going on and what the problem might be?

  • cletus51cletus51 Posts: 1

    i have same problem with my 2003 vue. Now it will not staart

  • I bought a 2005 vue about a month ago... 10 minutes after we drove it off the lot we had problems... none while test driving though. It acted like it was going to die out then back fired... Then it ran fine and the check engine light came on. We took it back to car lot and they hooked their computer to it and said it was the map sensor and something else... A week later the motor blew. We got a replacement motor and put it in and it wouldn't crank. Had to tow it to a dealership. They said there was something wrong with the wiring. Of course they couldn't guarentee their work. At least it was running after that. We would be driving down the road and and die out. We would restart it and the engine light would be on. Codes for running rich and map sensor and oxygen sensor would pop up. Put a brand new map sensor on it.. Ran okay for a day then started all over again. found out it didn't have a catalytic convertor on it. So we bought a new cat for it and new oxygen sensors on it along with another new map sensor. Ran good for a day or two and it's doing it AGAIN... Other codes that have come up are random misfire, bad or missing gas cap and throttle position sensor. I'm running out of ideas, and money.... Can anybody help me. We even took it somewhere and had the injectors cleaned.

Sign In or Register to comment.