Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler 300M

1122612271229123112321267

Comments

  • bluesky999bluesky999 Posts: 253
    Easy, I did voice my conern to the service mgr re/the battery. He stated that with this particular battery it should last its full life w/o checking the water. I was skeptical, but I asked if such a situation would affect the warranty and he said "no", so I let it go at that.
  • mikeyjohnmikeyjohn Posts: 365
    Do a search on the DC worldwide site, but if he wants to come to Canada there are several in the showrooms in my city here in Calgary Alberta. We have around 7 dealers here and if you have a problem accessing the dealer sites, then contact me here and I will e-mail you my postal code which will allow you access to local dealers. I do not have my 300M any more, as I now have a 300C. Good Luck!!
  • bigmike5bigmike5 Posts: 960
    Well, I survived the surprise showing of my new ride to the wife when she arrived at the airport after a couple of weeks in NE. After seeing the Vette her questions concerned getting rid of the 99 300M. No chance. Maybe I can get rid of her Eldo?... Now I am really courting death. lol. Anyway the new ride has been tinted, striped and photographed, and it should be ready for the Woodward Dream Cruise if I don't get any 300M'ers who are interested in a meet up near Detroit. Local Bob B. will assist me if there is interest. You needn't be a Club member to join us, just love the M with your heart and soul, and come see the greatest gathering of cars you will ever encounter. Check the WDC site out if you don't believe me. Anyway, any 300M'ers interested in a meet? Always the 3rd Saturday in August just north of Detroit.
  • hayneldanhayneldan Posts: 657
    My 99 Intrepid went into limp mode and returned to normal operation after a off on of the ignition switch. Hard downshifting, by itself would return to the limp mode. Thanks to the 300M owners, I suspected one of the trans sensors, since the car is still covered by the extended warranty, with a deductable, I brought it in to the dealer and suggested I knew that it could be one of the sensors but suggested they check both. They ended up replacing both and the car runs like a dream again. Thanks again 300M'ers and Intrepid owners for bringing this up on these boards.
  • bluesky999bluesky999 Posts: 253
    That was just one funny title for a post. :>) But you may be counting your chickens prematurely; she might just be considering her options at this point, such as an "accidental" collision between you and her Eldo, possibly even slow death by nagging (the worst of all) --who knows? But on the serious side, congrats on your vette purchase. It's an incredible car; definitely best bang for the buck in the over 40K performance car category. Wish my savings weren't decimated by the stock market crash and I might even have one...
  • bigmike5bigmike5 Posts: 960
    Stickered for $49K. Out the door for under $39K, and I suspect that I did not get the "best" deal available, altho I am happy with what I paid. The deals are definitely out there as they clear the lot for the 05's, and now it is back to GM going 0/60 on the 04's. Oh, well.
  • alg528alg528 Posts: 18
    I know I've read several things on this board about the dashboard light show the 300M can put on, but I never thought it would happen to me. This morning, after 59,000+ miles, it did. What should I tell my dealer about in the way of a solution? Was there a TSB concerning this problem? Thanks for anyone's help on this.
  • You might be better off to grin and bear it!

    My wife and I have had 4 300M's and 2 of them have given us a light show (both interor and exterior, by the way). But it happened only once with each car. There were no detectable side effects from the show.

    You know that your dealer already has his response in his computer waiting to print out on your work order -- "could not duplicate problem." LOL!
  • lflowerslflowers Posts: 155
    Car & Driver has pictures of (supposedly) upcoming coupe and convertible versions of the 300 in the August edition. I don't like the boxy look of the 300, but if the pictures are an accurate representation of the 2 future models, I just might be interested in trading my trusty M for a 300 coupe. Both new models bear a strong resemblance to the 300 convertible show car from a couple of years ago!
    I hope the report and pics are correct!

    Lynn Flowers
    McKinney, Texas
  • laurasdadalaurasdada Posts: 2,493
    Hello: My '99 M w/61K miles occassionally puts on a light show. I adjust the interior lightiing rheostat and that usually cures that incident. In the 5 years I've owned my M, I've probably "only" had a half dozen or so light shows.

    My only other electrical gremlin has been somewhat recent, I call it the Fan Show! Suddenly, CC fan will kick up to full blast, shutting off CC does not stop the now nuclear powered fan. Luckily, the three times this has happened have been just shy of my destination, so once I "reboot" the car, all is well.

    Went to a 4th BBQ, a freind of the evil wife's who had never seen my M before asked if I had just gotten a new car! 5 years of washing, waxing have kept it looking new....from a distance! A few wrinkles up close, unfortunately.

    '13 Jaguar XF, '11 BMW 535xi, '02 Lexus RX300

  • bigmike5bigmike5 Posts: 960
    Big storm went thru here last nite, and at 12:50 a.m. my baby got hail damage big time sitting in the driveway. She was in the driveway because the new ride [Vette] is in the garage. The custom car cover I ordered for her had not arrived yet. Got about 15 hits each on the roof and hood and a few on the rear deck that I could see this morning. To the repair shop at 9:00 a.m. for an estimate and hopefully just a "pop-a-dent" appointment. I am hoping it won't total the car. Am I p.o'd?! She just won an award at last week's local car show here. Bummer. The dang custom cover has been on order for 3 weeks, but it looks like it will be too late to protect her. I am really bummed out. My 6-year anniversay with her is the 27th.
  • illini4illini4 Posts: 140
    I had similar hail damage to mine a couple years ago. Dent Wizard was 100% successful in removing every dent and USAA picked up the tab. Any car cover I've seen would be too thin to prevent hail damage.
  • bigmike5bigmike5 Posts: 960
    Well, the shop says about $1,100.00 if it goes to Paintless Dent Repair [PDR] guys and they are unsure if USAA is going to want to send the team back here to do it. Depends on how many others got hit. While I was at the shop State Farm referred 4 to them for a look-see. Won't know for a day or so whether it will be PDR or conventional repair. I agree on the cover, but I figure at least 40-50% of the little dings could have been stopped. Maybe I am too optimistic. Oh well, at least I have the Vette to drive when the M goes in the shop.
  • morselandmorseland Posts: 25
    Dear Bigmike,

         Two weeks ago our neighborhood in Scituate, Ma. got hit with golf size hail I had never seen here before in my life. I was home at the time and got my new Dodge Magnum (three days old)in the garage before any bad damage but three dings on the car will cost $305 to repair. My 300M was outside at a body shop one mile away and got $450 worth of damage. Some cars in my neighborhood were totaled. There was a tornado warning in Marshfield, the town just south of us.
          I haven't run that fast since high school to get the new car in the garage since the hail started small and just became larger and larger. My local area looked like a hurricane hit for the fourth of July weekend.
         
       They have had quite a few national companies here doing work and the local body shops are swamped. Damage was alot worse than what their computer models predicted.
  • bigmike5bigmike5 Posts: 960
    Geez--I was in Danvers/Swampscott area from 19-28 Jun, glad I missed that. My daughter [who used to live in Scituate near the water] didn't mention any hail storms recently, so maybe the northshore did not get hit. We had a storm here 2 years ago that got up to tennis ball size hail. My office at Fort Knox paid out almost a $1M for damage to soldiers cars that got hit. I guess I am just glad the damage wasn't greater. Just wish with all the computers, satelites, and projection tools that they could give better predictions and warnings.
  • alcatrazt2alcatrazt2 Posts: 70
    Sorry to hear about that sad news...it really hurts. I thought the few scratches (intentional) on my 02 Pro-AM 300M were bad, but I can't imagine having hail damage it to the point of totaling the car...Well, hope it all works out well, and it doesn't cost you a fortune to repair it, even though you would probably spend a great amount to fix something you truly love...:(
  • bigmike5bigmike5 Posts: 960
    Altho I don't have a lot, money would almost be no object for repairing my baby. But fortunately, my Comprehensive deductible is only $200, so all I need to worry about down the road is the insurance company jacking up my rates because of a claim, and the wife urging me to sell her--I mean the car not the wife. lol Supposedly a team of PDR guys arrive at the body shop today, and I dropped her off last nite--the car not the wife--so they can start working on her once they get set up. This all forces me to drive the Vette to work. I can deal with it.
  • fuzzywuzzyfuzzywuzzy Posts: 958
    Your insurance shouldn't go up for a comprehensive claim. If they raise your rates I have read that's against the law.
  • alcatrazt2alcatrazt2 Posts: 70
    Hey everyone...Best of luck to you Mike...Hope the car gets all the goodies done to it as soon as possible. As of my 300M, I was considering getting a radar detector. Does anyone have any suggestions? It's not like I race the thing, I just want it to detect cops etc., less than a hundred bucks, anyone have any good suggestions? Plus, will I have to plug it into my on dash cigarette lighter outlet (next to the shifter). I've never used it, all it is is an AMP Nob, does the thing come out? Thanks. Take care.
  • fuzzywuzzyfuzzywuzzy Posts: 958
    Most everyone uses the Passport 8500 or the Valentine 1. I have the V1. It's expensive though at $400. I heard some of the cheaper Bell units work ok. I had mine hardwored in the M when I had it. Now it's hardwired in my Acura.
Sign In or Register to comment.