Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2011 Chevy Equinox Problems

1363739414254

Comments

  • CapeCodCapeCod Posts: 117
    Could it be a "false reading" that someone is sitting in front passenger seat without belt fastened? Possible a briefcase, gym bag etc is on the front passenger seat??? Did you disconnect and re-connect your seatbelt as a test for a malfunction? Maybe a piece of clothing (jacket?) or moisture is in the connection?
  • Me too my fuel economy is horrible not even close to what they say Ive been to 3 dealers and everyone says Im the one with the problem (my driving habits) all my other vehicles were fine I dont think Ive changed I think its the vehicle but know one wants to admit it. I live 45 minute drive from the plant where this vehicle was made and sometimes I wonder if I should move further away from it this is the worst vehicle Ive ever had keep it up GM and chapter 11 might be coming soon and then ask people to buy your product and then see how people really feel about all of this
  • Me too I think finally they are going to replace my vehicle it's only been nine months since I've had it. This is the worst vehicle I have ever had I told them I wanted replaced with V-6 engine I just need to wait and see now with what they are going to do. The person I am working with is trying to help me out so hopefully I can get out of this vehicle. I told her to go on this forum and see all the complaints. The complaints are all about the 4-cylinder but the 6 cylinder I have heard nothing but good things. The person at General Motors admit to all these problems that she knew about them so she knew I was not lying. I told her this has been a battle for the last nine months
  • uncfanuncfan Posts: 3
    Received call from dealership this morning. They did hear the noise this morning and the tech agreed it was worse than before the actuators were replaced. He referenced a PI which indicates that the actuators are to be replaced (which was done at the last visit) and if that doesn't fix it, no further repairs are to be made or attempted. A programming update for the ECM is being developed that is supposed to correct the problem and nothing further can be done. No idea of when this update will come.

    Have emailed Sarah my information this morning.
  • firstnoxfirstnox Posts: 12
    "No further repairs are to be made or attempted?" Is this your decision, the dealers, or Chevrolet's? The car is under warranty - all possible attempts to remedy the problem MUST be made. I hope you keep us posted on your progress.

    We had all this work done at month 2 of ownership and knock on wood, one year later (our Equinox 4 Cylinder) is a year old today. I read this column every day to see what this car is doing to people. Never again with Chevy!
  • uncfanuncfan Posts: 3
    This is the instruction per the PI (dated April 2012) which is from GM. So, I guess you'd say the decision was the dealership's per GM. Certainly not mine...

    This was my first brand new Chevrolet since 1994. Very disappointed and not sure I'd buy GM again. Feel like I made a very expensive mistake.
  • pfacpfac Posts: 1
    I am in the process of buying my 17 year old a car and she loves the Chevy Equinox. I have owned Tahoes for many years and couldn't be happier.

    Am I safe with the EQUINOX 6 cy. or has anyone had issues as well??? Is it just the 4 cyl???

    Any advice would be greatly appreciated!
  • ejbergejberg Posts: 3
    This is the identical story I heard this week after the dealer replaced my cam actuators again. No timetable on the reprogram that will supposedly ensure that the cams return to the zero position at start-up ... per the service manager, the fact that they're not zeroing is supposedly the root cause of the start-up noise. So, to me it sounds like replacing cam actuators doesn't fix anything -- it's just a delaying tactic that might help muffle the noise while making it seem like they're doing something.
  • rs61512rs61512 Posts: 1
    I was driving my 2011 equinox last week when I lost acceleration. I had to coast into a parking lot, put the car in park, tried drive again, nothing. I shut the car off, turned it back on, and it was fine. Three days later, I lost acceleration again. This time, everytime I tried to accelerate, the car stalled. Kept restarting it, nothing. Had to have it towed to dealership. They got it, said it worked great, and could find nothing wrong with it. Started a case with GM, and they are terrible! The first girl told me they could probably get me a rental, since this is a safety issue, then they decided it hasnt happened enough to warrant help. Mechanic said it sounds electrical, but they cannot find a problem. I have been lucky enough to have been in a aprking lot, or small road, but I do mostly highway driving and I am terrified to drive it now!
  • fuzzhead1fuzzhead1 Posts: 3
    I just had this happen to me today. It was 90 and it kicked off the air and when I stopped and turned it off and on it finally started too work. I have nothing but poblems since I bought one year ago
  • jpfjpf Posts: 496
    Stay away from the Equinox or Terrain, both 4 and 6 cylinders. Unless you're planning on buying another full-size sport utility (Tahoe, etc.), then stay away from GM (i.e. Equinox, Terrain, Acadia, Traverse). They're all problematic, both 4 and 6 cylinders.
  • dljwdljw Posts: 1
    Our 2011 Equinox 4cyl has under 10,000 miles and usually has the starter noise on a cold engine. The dealer will not hear the noise unless the car sits before starting. We were also given the line about replacing the actuators but we knew it would not correct the starter problem. It is just a waste of time and money for GM to even insult their customers with this as a solution. I would like to know how long before GM corrects this problem. How long have they been working on correcting this problem. I started having this problem about 6 mos ago and there were complaints then. Anyone with an engineer degree have any ideas why the starter grinds and what damage it is doing to the engine?
  • Just like yours and mine and many others out there with this piece of crap they messed up and they can't figure it out. So now we are stuck with this garbage. I have driven GM over 20 years now and this is the worst vehicle I have ever had just like the rest of the people on this forum and the people who are not on this forum I'm trying to get them to switch my vehicle to a V6 but it's like pulling teeth my fuel economy is very poor they say it's my driving habits looks like we all have the same driving habits. Then there is Sarah on GM customer service who makes it sound like she's trying to help but nothing seems to happen
  • CapeCodCapeCod Posts: 117
    We are talking the same noise here???
    Mine sounds VERY much like the sound of a diesel engine and is from within the engine. Does not sound like a "grind" and although it is heard at start-up it is not from the starter.
    My ultimate fear is down the road this leads to a serious and expensive engine repair... past warranty of course. The other fear is once the problem is commonly known, I'm stuck with a lemon no one wants in trade in. Remember the Chevrolet Vega !!!
    BTW I'm sure Sarah from GM Customer Service is just a false identity... much like "Peggy" from the charge card commercial. Probably a roomful of Sarah's trolling the different GM forums promising customer service... cheaper than actually fixing the problem?? Or worse... "What problem?"
    Do I sound a bit testy... probably because my startup noise is back and happening more frequently after 4 to 5 month absence! I even like my dealership but I still remember their look of puzzlement when I mentioned the noise to them nearly 9 months ago. Never even made it to the work order?
  • jpfjpf Posts: 496
    I believe GM is reworking their 4 cylinder engine and will come out with a 2.5 liter 4 cylinder within the next year. They may not want to invest a lot in the current 2.4 liter engine since it will be replaced. Just a thought.
  • bdownenbdownen Posts: 1
    My wife is having the same problem with her Equinox. At least 4 times so far the engine has just stopped. It is undoubtedly a major safety issue and she now does not trust it to safely get her to work and back. She's bringing it in to the dealership a second time today, although we know how that will end up going. "We can't reproduce it and the software doesn't show any failures". Which means we'll have to wait until it fails and causes an accident before they take the problem seriously.

    If, by some act of God, Chevy acknowledges an issue and repairs it, you'll be the first to know.
  • Just like you me and all the others but if our warranties were over I could just imagine how many codes and problems they would of found
  • viper222viper222 Posts: 1
    Well here's what's up!!! Been dealing with this P.O.S for a year now. First of all I had to provide the PIP for the dealer, they had no idea!!? Unreal and they are the "pros"? Took it in for engine noise and stalling on start up...no idiot light.. or anything. They checked the starter mounting bolts and sent it out the door!! CND (can not duplicate). Drive it for a week engine noise again and I said this thing is only getting 25MPG! Car had almost 10,000 miles on it when they finally changed some parts. They did some cam phazers...I had the car another week same shity mileage! Took it back because I asked them if they changed the oil when they did the cam phazers and they said no! Told them MPG was still bad. They found out the fuel pump orings fail and it jacks fuel in the crank case...it mixes with the oil intern the poor mileage. OK...stop right there!! Raw fuel in the crank case!! How many THOUSANDS of miles did this take of the engine and we have been driving it this way since NEW!! I sent an oil sample in to a lab to get tested...came back "could not tell viscosity of oil. Sample again at next change and resubmit" Well....now have just over 19,000 miles on the car and engine noise on start up is back!! My oil life meter says it's at 50% yet, but we put some miles on so I decide to change it last night. Drained the BLACKEST...SMELLIEST oil I have ever seen come out of a car with only 4000 miles on the oil!! Needless to say I took it to the dealer today and guess WHAT? Need some more cam phazers!! P.O.S I am so sick of this car!! I have sent another sample off in the mail today and should have results back soon. Heading for the BBB and the lemon law next!!
  • oldfogey2oldfogey2 Posts: 1
    I just got my 2011 Equinox back from the dealer for the 2nd time for the transmission downshifting very hard and jerking. They reprogramed the "Transmission Control Module" (TCM). There is a GM Service update, dated April 23, 2012. The Document number is "PI0724 : Harsh 2-3 Shift" it addresses the 2011 Chevy Equinox and the 2011 GMC Terrain. Equipped with the 2.4 Engine RPO LAF and Equipped with 6T45 Automatic Transmission RPOs MHC, MH7. It appears to have corrected the problem. (for Now)
  • lsmithhartlsmithhart Posts: 21
    I would agree with the seat belt warning. I often carry a laptop briefcase on my seat and it does the same thing. Clear off the seat and life goes on... fixed. Now if my 15,000 mile Equinox was that easy to fix! I too have had the cam sensor issue, causing the vehicle to break down in a bad part of town... at night... with my wife driving! I bought her this vehicle to give me peace of mind, and now she drives my 2007 Mazda.
    I heard a noise at 1000 miles and was told that it was normal for the engine. I disagreed, but had no recourse. Now, at 15,000 it is no longer a reliable vehicle in my eyes.
Sign In or Register to comment.