Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





"Service Stability System" Chevy Uplander.

ohiochrisohiochris Posts: 1
edited July 2 in Chevrolet
Have noticed the Service Stability System message on my dash ; this is only the 2nd time in a year that I've seen it.

Any comments/thoughts appreciated.

Thanks for your time. Chris.

Comments

  • 442dude442dude Posts: 373
    edited April 2011
    We just had the same problem on our 08 Uplander - brought it to the dealer quick since the 3/36 warranty was just about out.

    Long story short: They replaced the front left hub/bearing/speed sensor. Seems that the sensor was going bad and you can't replace it without replacing the bearing/hub. They also replaced the wiring harness that goes to it. If you're still under warranty you might want to get it checked out.

    Good Luck
  • gmcustsvcgmcustsvc Posts: 4,125
    ohiochris,
    I would recommend having it looked at by your dealer.
    Christina
    GM Customer Service
  • max5841max5841 Posts: 4
    I have the same problem,it is in the wiring harness,also I have a customer who has the same problem same year 2008 uplander lx.They have a directive harness where moisture is causing the problem.gm should have a recall on this I also was talking to a person at the gas station having same problem what are odds on that.
  • jpfjpf Posts: 496
    I just purchased a 2007 Uplander. I believe our vehicle is not equipped with this option. I checked the owner's manual and it is not very clear. I believe, if the stability system/traction control is present, then a separate light should be illuminated between the driver's information center and hazard lights on the instrument panel. Our vehicle has no such light. Am I correct in assuming so? Any comments are very much appreciated.
  • dear ipf I have an 06 up-pain-in-the-[non-permissible content removed] with tc. Near the four way button there's a tc on/off botton.
  • jpfjpf Posts: 496
    nanook, thanks for the heads up. Mine does not have a tc on/off button. The button is fixed and can not be depressed. Also, there's no tc or stability system light on start-up. I guess my van does not have that feature. Wish you better luck with your 06.
  • ipf,

    If your vehicle has Traction Control, the on/off button would be immediately to the left of the Hazard Warning Flasher button, located above the radio. When you turn the ignition switch from off to on, the Traction Control Indicator Light (located in the Speedometer Cluster) will light. If you do not, like my 2006 Uplander LS, there will be a blank cover for the Traction Control Button and the Traction Control Indicator will not illuminate.

    maddog0324
  • I have a 2008 chevy uplander, with abs, tc, and stability light. Also has 3 codes, 0050,0253,0254 still trying to figure what needs replacing.

  • guitarz1guitarz1 Posts: 1

    I have a 2008 Uplander LS with the 3.9L Flex Fuel engine and I think I have found a way to fix the service ABS, traction control, stability system warning light. It seems related to the amount of brake fluid in the master cylinder reservoir under the hood. If the fluid level is slightly below or above the max marked line on the reservoir - the warning lights come on. It seems to be a very temperature sensitive sensor in this system. Let me explain my findings. It is a cramped engine compartment and in the summer under warm hot conditions the brake fluid slightly expands, bringing the fluid level slightly higher than the max line and then triggering the sensor. In the fall, when it starts getting cooler, the brake fluid level slightly contracts - bringing the fluid level just below line - hence also triggering the sensor. You must maintain the fluid level and then there seems to be no issue. If there is too much fluid, siphon some off with a straw. If there is too little -ad a few drops to top it up. You can buy brake fluid for like $10. Also I noticed that some brake fluid evaporates in the summer and you may have to top up again. I can go for several weeks to a few months without the warning lights coming on by doing what I just mentionned. My brakes work fine. I do like this van very much and find it powerful and comfortable to drive - it just has a buggy electrical system. I hope this helps people. At least try it out - before you go and have expensive repairs done. Cheers. Also if you have charging error messages - shut off the timer on your interior lights and the problem is solved!

  • tabbyg2014tabbyg2014 Posts: 2
    My service abs system light comes on as well thanks for the heads up I will check the fluid. Also my brake lights went out but the bulbs are good would I need to replace the light fixture or is it electrical. I have an 07 uplander
  • dutchie1dutchie1 Posts: 1

    I really like the ideas of the persons in the forum and will try those that might apply Thanks

Sign In or Register to comment.