Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2012 Subaru Impreza

1313234363780

Comments

  • ateixeiraateixeira Posts: 72,587
    The publicity won't hurt sales.

    It may be a while before we see a lot of 5 doors in stock on dealer lots, though. They're still short on supply and around me pre-sell most of them.
  • jd_24jd_24 Posts: 92
    I'm looking to get a new Impreza. I'd like to have automatic headlights as much as pssible, but I'm not going for the limited version. Most likely the premium 5 door. My question is do the headlights turn off when the key is removed or engine shut off?

    On my 2001 Outback I just leave the headlights on all the time. When I shut it off and remove the key the lights go off.

    The owners manual that I found online seemed to say the lights stay on and you get a chime whne you open the door and the lights are still on.
  • No issues what so ever! I enjoy more everyday with my 5 door impreza.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,268
    I should hope so! That feature has been on every Subaru model since the 1990s, so not having it now would be a big step backward. :sick:
  • flopkaflopka Posts: 22
    edited March 2012
    But the manual does seem to imply that they DON'T go off...see here:

    Before leaving the vehicle, make
    sure that the light control switch
    is turned to the “ ” (off) position.
    If the vehicle is left unattended
    for a long time with the light
    control switch set to a position
    other than “ ” (off) position, the
    battery may be discharged.


    Even if the key is removed from the
    ignition switch, the lights can be illuminated
    by operating the light control
    switch from the “ ” (off) position to the
    “ ” or “ ” position.
    .

    If the driver’s door is opened while
    the lights are illuminated and the key is
    removed from the ignition switch, the
    chirp sound informs the driver that the
    lights are illuminated.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,268
    edited March 2012
    Oh, I understand where the confusion is coming from now.

    If you are driving the car with the lights on, park it, and remove the key, the lights will turn off by themselves when they key is removed. Now, if you turn the lights off (on the switch) while the key is not in there, and then turn the light switch back to 'on,' the lights will stay on regardless of the key's presence (or yours for that matter!).

    In that scenario, the chime will occur when you open the driver door to remind you the lights are on. If you opt to ignore it and walk away, you'll likely return to a dead battery!

    On the other hand, if you buy the car, set the lights to "on" and leave them there indefinitely, they'll always be on when you put the key in the ignition and off when you take it out. ;)

    Does that make sense? I suppose I could make up a video demonstration on my own car (it's a '10 Forester rather than a '12 Impreza), but hopefully the explanation above is clear.
  • debbadoo2debbadoo2 Posts: 24
    For those of you who park your Impreza outside regularly in the rain, have you noticed the problem with the weep holes not draining until you open the door, and then an excessive amount of water runs out? I've seen several people comment on this and have read about the same issue with other cars. Apparently the holes are draining okay, but not until after you open the door which means a substantial amount of water has accumulated in the door in the meantime. This concerns me, as I do have to park outside. I've never had this issue with any other car but I guess it is not that uncommon, depending how the door seals are designed. It sounds like the holes are somewhat blocked when the door is closed which does not allow enough water to escape when it rains hard.
  • flopkaflopka Posts: 22
    I haven't noticed this yet, but then again I'm in the Northeast and we have had no heavy rain this winter. I'll keep an eye out for it though.
  • flopkaflopka Posts: 22
    Thought I'd share this incident here because it may be Subaru-related, maybe not... While driving home yesterday, I was almost home when the Impreza started emitting a dreadful high scratchy metallic squeal on the driver's side, seemingly from under the car or around a wheel. "What!" I thought "Already?!" (the car is a week old) I pulled in the driveway, then immediately thought to test drive it around the block a few times... and mysteriously the squeal was gone.

    I'm almost positive that I somehow picked up a rock or pebble from the road (dirty winter road, no street cleaners) and it got caught in a wheel or brake caliper somehow. I went online to research this and came across an interesting comment from someone who used to work for a Subaru dealer and he said that Subarus are sort of notorious for picking up road debris occasionally this way. Anyone else had this experience?

    In any case, it's said that 90% of the time, going in reverse will kick out the stone. I would guess that driving with such a squeal might result in nasty scarring to whatever is rubbing against a foreign object. Anyhow, glad that the noise seems to be all gone - it was very unnerving to hear in a brand new car!
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,268
    edited March 2012
    That will happen from time to time, and reverse is generally the best way to eject it, combined with repeated forceful applications of the brakes. If that doesn't do the trick, just lift that corner with the jack, remove the wheel, and physically remove it.

    I'm not sure that Subaru does it any more or less than other cars. Disc brakes are certainly more prone to them than drums were (hey, I still have two vehicles with four-wheel drums!), but that's about it.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,268
    That's not good! This is a known thing on many models? I guess it wouldn't be too much of a problem if the vehicle is used daily, but let it sit for a little while and one could have a sizable puddle in there! Stopped drain holes are the single largest contributor to "rusty door syndrome" on old cars. :cry:
  • onemodogonemodog Posts: 26
    6 Weeks tomorrow since I drove my Subie home for dealer. So far all is well. I am avg about 27 mpgs and coming up on my first oil change (will do it between 3000-3200. Currently at 2650 miles). I am hoping for another 1-2 mpg after the change but am not expecting to hit my goal of 30+ mpgs until it warms up.
    The car is fun to drive though I wish it had just a bit more oomph off the line (have a Sport Premium CVT). Ive been pushing the car a bit harder since I hit 1500 miles and I must say it has handled well.
    The tires handle well in wet weather but I havent had a serious storm yet, just some mild ones.
    Last night I saw the Impreza commercial where the car is in the snow showing its AWD off. Looked like fun. My wife and I decided a drive to Tahoe is in our immediate future.
    All in all, I am happy with my purchase.
  • debbadoo2debbadoo2 Posts: 24
    thom52, has your wife had any recent issues with the slow cranking now that you are following the "prescribed" startup procedure?
  • thom52thom52 Posts: 30
    debadoo2 wrote:"thom52, has your wife had any recent issues with the slow cranking now that you are following the "prescribed" startup procedure"

    NO problem with hard cranking, ever since she started turning the key to "ON" and waiting for the gages to stop waving at her. (and not touching the gas pedal!)
    There is a theory that you only have to do this after its been sitting for a long time, like overnight, but its simpler for her to use the same procedure all the time, so its a habit and no more worries.

    One person claims they had a hard start even with doing this. I can't confirm that he followed the simple instructions EXACTLY, and no one else seems to have had further problems. Yet.

    My wife LOVES the car. Absolutely no regrets. We are currently getting about 28mpg with mixed driving. (Premium hatchback, CVT, basic 16" alloy wheels, approx 500 miles.) :shades:
  • odie6lodie6l Hershey, PaPosts: 1,078
    I know it was probably an honest mistake, but I got a good laugh not once, but twice this week.

    The dealer that I have been working with decided to send me a letter in the mail (twice) congratulating and thanking me for making my purchase of my brand new Subaru Impreze Sport Premium with them. It goes on to say they hope I have many years of great adventures with the vehicle and to contact them is there is anything they can do to assist me with any upgrades or additional purchases. With one of them was also a Sample copy of their Customer Survey that has been filled out to show you how a perfect survey should look and that they hope that when mine arrives in the next week or so that I will be able to fill it out the same.

    Thought it was kinda funny, but if I do happen to get the survey in the mail, that will be the icing on the preverbial cake. :D

    Odie
  • kanjiikanjii Posts: 99
    I'm a little PO'd today. Last night, my oil light came on and I only have 2126 miles on the Subie. What the heck? :mad: I checked to see if there is any oil leaks, none. I really hope this is not an oil guzzler. I emailed Subaru USA about it. They said if it needs a quart of oil at 1200 mile or a liter at 2000 to call your dealer/service. This is not good. Have any of you have this problem? I heard the older model engines eat a lot of oil.
  • ateixeiraateixeira Posts: 72,587
    Well, it is break-in, plus the oil level may have been low to begin with. The dealer is supposed to check that at the PDI.

    Had you checked the oil level before now?
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,268
    No, significant oil use is not typical (even on the EJ engines). Unless you checked it prior and it was full, I wouldn't start worrying about it yet because it may have been low from the start. Definitely keep an eye on it, though.
  • kanjiikanjii Posts: 99
    No, this is the first time I checked. I did call Subaru service and this was the first he heard it too. Never happened to my Nissan and Hondas. I thought maybe this is due to a boxer engine. I don't know. Well, I'm off on vacation for a few weeks and the car is in the garage, I guess I can get a qt of oil and put it in just to be safe.
Sign In or Register to comment.