Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2001 SSEI whines & stumbles

wayne477wayne477 Posts: 1
118,000 miles on our 2001 SSEI. Just had the rear shocks replaced with Monroe air shocks, new plugs, new wires, replaced the leaking gasket on the oil pan. Car idles fine, no issues under mild acceleration. Under hard acceleration, it now stumbles/hesitates. Figuring that the plug wires got crossed, I took it back to the shop and we checked that. They seem wired correctly. While checking it out, I also noticed a high pitched whine coming from under the car.

I turn on the car, hear the fuel pump go on and off, sounding normal. After starting the vehicle, the whine starts a few seconds later. DOes not seem RPM dependent.

It's not the compressor mounted under the right rear corner, did not have time to get it up in the air to find the whine, difficult to pinpoint where it originates. The trans seems a bit overfull of fluid, we are getting that addressed.

Pulled the codes:
P0420 - Stored Error(Mode 3)
Catalyst System: Efficiency Below Threshold (Bank 1)
P0442 - Stored Error(Mode 3)
Evaporative Emission Control System: Very Small Leak Detected
P0420 - Pending Error(Mode 7)
Catalyst System: Efficiency Below Threshold (Bank 1)
P0442 - Pending Error(Mode 7)
Evaporative Emission Control System: Very Small Leak Detected

The shop has no idea on the hesitation/stumble, though it was Saturday and they did not really have time to look at it. I was hoping to give them some ideas of where to look.
Sign In or Register to comment.