Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler 300M Care and Maintenance

1235»

Comments

  • hi guys, i have a similar electrical problem lie phaex
    i also have a 99 300M,
    mby battery just died out on me this eve, i couldnt figure out why, i jumped it and it ran for like 2 mins and the engine dies out while i'm moving, i was just happy I hadn't hit the high way.
    a friend who helped me jump start suggested i'm having a problem with the dynamo, i guess like crdivoff mentioned it may be called other wise.
    from what i've heard from others, a dynamo replacemet makes a huge hole in the pocket.
    i'm gonna be taking it to the garage cause the company is a rip off..! nothin new..
    well a reason for the battery to die out is because my tail lights dont go out sometimes and if i dont check it, it takes a toll on the battery.
    however, 2 things that i need to know, is a dynamo / generator a possible problem? or is it the battery?
    and should i get the wiriing checked?
  • i have 2000 300m with over 126000miles it runs as smooth as it can be plenty of power and very quiet unless i punch it the she screams only mods intake and platinum plugs had a damaged coil pack ran on five cylinders for a day 50 dollar part i replaced myself car was back to normal in 10min passed emissions and i was about 2months overdue on an oil change car is great you just have to care for it properly thumbs up to the previous owners you did a good job, i outrun chevy impalas 00 and up brand new altimas and maximas, stock grand prix's gt and gtp 3.5 chargers and magnums crown victorias, got followed home by an officer one he said he was goin to pull me over i need to slow it i was moving way to fast, yeah right i didnt even see him in my rear view mirror i would have never caught up if i dindt slow down to turn into the parking lot
  • mag30manmag30man Posts: 1
    There is a lense kit for glasses you can buy on tv that will do the trick.....you may be able to buy it at CVS also. good luck...........
  • garyghgarygh Posts: 2
    I have a 2000 300M. The last two years I have had a sound in the engine that I will describe as sounding like a air pump leaking air. I have this sound only when the car is driven...never at idle. When the car is at idle it runs and sounds like new but once under way I can hear this sound more and more. To my knowledge there is no air pump on the 3.5 engine.. Any thoughts would be appreciated. Gary
  • I have a 2004 300M Spec. w/70K miles; about two months ago I started hearing a clucking noise coming from the top part of the engine at the back fire wall. I had my sway bar links replaced and the noise was still present. A few weeks ago I notice play in my steering wheel and was told the bushings on my rack in pinion mount was bad and that is in the same area where I here the clucking/knocking noise; any advice out there?
  • i have similar problem with my 300 m 1999 can you help?
    let me know how did you solve the ac fan issue :(
  • I have a 1999 Chrysler 300M that has the Automatic Temperature Control (ATC) Unit fan stuck on high no matter what is selected (Auto, Manual or OFF). It comes on high when I start the car and cannot be turned off. I check the associated fuses (OK) and looked for stuck relays, but there are none associated with the ATC.
    I reset the AC through a certain combination of buttons together but useless someone have post before that a blower motor power module which located on the lower right side of the HVAC unit housing and is controlled by the Body Control Module (BCM). It could have failed on so the fan runs full speed whenever power is on.
    But any idea where HVAC unit or BCM exactly are? And how they look like???
  • Wow, I could have wrote this post because I have the same thing happening to me. Did you ever get this figured out? If so what was the problem? What was it that needed fixed? Any help would be great, of you have found out any info. I'm sure just like me, you are annoyed by this. Thanks
  • Hi,

    I had to finally take it to a mechanic since my attempts at fixing it were futile. He replaced what he called a "Fan Control Module," those were his words for it since I could not verfy that name anywhere. The FCM apparently has a "resistor" in it that burned out (open). When that happens, one can not turn the fan off or control the fan speed, although every thing else works. In any case, that fixed the problem. That module took six months to get because Chrysler's supplier for that FCM no longer made them so I had to wait on Chrysler to get a new supplier. The cost for the module itself was about $190.
  • hello i have a 1999 Chrysler 300m this week out of the blue i see smoke coming from under the hood check it out, to find radiator fluid all over the place thank God it made it made to the shop they replace 2 hose that were damage for reasons i don't know. but now 1 day later the car is still over heading with smoke coming from the same place. :confuse:
  • cklockwocklockwo Posts: 2
    Hi, I have recently had the same problem with my 99 300M. The situation with the ac is whenever i turn it off it will then just go into blower or maybe defrost mode at full speed, just blowing all the air down near your feet. Ac still blows cold and everything works fine but it just wont turn off or adjust any air speed at all, just full blast at all times. Is this the exact issue that you had? If so youve saved me a fair amount of money!
  • shilkomshilkom Posts: 6
    Hi,

    I had to finally take it to a mechanic since my attempts at fixing it were futile. He replaced what he called a "Fan Control Module," those were his words for it since I could not verfy that name anywhere. The FCM apparently has a "resistor" in it that burned out (open). When that happens, one can not turn the fan off or control the fan speed, although every thing else works. In any case, that fixed the problem. That module took six months to get because Chrysler's supplier for that FCM no longer made them so I had to wait on Chrysler to get a new supplier. The cost for the module itself was about $190.
  • cklockwocklockwo Posts: 2
    Thanks again I really appreciate the info! Do you mind me askin how much it cost him to install it too..parts and labor?
  • shilkomshilkom Posts: 6
    $190 for the module and about $40 for installation, I believe.
  • I found a vacuum port on the right (pass.) side of the engine , no plug, no hose running from it. Look on the side of the intake manifold...
  • I have a '99 300M. It produces warm air and cold air, but the blower won't work to move the air out into the car. I've had the blower motor, the blower resistor and the head unit replaced, and it still won't blow the air out. My mechanic spent the last 1 1/2 days trying to diagnose it, but he can't come up with anything. Has anyone encountered this problem before? Any ideas on what may be causing the problem?
  • agbaagba Posts: 1
    I have a 99 chrysler 300m which as 371,000 miles on it I do notice my engine got too hot each time I drive and always had steam in my rear light after packing and sometimes water do gush out from the coolant jar and my battery do run down after I packed the car for hours pls I need help who knows what maybe the problem bcos I love this car.
1235»
Sign In or Register to comment.