Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2005 Chysler Town and Country Limited losing antifreeze, heat not working.

My Van is having several issues. The heat is not working most of the time and its losing antifreeze, I can smell it but I can't find a leak. Its not under the van after I've been parked and its not coming out the exhaust. Also, its not overheating. Worried its serious, like a gasket or cylinder. Hoping its easy like a thermostat, any ideas?

Comments

  • srs_49srs_49 Posts: 1,394
    Check your oil level. See if it's higher than it should be and if you have a light brown, frothy film on the dip stick. If either of these are true, you probably have a head gasket leaking allowing coolant to get into the oil pan.

    The coolant has to be going somewhere!
  • The oil has been low to. I had to put oil in a couple of weeks ago.
  • cmack4cmack4 Posts: 302
    Our '05 T&C just went in the shop with the same symptoms. It needed to have the water pump replaced with only 75K on the clock. Seems too early to me, but I've seen others have to replace them even earlier. I'm not at all happy with the build quality of these things!
  • shopdog97shopdog97 Posts: 160
    edited February 2
    I'm just looking for an answer to an issue my Pastor is having with his 03 Town&Country Limited. He gets great heat and he can switch between defrost and front, etc, but the FAN speed is stuck on Hi always! There is no in between, and the fan also comes on as soon as the van is started up. I was wondering if if might be a bad fan switch? Any suggestions, anyone??? Thank you!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 47,543
    edited March 9
    @ FUZZNUT --You should put a pressure pump on the cooling system (needs to be pumped only only a few pounds over your radiator cap rating). That should show where the leak is. If you can smell it, and there's no excessive white smoke coming out of your tailpipe (like steam), then you have a leak somewhere for sure.

    @ SHOPDOG --- Watch THIS VIDEO
    fuzznut69 said:

    My Van is having several issues. The heat is not working most of the time and its losing antifreeze, I can smell it but I can't find a leak. Its not under the van after I've been parked and its not coming out the exhaust. Also, its not overheating. Worried its serious, like a gasket or cylinder. Hoping its easy like a thermostat, any ideas?

    MODERATOR --Need help with anything? Click on my name!

  • bighairbighair Posts: 1
    2005 I dont know what to do so many issues this the worst chystler I have ever owned!!! I strongly believe its because I payed for it out right!
Sign In or Register to comment.
2005 Chysler Town and Country Limited losing antifreeze, heat not working. - Car Forums at Edmunds.com