Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





MB M-Class Owners: Care & Maintenance

drew_drew_ Posts: 3,382
Ooh, new topic! :-) Thanks Karen.


Drew
Host
Vans and Aftermarket & Accessories message boards
«134

Comments

  • Actually, this is an easy one...contact www.carcareonline.com. In addition to great cleaning and detailing tips, he sells a wide assortment of cleaners at GREAT prices. I'm not affiliated with him, just a very happy customer.

    Bill Shaw
  • roxreps1roxreps1 Posts: 10
    Does anyone know a friend who has a car lift in their home garage, preferably in So. Cal? It's for a commercial shoot. roxreps@aol.com
  • procterprocter Posts: 19
    Does anyone have a manual -- not pirated?
  • Greetings,

    Does anyone know where to buy OEM brakes pads for 2000 ML320? What's the brand Mercedes use as their OEM pads for ML320? Galfer USA or Textar? (Jurid or Pagid?)Please post the websites ASAP. Thanks!

    Paul
  • Hello,
    I was wondering if anybody that owns a 2002 ML320 had the same problems I am having with mine
    I bought it used Starmark certified and afetr two weeks the lights for the BAS ESP AND ETS came on solid, I took the car to the dealer and after a whole week I've got it back "repaired". well right after I drove it for 8 miles the lights came on again.

    Anybody has experienced the same problem, it seem's that the dealer doesn't know how to fix this issue

    Thanks

    MArk
  • Mark:

    It is most likely your brake lamp switch that is located at the brake pedal support arm.
  • Thanks, I will check on that when I take the car back to the dealer
  • Dear Mark,
    I own a 2000 ML320 and had this nagging problem for about 6 weeks. The problem tends to be worse in warmer temperatures.
    The Mercedes Service did the following:
    1. They replaced the control module for the BAS ESP, ETS (I think the Brake light comes on as well). The problem came back.
    2. They noticed that the o-ring on the windshield wiper fluid reservoir was leaking and had shorted the hydraulic pump motor out, causing insufficient hydraulic pressure for the subject systems. They replaced the reservoir and the pump/motor assembly. Problem solved, right? Wrong.
    3. Apparently, the shorted motor did a number on the fuse assembly. They replaced the fuse assembly.
    I've been alarm free for about 6 weeks (since step 3 repairs were done).
    You're lucky that you're still under warranty. I had to pay for the painful process.
    Good luck.

    KL
  • loveylovey Posts: 2
    I am looking to purchase a 1999 ML 430 - I am hoping to find someone who has owned this SUV.

    43,000 miles = $19,500 asking price
    Very clean inside and out - I really like this but the number of postings from unhappy owners has sent up some red flags.

    I have a couple of questions...
    1. any recalls?
    2. repair history?
    3. the seller of this SUV is the 2nd owner, he says on the 99 ML 430 and the 98 & 99 ML 320 their is a 150,000 and 10 year warranty on this oil lubricated parts of the engine. He said the warranty goes with the car not the drive. I called a local dealer - no one has not heard of this - have you?

    PS - I am not a 1st time MB buyer.
  • tt30tt30 Posts: 31
    Lovey,

    You can find repair history knowing the VIN number (use services like carfax.com). There were a few recalls on 1999 ML320, but they should be fixed by the owner.

    Re your 10y/150K miles warranty: My 1999 ML320 just failed so I know the details on this. The warranty applies to the original owner of your ML320 only, and only if the engine fails due to the oil consumption/sludge problem. I talked to the lawyer who won the lawsuit against Mercedes today and he said this does not apply to a new owner on the vehicle.

    Buy it on your own risk!

    ~V,
    ML320 1999 77K miles engine failure.
  • mercaramercara Posts: 291
    I have been happy with my 1999 ML320. 68K miles with no major problems. Ihave had a few minor issues. Never once been stranded. 19.5K is a fair price. But if it has no documented service history avoid it. I would suggest spend a bit more and getting a newer model.
  • Hi
    I have the ML320 since the year it come out 1998. after all this years,I think it is about time to change a new battery. Any one can give me some information for what make and model is good for another 6 years??
    Any info will help thank you all.
  • mercaramercara Posts: 291
    Mine died last year. I couldnt' find any food after mkt batteries. I paid about 115 USD to buy it form the dealer. I installed it myself.

    IF YOU ARE PLANNING TO INSTALL IT YOUR SELF PLEASE DO THE FOLLOWING.

    If the battery is fully disconnected you will have to reset some systems like possibly the ETS. You will also have to rekey in the code for the stereo as the stereo things that it has been removed from the car and re-installed. So what you need to do is to get DC battery charger or a spare battery to supply the current before you completely unplug the existing battery.

    I would recommend doing this soon as you can. Six years is about the life of these batteries and it is not worth trying to keep them longer just to save 100 bucks. Give you piece of mind.
  • Hello Mercara
    Thank's for the infor, I think I will let the dealer to do it for me. you are right it is not worth it when it comes to -38c and waiting for tow truck to come. Not funny at all.

    Thank you
  • emicoemico Posts: 1
    http://www.manualsunlimited.com is selling Repair CDs online. Does anyone here have any experience with this website and their products? Thanks.

    Here's the link:

     

    http://www.manualsunlimited.com/catalog/advanced_search_result.ph- p?keywords=2001+ML+320&x=8&y=8
  • HEY GUYS IVE GOT A 99 ML 430,,I BOUGHT WITH 50K MI ON IT ,,SO FAR BESIDES GAS MILEAGE BEING 19HWY,ITS OK,,BUT WHEN I ROLL THE DRIVER'S SIDE WINDOW UP AND DOWN,I GET THIS STICKY DOOR PANEL ADHESIVE ON THE WINDOW,WHAT IS IT AND,WHAT SHOULD I DO TO FIX IT?
  • jhinscjhinsc Posts: 397
    We had the same thing happen twice to us in our '00 ML320. I think it's something about a gasket or seal going bad on the window motor inside the door. Ours was fixed under warranty each time. Hopefully you have an extended warranty to cover this, as I'm sure it will be an expensive fix at the dealer.
  • Does anybody know how to remove the service indicator light from the dash on my ml 320 after its service. Believe it or not our mechanic did a great job with the service but didn't remove the warning light!

    Any answers??

    Thanks Scott in Australia
  • THANX ILL LOOK INTO THAT....ALSO..HOW DO I STOP THE SQUEAKING MIDDLE CONSOLE IVE LOCALIZED THE AREA BUT I CANT THINK OF WHAT TO PUT ON IT TO MAKE IT STOP
  • i do not have my owners manual..and when i startbthe car,,i get a wrench and a -7000 blinking on the msgindicator,,and then it disappears,,should i panic?,,cuz the vehicle runs great...the dealer i bought it from says its been service but im worried..help!
«134
Sign In or Register to comment.