Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Pathfinder Maintenance and Repair

1626365676891

Comments

  • smokey75smokey75 Posts: 434
    I don't have the service manual with me right now but it said something like "Under normal operation the rear O2 sensors are not used." I've always used premium fuel (and usually quality fuel from Chevron) on my 2001 and I'm about to replace my second sensor. I have heard that too much sulphur damages them though.
  • GHUTCHINGHUTCHIN Posts: 4
    I am having the same problems and I have replaced some, but not all ignition coils. The engine light keeps coming on but it doesn't seem to missing anymore. I have to take it back it, I guess. On top of that, I am experiencing automatic transmission 'flaring' and some sort of problem with a mass airflow (not sure what it is, too many problems at this point).
    description of flaring problem.
    http://auto.consumerguide.com/Auto/Used/reviews/full/index.cfm/id/2506/act/usedc- arreviewshowall/
  • jfkjimjfkjim Posts: 2
    My Pathfinders warning that goes off when you leave your lights on and try leaving the vehicle before turning them off , is not working, I cant find any info in the owners manual. I have talked to a guy who says it is a square small box in with the fuses, and he may be right, but there are threee square boxes , different colors, and no labels on them. Anyone have tha answer to this ?? I really miss that warning ! Thanks
  • mwalburgmwalburg Posts: 1
    This dome light issue is the cause of a rusted pin switch that is in the rear hatch. Remove the rear plastice panel and it is easy to spot in the center of the hatch
  • gallengallen Posts: 4
    ok i've had my 87 PF for about a month now and i love it just that when im driving it doesnt have enough power to get going but fine after 55 mph and i need to know some ways to boost horsepower but i do some trailing so i dont want to hurt the wat i trail. ok also on my PF on the left of the steering wheel on the dash there is a switch that when i switch it i hear a click in the front of the car could that be the locks for the wheel or wat? i know there are locks on the hubs of the rims so i dont know :confuse:
  • raddyraddy Posts: 2
    An update and solution to the problem! Only after 3-4 years of having this problem slowly get worse and after Transmission people say that I need a complete transmission rebuild! Took the car to a NISSAN dealer who took it for a spin and identified a faulty heat sensor in the transmission which was causing the overdrive to disengage. Only cost $150 AUD for the part and labour!

    Cheers
  • I had a problem very similar to this. The mechanic I take the car to said it was a problem with one of the front hubs. Apparently one is starting to engage at low speed causing a thump, thump, thump, and occasionally a buzzing sound like a piece of cardboard in a bicycle wheel.
  • beatle1beatle1 Posts: 2
    Dear Jc,
    The right hand side head lamp on my pathfinder does not work, I have checked the bulb and the fuse, both of them are OK; so I suspect that some relay can be faulty, but I have no idea where they are located, I'm sure your instructions about the fog lamps will be useful to clear my problem, can you please send me that by e-mail (ivanz_bo@yahoo.com). Any other info about the wiring on pathfinder head lamps will be welcome as well.
    Thank you in advance
  • beatle1beatle1 Posts: 2
    Tgee,
    Ihave the same problem on my pf now, can you let me know how did you solve it?
    Thanks in advance
    beatle
  • A well known documented problem that a good amount of pathfinder drivers will experience around the 100k mileage mark caused by the rear control arm. From some research I’ve been doing I realized that although this problem is well documented there are still a lot of you that do not understand or of heard about this problem. Do you get a severe swaying starting from the rear end of your vehicle when you hit around 70 mph? Usually drivers experience this when they let of the gas pedal around that speed. Only way to fight this swaying is to let of on the gas and hope the sway goes away. There are lots of independent auto mechanics that have a hard time pin pointing the exact cause of this particular swaying problem the pathfinder has. Therefore many people end up taking advises of these mechanics that do not fully understand the problem. So you owners of this vehicle end up replacing struts, shocks, and even getting new set of tires. After all these fixes you still realize your main problem the swaying has not been fixed. Almost everyone that had this problem wasted their money on fixes that had nothing to do with this problem. I have come up with the exact solution on how to fix this problem and hopefully save you some money.

    Nissan Pathfinders 1991-2002 swaying is caused by the bushings in the rear control arm. There are two arms in the rear of your car the upper and the lower arm. Typically what causes this problem is the lower trailing arm. What I recommend is that you replace the Lower arm first to see if that fixes the problem. If swaying continues replace the upper part of the arm. That should fix the swaying. Another option you have is to replace just the bushings that are located on each tip of the lower arms. Each arm has 2 bushings on each end so you will have to purchase 2 sets to replace just the 2 lower arms. I would recommend you purchase Polyurethane bushings. Those are stiffer then the original Nissan bushings and will last longer then rubber. You may buy them >>HEREhttp://trusty625.blogspot.com/2006/04/nissan-pathfinders-swaying-problem.html
  • jman73jman73 Posts: 1
    My '95 PF just started blowing a 10A fuse (marked "meter" in the fusebox) that shuts down the tach, speedo, OD, and shifting. I can't drive more than about 10-12 miles at highway speed before it blows. If I replace the fuse right away I can drive a few less miles before it blows again. I can keep doing this until eventually the fuse will blow as soon as I shift into drive. The PF is drivable when the fuse is blown, but it doesn't shift automatically. Any ideas on what could be causing this?
  • xplorx4xplorx4 Posts: 621
    LOL! Wow, those are photos of my truck! Wow, I'm flattered that my truck is now used as a reference on a blog!! ;)

    Do note, however, that the lower link shown on the link has been modified. A piece of angle-iron has been welded to the link for off-road durability. OEM links are just round tubes. The bushings, though are the stock ones, which were later replaced with polyurethane bushings.

    After replacing only the lower links, I have not had the swaying problem return. (One of these days I'll get around to replacing the upper links as well.)
  • aholmesaholmes Posts: 1
    My rear brakes squeal, right rear wheel. I pulled the drum. It looks fine. The shoes are'nt worn. I'm considering replacing the drums,and the shoes. I cleaned the drum and shoe pads, there's less squealing, but still consistant.I have all of the replacement part's. Will the squealing stop if I put on new shoes, springs, and drums?
  • 56roses56roses Posts: 4
    I purchased a new 2004 Nissan Pathfinder in March 2004.
    At 5600 miles (February 2005) I noticed the front tires were wearing unevenly. Took to my deal and was told everything was OK and the tires showed no uneven wear. At 7900 (May 2005) miles the both front tires were quite worn on the inside edge. My dealer now tells me I need an alignment that is why the tires are worn. After much discussion as to why they did not notice this just 2300 miles before they performed an alignment for free. I still had the problem with the worn tires to deal with but the service manager would do nothing saying it was due to the alignment (hard to believe the tires were so badly worn after only 2300 miles since the last inspection when they were said to be Ok by the dealer. I spoke with the owner of the dealership and he said Nissan USA would do nothing but he would split the difference with me as follows:
    Take my full size (new) spare and use that for one front tire, he would take a tire off a new vehicle in his lot as the other front tire and the less worn of the original front tires would become my spare...I agreed to the "compromise". (The dealer did not do the alignment again when he switched the tires saying it was fine).
    Now at 12500 (march 2006) miles my front tires are once again quite worn it the same way (that is only 5,000 miles since they were replaced). I took it to the dealer and they say they see nothing wrong but I should get an alignment. After much discussion again they agreed to perform the alignment for free. This time, though they would do nothing about the tires.
    I spoke with Nissan USA who reviewed the dealers records and they say there is nothing I can do unless I take the car to another dealer and that dealer finds something wrong. Since the car was just aligned, again, I highly doubt there is anything to find.
    I need your opinions on how to proceed. Is this not unusual? How can the a vehicle the manufacturer advertises as an "Off-road vehicle have its alignment go out so easily? This car has only been driven on smooth pavement.
    My biggest problem may be I can not use the lemon law here in NY State since the car is older than 2 years (although as you can see we do not use the car much since it only has 12,500 mile on it).
    Your opinions and help are much appreciated.
    Barry
  • zzr12zzr12 Posts: 18
    I had approx 2500 miles on my 04 LE when I noticed that the outsides of the front tires were wearing unevenly. I took it back to the dealer who performed a wheel alignment for free. I now have 25,000 miles with no abnormal wear. I would try another alignment. Hope you get it sorted.
  • schlickschlick Posts: 2
    My sway bar link has a crack in the rubber boot. Do I need to do an alignment after replacing them?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,796
    nope.

    MODERATOR

  • caharrisoncaharrison Posts: 1
    I have a 1997 Pathfinder, and the Check Engine light just came on this past weekend. The shop told me the #1 O2 Sensor is bad and it'll cost $258 to replace it. This seems expensive to me, since the cost of part appears to be around $70-80. How difficult is the #1 sensor to replace? I've heard it takes a special wrench that's about $20, so am thinking about doing it myself.
  • ridesnowridesnow Posts: 6
    automatic transmission "flaring" problem....my auto. trans feels like is slipping...but this only happens when its cold or not warmed up. Might be the same "flaring" problem ur talking about
  • ridesnowridesnow Posts: 6
    my suggestion...if u have an '87 PF and its giving problems...get a new one...or atleast a newER one =) ur PF is almost 20 years old
  • ridesnowridesnow Posts: 6
    i have an 01 Pathfinder and also have a transmission slip or "flare" when its cold or not warmed up. I really think nissan knows about this problem and many other problems such as ignition coil failior/mis-fire and they are not addressing the problems or admitting these problems are NOT part of regular maintanence. I also have a powersteering leak.
  • smokey75smokey75 Posts: 434
    Nissan does know about it. Read the TSB for it at www.nissanhelp.com. Your dealer will be happy to fix it... if you're still under the powertrain warranty.
  • mick9mick9 Posts: 2
    2006 pathfinder diesel auto 18000 miles dealer says needs all 4 discs and pads has anybody come across this amount of wear in such a short time
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,796
    Seem odd to wipe out all the rotors. Wasn't your brake pad wear sensor working?

    MODERATOR

  • wwkwwk Posts: 1
    Hey,
    Where did you get the polyurethane bushings? I really need to order all 8 because I'm begining to get sea sick driving to work.
    Thanks
  • mick9mick9 Posts: 2
    pads had not worn down to sensors (nearly) but the wear on the discs was unbelievable
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,796
    Sounds like low grade OEM rotors to me in that case...if they weren't warped or burned but only ground up, one would have to presume the metallurgy or the pads were not the best. I can see a race car doing this but not a Pathfinder.

    You might consider shopping around, asking around and seeing if some aftermarket products might be better for your truck.

    MODERATOR

  • Is there an issue with this model year moving with the brake depressed or moving quickly after the brake is released, but before gas pedal is depressed?
  • jomarchjomarch Posts: 6
    MY FUSE KEEPS BLOWING THAT CONTROLS MY INSIDE OVERHEAD LIGHTING,CLOCK,ALARM SYSTEM AND DOOR LOCKS. I HAVE TO LOCK THE DOORS MANUALLY BECAUSE EVERY TIME WE REPLACE THE FUSE...IT SEEMS TO BLOW IT SHORTLY AFTERWARDS. CAN ANYONE HELP ME BECAUSE THE MECHANICS CAN'T SEEM TOO AND I CAN NOT AFFORD TO PAY THEM BECAUSE I AM DISABLED.

    SINCERELY IN NEED OF HELP AND SUGGESTIONS
  • rickdb1rickdb1 Posts: 1
    I have a 1996 Pathfinder and was wondering if it is normal for the security system to automatically lock the doors after a preset time after parking the vehicle? Seems to only do this when the keys are removed from the ignition. Is there a setting that can be changed to stop this? Afraid I'll lock the keys in the car if I forget them when parked in the garage, Etc. Thanks for any help,

    Rick
Sign In or Register to comment.