Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Pathfinder Maintenance and Repair

18586878991

Comments

  • Did you get it replaced?? Its so easy to do, I seriously bought mine online and replaced it for 120.00, car has worked great sense then, and or kragen has them for 150 i believe. Im a grl and could replace.
  • 99accent99accent Posts: 232
    look at the motor under the area of the antenna ,find a red wire going into it and pull the little connector off this will stop it
  • I am only getting the P1167 code. How do I determine which oxygen sensor needs replacing?
  • P1167=Heated O2 Sensor 2 Maximum Voltage Monitoring Bank 2
    H02=Oxygen sensor
    S1=Front Sensor/S2=Rear Sensor
    (B1)=Right Bank Sensor/(B2)=Left Bank Sensor
    Therefore P1167=Rear/After Converter Left/Driver Sensor
  • longfieldlongfield Posts: 1
    What would be a fair price on changing the front wheel bearing on a 4wd 2001 Pathfinder?
  • I have a '98 pathfinder xe. My tail lights and dash lights are not working. The 'TAIL' fuse in the engine compartment is fine. I've also put a new headlight combination switch in with no change. Does anyone have any suggestions!?
  • pfx2pfx2 Posts: 5
    edited August 2010
    I just changed my fuel sender switch to fix the gas gauge that wasn't working. It seems to be a common problem with the Pathy.

    Now my MPG is dropping? It was around 16 now 14 MPG. The dealer did a smoke test to check for a leak in the fuel system.

    I changed the plugs and air cleaner too? Checked tire air pressure

    Any tips?
  • You all know about the recall involving the DTE (distance til empty) situation, right? If not you should look into it.

    Back when my 06 Pathfinder was brand new and I ran out of gas twice (on my way to fill up... gas level showed 1/8 tank but was actually empty) I wrote to Nissan North America, spent alot of time on the phone... to no avail. The dealership did replace the part eventually , under warranty, but in the last few months we got a recall notice about this exact situation. I wonder if my persistance with Nissan NA had anything to do with it....
  • m6userm6user Posts: 3,037
    Hi,
    I'm posting this here and on the Infiniti QX4 thread. The Infiniti thread is very quiet and since the vehicle is pretty much the same as a Pathfinder I was hoping that someone here could help.

    Does anyone know exactly how many catalytic converters there are in a 2002 QX4? Was getting a rear bracket repaired at Midas and they stated that my catatlytic converter was leaking bad to the point you could see it. They said since I have 77k and just short of 8 years since purchase it should be under emissions warranty. I checked and the emissions warranty says it will replace catatytic converters up to 8yrs/80k miles. I've got 3k and 3mos left.

    Called and made an appointment with the dealer and they started to give me the runaround about certain catalytic converters being covered under that law and others that weren't. Something about pre and post catalytic converters???? Said they will have to look at it but it sounded like he had already made up his mind to deny warranty work. Went on to several auto parts sites and could only find mention of two converters....one on each side. Don't see any mention whatsover of pre and post converters. Am I getting the runaround?? Does anybody know?
  • I have a problem my Nissan Pathfinder 01, The rear of my truck is lean to the left, i replaced the both coilspring and struts because thats what they told me in the dealer to replace. But it's still leaning. If someone can help me its going to be apreciate. Thanks
  • gsemikegsemike Long Island, NYPosts: 1,783
    Check out the control arm bushings
  • Hello,

    I own a '02 Pathfinder 4WD with over 150K, and the SES light came on about 3 weeks ago. It has been off and on - we tried tightening down the fuel cap, and that seemed to help for a little bit.

    Anyway, O'reilly ran the dx machine and the code P1167 came back. I've done some internet surfing and it seems the code is for the Oxygen Sensor, but I can't figure out whether it is rear (inclined to think so) and whether it is drivers or passengers side. Different people claim different things, and since it runs at least $80 at a parts store I'd rather not install it wrong and have to buy two.

    Also, I'm planning on changing it myself, but don't own a modified-O2 sensor socket...can a regular wrench be used w/out harming the wiring?

    Finally, a fuse is bad as well - at night we can't make out our RPM or temp meter, though the light for the MPH & Gas gage are working just fine. Would the SES light be connected by chance to a blown fuse?

    Thanks for any help you can give. Appreciate it!
    -slimbear
  • shark715shark715 Posts: 380
    Slimbear, before you go any further, see below. You can register for free and read the Nissan technical bulletin related to the code. The SES light would not be lit by a problem with the instrument panel lighting.

    http://x.nissanhelp.com/forums/Knowledgebase.html?catid=241&filter=&page=1&keyid- =44
  • raycmraycm Posts: 1
    Our 96 Pathfinder threw Crank Position Sensor code, I replaced it, even though it had been replaced several months earlier. Cleared the code, check engine light stays off, but when you start it, it idles very erratic, then dies. It feels and sounds like its way out of timing still. I've replaced several relays, map sensor is fairly new also. Is there another sensor or something that doesn't throw a code that might be causing this?
  • Geeesh, what a good resource! Thank you shark715, the help is much appreciated, and now i know where to turn in the future.

    I hope O2 sensors aren't hard to change out in Pathfinders, because I'm planning on doing it myself this Tues.

    Thanks again for the help.
  • My 05 Pathfinder has been vibrating at about 45 to 65 mp/h on the highway, but only when the accelerator is pressed dowm. When I coast, it goes away. This sounds like the u joints are gone (again). Is this a readily available part that pretty much any mechanic can fix or am I stuck with the dealer?
  • 99accent99accent Posts: 232
    2003 pathfinder le v6
    I see a lot of the v6 35D engines need chain tensioner replaced at only 50,000 miles, I started to here a slapping noise but it runs good, should I have it checked out buy the dealer, and what would this fix repair cost me? anyone ever have a chain done
  • 99accent99accent Posts: 232
    what oil can you use un a nissan v6 03 path finder 10x4o
  • cactushingecactushinge Posts: 3
    edited February 2011
    I was cruising at 70 MPG when I had a misfire with a slight chug. Within 30 seconds it did it again and then started missing 3 or 4 times in 5 seconds, within 2 minutes I lost power and truck would only barely drive at idle. It knocks and spits very violently when accelerating. I drove it 3 or 4 miles to an auto parts and the catalytic converter got red hot and melted the carpet under my seat. I couldn't drive more than 15 or 20 MPH. I first suspected it being stopped up so I disconnected the exhaust to see if it ran any different. It didn't make any difference. I put it back together and put a new fuel filter on. I have good fuel pressure and don't think it is the fuel pump. It starts fine idles a little rough and pops real loud when accelerating as if the intake valves are open during combustion. It sounds identical to a motor with timing off. If it wasn't for the mild miss fire at the beginning I would check timing marks. Before I purchase a scanner does anyone have a good ideal what this may be? I broke down while out of town and I don't even have my repair Manuel for code references. I don't even remember how to pull them up.
  • 99accent99accent Posts: 232
    A 95 HAS A TIMING BELT that could have jumped a few teeth .
    have that timing belt checked out before you run it again.
  • cactushingecactushinge Posts: 3
    edited February 2011
    I replaced the timing belt about 75,000 miles ago. If that is the problem why would it start out so mild having only 3 or 4 misses within a minute or two at 70 MPH? I could understand belt jumping if it lost power all at once. Perhaps at the beginning the computer was able to compensate, if it jumped very little at first? Thanks, I may take a look at the belt.
  • 99accent99accent Posts: 232
    those belts have to be replaced at 60,000 yours is 15,000 overdue
    I hope thats the problem the belt thats an easy fix if it is
  • cactushingecactushinge Posts: 3
    edited February 2011
    I guess I was looking for something more complicated. I was going to buy an import engine right away because I have 250,000 miles on the one that I have now. It leaks oil and I didn't want to spend 30 or 40 dollars for a belt. I gave it one more good look. As I was looking for any loose connectors or vacuum leak as I just wanted to be able to drive it to a safe place to leave it for a week until I could get it home. I found a fuel leak. A small rubber fuel hose about 3" clamped to steel tubing on each end. The hose is rotten and it was leaking. The truck was idling and as I moved the hose with a screw driver the roughness stopped. I tightened the clamps and drove 90 miles back home. I am going to replace the fuel line. I am amazed how the engine sounded like it was falling apart with because of a small fuel leak. It could have been worse.
  • Well, my 2001 Inifinti QX4 just had it's service engine light turn on. I took it to AutoZone for a scan and it came up with a P1320 code - http://www.infinitihelp.com/diy/obd_..._infiniti.html

    Took it to the dealership and they have diagnosed that 3 out of the 6 ignition coils have failed and that the other three are weak. If they replace the 3 failed ignition coils, they say that leaving the three weak ignition coils will still cause the service engine light to go off, not allowing my car to pass inspection which I need to do this month.

    They wanted $1300 to replace all six ignition coils and spark plugs. Ignition cables are $135/each and labor is $390.

    Instead of paying that ridiculous amount, I ordered the parts from RockAuto for $320 and paid a local repair shop $170 to install the new coils and plugs.

    After clearing the code, on the second start, the P1320 code comes back. So far, my shop has found nothing wrong with the MAF, crank/camshaft sensors and wiring.

    Note, thru-out all of this, my car starts and runs fine. The only thing noticeable is a high drop in gas mileage.

    They took the car to another shop they work with and they believe that the coils I bought might not be working properly and suggest replacing all of the coils again.

    Right now, I'm having them replace the 1st(different than 2-6) coil. If that doesn't work, try swapping a new coil in for 2-6 to see if they can determine if just one of the coils is bad.

    Any other ideas besides taking it back to the dealership? They'll probably want to replace all of the coils with oem ones first.

    Anybody else have this issue with their Pathfinder?

    Thanks for reading...
  • my 1995 nissan pathfinder suddenly stopped going into reverse what can I do to fix the problem
  • dbinkleydbinkley Posts: 1
    edited March 2011
    1999 pathfinder

    removed blower motor and put 12 volts on leads, motor engaged no problem. checked fuses and they are good. put meter on connector and the voltage was very low. Any ideas on what else i can check?
  • dnn1942dnn1942 Posts: 1
    My 2002 Pathefinder instrument lights did the same thing. On mine the contacts seemed to lose the tension. removing the three bulbs and slightly bending the ears/contacts seems to have worked so far. I will order a new set of bulbs for the next time they go out. Removal is easy. stubby philips for the 2 screws in the top of the bezel. then pop it out, top first. the rest is obvious as you can see screws. bulb housing are 1/4 turn.
  • Why is my nissan pathfinder 2003 se 3.5 engine gauge is reading way to hotter than normal. I've replaced the therostat / radiator / fan clutch / radiator flush / (in same year). Drive my truck for 15mns in a hot day again the guage for the temp. reads very high??
  • 99accent99accent Posts: 232
    edited July 2011
    the 2 things you didn't check and cant is the impeller inside the water pump to see if its slipping, a 2003 has a timing chain that turns it on the shaft.

    the easy thing to check is the radiator cap ,they do get distorted or cracked ,this is the first thing to check or just get a new one from Nissan, there was a discrepancy one of those caps because one is 3 lbs less in pressure rating that the other ,so make sure you get the right one . :shades:
  • shirl21shirl21 Posts: 2
    My daughter has a 2002 Nissan Pathfinder. Her check engine light came on recently. It was told to us that the possible cause is this IVTC sensor. Can anyone explain it to me? Does this need to repaired immediately? How much would something like this cost me? I appreciate any assistance with this.

    Thanks!
Sign In or Register to comment.