Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





MB M Class Owners Maintenance and Repair

drew_drew_ Posts: 3,382
Hello everyone,

This is the topic to discuss any problems that your M-class has (had) and any solutions to the problems.


Drew
Host
Vans and SUVs message boards
«13456733

Comments

  • kenyeekenyee Posts: 738
    I've collected a list of known problems at the M-Class Outpost.
  • drew_drew_ Posts: 3,382
    Spraying some silicon spray into that area (along the base of the windshield/dash) and letting it work its way in for a few days solved the probem for me. However, I did mention it at Service A. FYI, according to the work order, "A-pillar trim fit foam under dash corner to realign corner of dash. Refit A-pillar trim". The slight amount of play that used to be there is now completely gone. It is as tight as the A-pillar trim/dashboard on the driver's side. No squeaks, no creaks. :-)


    Drew
    Host
    Vans and SUVs message boards
  • kiiwiikiiwii Posts: 283
    There was an engineering oil class action against MB. Not sure what the model year coverage is, instead of 50k miles, I belive the engine warranty is extended to 100k for the engine oil problem.
  • jmsintxjmsintx Posts: 41
    How do I get to the cabin air filter for replacement ? Is it behind the glove box like on the E's ? TIA. JMSinTX
  • lsl1207lsl1207 Posts: 6
    I have a '00 and at 10k it needed new brakes and at 26k it needed a new transmission. At one time or another all of the computer lights go on for no reason. Next time I'll buy Japanese...
  • dietmikedietmike Posts: 7
    My upgraded Bose stereo on my 2001 ML320 Sport seems to have a reception problem. Most of the major stations in the Dallas, Texas area come in "weak". It sounds as if the treble cuts in and out just a bit. The CD works fine so I know it has something to do w/the antenna/tuner.

    Where is the antenna, in the windshield? .. and has anyone else had this problem?

    Thanks!
  • tlwwsotlwwso Posts: 12
    I'm getting a popping noise coming from somewhere at the base of the windshield on the passenger side. I saw the post from Jan. and didn't know if this is the same problem. The service department can't seem to fix the noise. Any suggestions? Thanks.
  • djdjdjdj Posts: 111
    In the general M-class commentary I have read that several owners have had problems with false readings appearing.

    OIL HI frequently comes up because it takes 8.5 bottle of oil and somedays mechanics pour in 9 whole bottle.

    But the problem could result from a bad sensor.

    After a 4 day battle with my dealer, the truth came out that this sensor is frequently defective. Mine read "OIL HI" and then "-2.0".

    The sensor needs to be replaced and it happens so often the dealers keep a number of the replacements on their shelves.
  • I have a 2000 ML320 and this is the second time that I have been stranded due to a seized fuel pump. Am I alone? Also, I have had numerous problems with the air conditioner, side door film, easily chipped paint, cracked rear support, etc. I never expected the MB to have so many problems.
  • biker5biker5 Posts: 199
    Hey, Buddy You are not alone, It happened to me twice also, if you read my post a few months back, my fuel hose busted on me while I'm driving in a high speed on a highway my ML just died and that was one of the scariest moment of my life I have my family with me. I just thank god and I managed to pull my ML to the safe side of the highway. They replace it twice and so far up to this date I don't have any problem. Take it back to the dealer and have them replace.
    Good Luck,
    Jim
  • Did anyone experience this problem? I was driving on the highway, a couple of days ago, and I noticed the ETS light (second left on the dashboard) being ON. It stayed like that eversince, when the engine is started, with the exception of 2-3 seconds right after I started the engine ytesterday day.
    I thought it may be a fuse, and this is how I saw in the fuse box that F22 coresponds to cruise control + traction control (ETS) + ...
    The fuse was fine, but this is how I got to test the cruise control, that I don't usually use, and found out it's not working anymore.
    So, please, if anyone had this problem before me, tell me, what should I expect if I go to the dealer? Is the diagnostic free of charge? This would be my first time going to the dealership with a problem...

    Thank you in advance,
    Serban
  • biker5biker5 Posts: 199
    If your vehicle is still under warranty take it in and have thenm check it. I had aproblem on my BAS but not ETS.got fixed under warranty.
  • I have a 99 ML 320 and recently the fuel pump also died as I was trying to get the car out of the garage, I am so fortunate that I was not on the highway as "biker5" above! The dealer replaced it under warranty, however the other things - rattles in the rear door and the electrical problems (all warning lights go on for no reason, window motor dying, rear wiper motor quitting)I have had it with this vehicle & I am turning it in when the lease is up. This is my first Mercedes and I have really been disappointed by the experience. I am looking at Toyotas and VWs now.
  • biker5biker5 Posts: 199
    Lucky you, that you are still in your garage when that fuel pump failure happened to you. So you read my experience Huh!. But since they replaced mine I don't have any more problem...knock on wood.;-) anyway have the dealer fix all the problem, yours still under warranty right.
  • rpalabarpalaba Posts: 1
    Need information on ML320 2002. Inside air circulations turns off by itself every few minutes. Benz dealer says it is a feature, although it took a while for them to tell us it is a feature (over the weekend for the salesman). Can't find the feature documented elsewhere. Is this true?
  • mclass4mclass4 Posts: 3
    My new ML320 had a power steering leak and a faulty fuel pump after 11 days of driving. Anyone else heard of this happening?
  • don99lhsdon99lhs Posts: 9
    Last week my 2000 ML320 developed a tranny leak. It seams to be leaking around the rubber seal on the trans. pan. The bolts that hold the pan on seam a little loose but when you tighten them it leaks worse. What should I do?
  • rnursernurse Posts: 3
    Wow! I was really keen on buying a used, err uh, previously owned 2001 ML430. But after reading all this, I'm not so sure anymore. Is there a place where I can find out if there have been any recalls on this vehicle?
  • Karen_CMKaren_CM Posts: 5,020
    Check this Edmunds.com article for info:

    Recalls, Technical Service Bulletins, and Other Good Stuff

    KarenS
    Host
    Owners Clubs

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

  • aspesisteveaspesisteve Posts: 833
    trying to sell my used ML320.
    Having by far the lowest priced Y2k car in the paper tells me these cars are not selling,
    because the only interest I get is people who want to pay $26k for a car that sold for over $40k just 2 years ago.

    The dealer I bought it from offered $25k - and said only on a trade. I was so pissed off that
    I told him I would park it out in front of his lot with giant for sale signs on it and a price much lower than the $35k he asks for the very same car. The MBZ dealer thinks he adds value by certifying a car that is fully under warranty and has been meticulously maintained.
«13456733
Sign In or Register to comment.