Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





MB M Class Owners Maintenance and Repair

1235722

Comments

  • roberto11roberto11 Posts: 4
    Has anyone been able to find out the cause (and fix) for this problem?
  • jckalachejckalache Posts: 6
    I've had MB look at the dashboard at least 6 times. At one point they removed the windshield and decided to weld the A frame thinking that that would fix the problem. It didn't and as a result the car started leaking water on both the driver and passenger sides. Eventually, they called for MB quality experts who ended up taking many pieces apart and found that the AC cooling insulation inside the dash is loose. The noise is kinda of gone but let me tell you for every piece they took out or messed with they introduced 10 new rattles. My point is be careful with MB technicians trying to fix one problem only to introduce many more. Again, I am sorry to say ml320 quality is very poor and MB technicians can't really help, at least in my case it's been a reoccuring issue.
  • email77email77 Posts: 27
    Hi
    Is it sound like a very high pitch noise, sound like coming from a fan. my ml320 1998. starting to do this some time last winter. it only happened in the very cold day. is not the belt. the noise is only hear inside. if you try re start the engine the noise will go away.
    Any one know how to fix it please. I don't trust MB dealer, they keep the car inside the garage so the car is warm. than tell you that is no noise at all. so you look like a ????.
    by the way the noise goes away after 10-15 mins.
  • jasijasi Posts: 2
    Recently got some bad gas. Had water in it. What needs to be done to fix this right?

    The place I purchased the gas at states I was the only one who has this problem. I always purchase my gas there. Purchased fuel on one day, had 'B' service done on the car. No problems. Gassed up the next day and with in a short time the check engine light came on.

    Thanking you in advance,
  • email77email77 Posts: 27
    Well
    What I would do is pump out the wate/gas tank. refill a tank of gas/gas.
    By the way how do you tell that is a water in your gas?
  • email77email77 Posts: 27
    Well I have just been told this noise is coming from a fuse box it had a fan inside. this fan make a high pitch noise. any one know how to fix it?
  • My 2002 ML500 has had excessive vibration - replaced all 4 tires around 25,000 miles due to severe wear; no improvement, in fact, vibration now occurs at lower speeds. Had front end checked, tires re-balanced. Just took care of repair for safety recall on power steering hose clamp. My imagination, or perhaps vibration has decreased... is there any possble connection?
  • roberto11roberto11 Posts: 4
    I just dropped off my 1999 ML320 at the dealer today to have recall service on the power steering hose clamp and to have the shrieking noise in the dashboard fixed. The dealer knew immediately that it was an "aspirator motor" and said I should have the vehicle back by tomorrow.
  • ew6ew6 Posts: 1
    Hi, I have a 2000 ML430, and have had all the same problems as you. I am disgusted with MB and this car. My service advisor actually told me one day to get rid of this vehicle. (Off the record, of course.) He said he is tired of making excuses for a "failed product." You mentioned a possible repurchase of your car through the lemon laws, and I was wondering if you wouldn't mind explaining in more detail, as I feel like I have been royally screwed by MB with this truck, and don't know of any recourse I can take. Thanks.
  • Karen_CMKaren_CM Posts: 5,018

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

  • she1122she1122 Posts: 33
    I see from a prior post that someone is asking about early replacement rotors. I have a 2000 ML430 and a friend, who is a brake mechanic, commented that the back rotors of my vehicle look dangerously worn. The ML has 34000 miles on it and the brakes were inspected at 23000 miles. I had them take the brakes apart as I was worried due to all the screeching noises they made. A Mercedes tech mentioned that the brakes have been upgraded in the newer ML's. Does anyone know if this is a warranty issue and the brakes can be replaced? My friend commented that the rotors looked like a safety hazard.
  • bczechbczech Posts: 2
    I had the same problem with my 2002. It was the fan for the fuse box. At least that's what they told me and I haven't heard it since.
  • batuceperbatuceper Posts: 4
    I have a 2000 ML320 which will run out of the MB warranty later this year.

    Can anyone with experience of 3rd party extended warranties give me advice as to which are the reputable companies from whom to purchase extended warranties?

    I am located in Dallas, TX

    Many thanks
    Steve
  • Karen_CMKaren_CM Posts: 5,018
    Take a look thru the FWI board for discussions concerning various warranty companies. And you might want to pose your question in this discussion:

    Extended Warranties

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

  • I've had the ML320 for four years now, and it has been giving me some engine problems lately. Although the vehicle starts up, the initial few minutes of drive is VERY jerky, and it will not rev up to more than 3000RPM, or it will knock, with severe backfiring. After the engine reaches optimum temperature, high RPM is not a problem, but pedal-to-the-metal, it can't crank out more than 140km/h. I've taken this baby up to 200km/h without a hitch, but not now. Also, the engine sounds like it's driven by chains or something, as it gives a funny motorbike-like sound. The dealer hasn't a clue. Any feedback, especially successfully solved similar situations, would be greatly appreciated. Thank you.
  • bkbroilerbkbroiler Posts: 2
    I too just had a problem with water in the gas. My 2000 ML320 started to run very roughly and I lost a lot of power. I was in the middle of no where (no cell phone service) and was barely able to limp to a diner which was about 10 miles from the gas station. They had to tow my ML to the nearest dealer which was 80 miles away. At that point I didn't know it was the gas. But they said there was water in the gas and it caused over $2000 in damage. This just happened and they are still working on it. They have to replace the fuel pump, fuel filter, fuel injectors, spark plags and drain and clean the fuel tank and fuel lines. It's still under warrenty but of course this is not covered. My insuarance company may cover this (still trying to find out), but if not then I need to try and go after the gas station (mom-and-pop stiation in little podunk town). When you add in the towning and tax they estimate the total bill will be close to $3000.

    Ouch, all because of some water in the gas!
  • kiiwiikiiwii Posts: 283
    The problem you described sounds like a bad thermo sensor in the engine. The computer is giving bad mixture of air/fuel. My colleague and I had experienced the same symptoms on our cars (not MB). The problems were caused by the thermo sensors.
  • twinmom2twinmom2 Posts: 1
    We've had very few problems with our SUV, other than the gas cap cover not closing, power steering clamp going out twice (and then we received the recall notice!), the glove box door becoming loose and the heated seats not working. Okay, I'm being facetious but really nothing major like engine problems. The heated seats being the most serious since it never worked well and we recently asked the dealer to have it fixed since we're still under warranty. It's been nothing but a nightmare and a comedy of errors. First of all, they had to remove the whole bottom seats and replace the leather since the warming unit is one piece. When they replaced the bottom seat of the driver's side (they forgot to order 2!) they never mentioned it was different color from my current interior (hence, the back of the seat and the bottom were 2 different colors!) I had to bring it to their attention and then they of course agreed with me. Again it's taken them 3 months to order this part and now they have to order it again since it's the wrong color. Two weeks later, our Service Rep calls and informs us they have discontinued my original upholstery color and that the dark gray they installed is the current color. They have offered to replace all the seats, the middle compartment and headrest but will not replace the sides unless I really insist and said they would work with me. They've had my car now for 2 weeks and still have a backorder piece, in the meantime they've given me a loaner.

    For those of you wondering, you can tell the color difference since the steering wheel is black and the side panels are black.

    We really need a bigger SUV with a third row. So here is my question to you all: What would you do in my place? Ask them to buy my car for high blue book since we really need a third row? I'm not sure I want another ML but I feel as though I'm stuck with another MB.

    Appreciate any advice.
  • jasijasi Posts: 2
    The fuel pump/filter and 3 injectors had to be replaced on my '02 ML 320. The gas retailer's insurance paid for the repairs and rental car (I was going on a trip: they provided me a '03 Chev. TrailBlazer. You don't know what you have until you drive something else.

    A tip for all: Pay with credit card or get 'cash receipt' and put your odometer mileage on the slip. You can verify (hopefully will be creditable) how many miles since you fueled up there. I always use the same gas station unless on a trip.
  • bkbroilerbkbroiler Posts: 2
    Actually my insurance company covered the $3000 bill I got for getting bad gas (looks like water contamination). They are going to go after the station but they say it will be difficult unless they find a pattern (others with the same problems from the same day). Otherwise the station can claim that it could have been vandalism - i.e. someone poured water into my tank when I went in and got some groceries from the convenience store.
  • Greetings,

    Does anyone know where to buy OEM brakes pads for
    2000 ML320? What's the brand Mercedes use as their OEM pads for ML320? Galfer USA or Textar? (Jurid or Pagid?)Please post the websites ASAP. Thanks!

    Paul
  • Best place for any Mercedes parts is www.mercedesshop.com. Great Service .... Great Prices
  • MY 1999 ML430 is in the shop having a new transmission installed!! The cost is over $5K. The vehicle has only 116K miles on it (and you can't service the tranny by the way). The regional rep for MBUSA won't offer goodwill stating excessive mileage!! EXCESSIVE MILES FOR A MERCEDES?? ARE YOU KIDDING?? WE ARE BEING TRICKED!! THIS IS NOT YOUR DADDY'S MB!! POOR QUALITY AT A HIGH PRICE!! THERE HAVE BEEN OTHER PROBLEMS I'VE HAD TO FIX AS WELL. I PLAN TO TAKE THIS MESSAGE TO THE PEOPLE BY USING MY ML 430 AS A BILLBOARD EXPRESSING HOW I FEEL. IF OTHERS DO THE SAME MAYBE MB WILL GET THE MESSAGE. BUYER BEWARE. RONERON1
  • We just got a 2000 ML320 and I almost hit a car yesterday because when I press the brake pedal it travels 2 inches before it engages. Our other cars engage with maybe a 1/2" of travel and I can't seem to get use to our mercedes.

    I went to 2 Mercedes dealers and they said this is just the way the brakes are designed on an ML. They also said there is no way to adjust this travel distance.

    Is this true?
  • kiiwiikiiwii Posts: 283
    Yes, it's normal. It took me quite sometime to get used to.
  • My wife's 2002 ML-320 (delivered April 02 and now with 20,000 miles) continues to have two problems that will not go away and in-spite of multi week long stays in the MB shop cannot be fixed.
     
    The first is an intermittent accelerator hesitation problem...from a standing stop you will step on the gas on nothing happens. No revs, no movement of the vehicle...nothing. Then after two-three seconds off it goes like nothing was wrong. It has happened when the vehicle is hot or cold, and there does seem to be a common weather factor...it seems to always happen when it is 80 degrees or above. We do live in an area that is also very humid most of the time (South Texas). How often does it happen? One or twice per week...sometimes four of five times per day.
     
    Next is a transmission problem...once again intermittent. The transmission will not up shift or it will downshift at will. Happens once or twice per month maybe. First go around the dealer replaced the control module but it still happens.
     
    We are wits end...not only are these two problems a reoccurring pain but that are both a real safety issue.
     
    I have read of others with the hesitation problem...how about the transmission problem?

    Thanks!
     
    Jeff
     
    McAllen, Texas
  • Have there been any service or technical bulletins issued for tranmissions on a 2002 ML-320?
     
    Thanks!

     
    Jeff
     
    McAllen, Texas
  • Have there been any service or technical bulletins issued for accelerator hesitation on a 2002 ML-320?
     
    Thanks!

    Jeff
     
    McAllen, Texas
Sign In or Register to comment.