Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln LS Accessories & Modifications

12467

Comments

  • garsarnogarsarno Posts: 72
    I have used the stainless pillar post covers with 3M tape on my '99 Town Car. Looks good on the Town Car but would look overdone on an LS. I have used all sorts of polishes on the stock posts but they did not come back to the factory look. The tape is very thin and is applied to the new post covers, you would need to follow the instructions very carefully as I did not and had to buy 1 extra post.
  • lssoullssoul Posts: 6
    I am about to replace my speakers in my 2000 Ls. I read that I must remove the entire door panel. Is this true. I have a blow by blow on the door removal, but wanted to ask if were true. How hard is it to remove the rear speaker cover in the trunk, it takes up so much room.
  • lssoullssoul Posts: 6
    I install the speakers. It was very easy. You can pop the speaker covers off, but you can't get to the screws holding the speakers. Perfect 5x7 fit. Oh yea, door panels did come off. I used SDAT's :)
  • nodaklsnodakls Posts: 1
    I just purchased my a 2000 Lincoln LS - I am looking at any mod's that will boost performance. I have read alot about Intake mod's - have you done this yet? If you can throw me a few ideas i would be grateful. BTW, I haven't read alot on problems replacements with the car - my car has just under 70k miles on it and I was just kind of wondering what to expect in the future, as far as problems are concerned.
  • apg4359apg4359 Posts: 4
    I recently installed the KKM V8 intake and have been experiencing problems.

    The "Check Transmission" error keeps displaying. I took my car to a transmission specialist and he said to there were numerous errors codes returned by the diagnostic computer. There was nothing mechanically wrong with the transmission. He recommended I remove both Positive and Negative battery cables and touch them together to fully discharge the system and purge all error codes from the system.

    This worked for a couple of days and the error returned.

    Has anyone experienced this problem when installing the Kurtz Kustomz Motorsport V8 intake?
  • Need Help fellas.

    I got the following error code from a Checker Auto Parts diagnostic tool:

    P0795 Pressure Control Solenoid "C"

    This error code is related to the "Check Transmission" error displayed on the dash.

    Any help would be appreciated.
  • Hello, I am new to the forums and to the Lincoln LS,

    I have a 2001 Lincoln LS V8, I am wondering if anyone knows how to program the Keyless entry pad.

    Does anyone know if someone makes a supercharger and/or turbochrager for these cars, and where can you find various upgrades for the LS V8 too.
  • I am looking for ways to modify my car. I want to add power. I plan to add a new exhaust system but wasn't sure what kinds to look at. I also plan to add a new audio system and 20'' Asanti's wheels. Please reply w/ any suggestions. Thanks!
  • Hi did you ever find out what that drone noise was, I have heard it on my ls. I thought it might be a rear bearing, so I called a dealer and they said that you have to buy the hub with the bearing $400. Anyone have any suggestions.

    mongoose
  • bobbylbobbyl Posts: 1
    Hey Man, I love what you did to the front end!
    I have an 00 LS and looking to add a new look.
    Would you mind telling me where you got the black honey comb bits and cost?

    Thanks,
    BL
  • I have a 2002 Lincoln LS that had been serviced by Desert Lincoln-Mercury in Las Vegas for 40,000 miles which was provided by Lincoln. After the included servicing had expired I decided to service the LS myself, because I wasn't that pleased with Desert Lincoln-Mercury service. The first service I performed I found numerous things broken and also noticed the oil level wasn't to the full mark on the dipstick. I didn't think much of it and serviced the LS, and did so again 4,000 miles later. My wife smelled oil and we made an appointment with Desert Lincoln-Mercury, since it was still under warranty until 75,000 miles. Long story short, I get a phone call from the service department telling me the valve cover had a hole in it? I asked how something like that would happen. Desert Lincoln-Mercury tells me someone?? stuck something down the oil filler and started the engine causing the valve to strike it and crack the valve cover, but it didn't happen there???? I asked where it happened since they where the only ones who touched the car, and me performing two oil changes. Desert Lincoln-Mercury tells me there was no way they did it and therefore they were not going to cover the valve cover?? Has anyone else experienced anything like this and what action should one take. I have no confidence that anything/previous services had been conducted correctly on the LS and unfortunately think I should get rid of it. I like the LS but have a very bad taste with Lincoln/Ford and probably with get a Cadillac next. All input would be appreciated.
  • cob12cob12 Posts: 3
    Do a search on 'drone' in this forum
    /direct/view/.ef22f48/0?14@@
    (that looks long.. it is just the problems and solutions forum on this website. It could be the halfshafts, apprarently that is a common problem... I have a similiar problem, but haven't solved it just yet...
  • Hi guys,
    My car was vandelized tonight and I need a new driver door mirror. I was wondering if anyone knew where I can get one inexpensively. Sorry if this is in the wrong section. I did not see a parts section. Thanks
  • 2002lsv82002lsv8 Posts: 2
    I too have this option and keep it turned off.
    It sucks!
  • 2002lsv82002lsv8 Posts: 2
    I have owned an LSV8 2002 for 15 months and thought it was an awesome auto until today. The vehicle will be four-years-old on 11/16/2006 and only has 58,000 miles on it.

    Apparently the front end has been going nuts on me since I changed rubber in October of 2005. (Same Michelin Pilot series that came with the car. I did not purchase the rubber at the dealership due to the fact that they did not and could not offer Road Side Assistance.)

    After several attempts to figure out the problem with both tire shop and dealership, everyone is puzzled - that was until today.

    The dealership hooked up a computer to the car and found out that the Variable Assist Actuator is defective as well as a module that controls this actuator may also be defective.

    The end result - Me spending $886.24 + Tax to replace the defective item/s.

    I told the dealership that I declined the repair work and it still costed me $140.66 for them to diagnose!

    Personally, I do not feel that I should have to pay for an item that apparently was going bad when I changed the rubber and was still under the 50,000 mile mark.

    No... I did not take an extended warranty and now I wish I did, but none the less, I feel that this is a manufacture defect, especially when the vehicle is not even four-years of age and is only 8,000 miles outside the 50,000 mile warranty.

    Now, I could see if the vehicle was 5-years of age and had 70-80,000 miles and if the vehicle was owned by more than two people and was never serviced/maintained by a FORD/LM dealership, that I would have to pay for this.... but since I am only the second owner and the vehicle has always been serviced by a FORD/LM service centers, then I firmly believe that FORM should take care of this item for me.

    I tell this story because I would like to know if anyone has expierenced anything like this - and what they have done about it, or what anyone may suggest for me to do, other than what I had already thought of... Find the car a home.

    Thank you in advance for your time. :sick:
  • Ford has a comsumer affairs appeal process where you can go above the service managers head. You should also call your local district office.
    But since you didn't buy the car new, they will be less inclined to help.
  • i redid my exhaust with 3 in. pipe and 2 chamber flow masters with 3 inch tips and it is awsome
  • robbo5robbo5 Posts: 1
    I've looked everywhere for dark headlight & taillight covers for my 2002 Lincoln LS, V8,but absolutly no luck.I find it hard to believe they cant be purchased.Does anybody have any ideas?
  • Hi folks. I purchased a brand new rain sensor (part number XW4Z-17D547-AA) back in 2000. I had planned to use it in a project I was thinking about doing but never got around to it. The part is brand new and has never been used. It also has all the schematics surrounding the LS wiper system. If anyone wants this part they are welcome to it. The part is free...just cover shipping and it is yours. if you are interested, check my profile for an email address where you can contact me. I'll hang on to it for a few more days and then I'm throwing it away if there are no takers.
  • Hello folks,
    I am attempting to put LED stop/turn signal bulbs in my LS. I purchased some great LEDS from a company in AZ. They are as bright or brighter than the incandescent bulbs. My problem is this. My car is sending pulsed current to the LED's, which cause them to flicker rapidly (about 15-20 times per second). There is definitely a rapid increase /decrease in voltage. This happens when the motor is ON or OFF, so that rules out the alternator or charging system. The necessary resistors are in place however it happens with or without them.
    I have tested the bulbs in a 2002 Escape and they function flawlessly.
    I know there is a Lincoln Engineer that would laugh at this problem and tell me how (if possible) to fix. But I can't find that person. CAN ANYONE SHED SOME LIGHT (NO PUN INTENDED)ON MY PROBLEM? Thanks JRIEGER
Sign In or Register to comment.