Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2012 Chevrolet Equinox

24567

Comments

  • Notice when cars are passing me on the left lane, that the traffic noise is very loud. It alsmost seems like the drivers door is not fully closed. Is there some sort of adjustment they can make to the door closure ??
    Tom in Texas
  • tomsfiretrucktomsfiretruck Posts: 6
    edited August 2012
    Noticed that the front and back seat power outlets do not function when the engine is turned off, but yet the one in the cargo area works just fine.
    Any thoughts.................Tom in Texas

    Nagging little things, for an otherwise good running/milage vehicle.
  • Congratulations on your new Equinox, smokey27, although we're sorry that you are having some concerns with the way it's idling upon start up. If you decide to have your dealership take a look into it and would like for us to follow up on that appointment, please contact us at socialmedia@gm.com with more details including: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your involved dealership. This will allow us to set up a Service Request and contact your service department.

    Best,
    Sarah
    GM Customer Service
  • Good morning tomsfiretruck,

    Congratulations on your new Equinox! Aside from the road noise and power outlet concerns, we're glad that everything is going well. Are you planning on having your service department check into the power outlets and road noise concerns you are having? Keep us updated on what they say!

    Sarah, GM Customer Service
  • ronwelronwel Posts: 57
    I can tell you that this is not a problem as this was how the car was designed. The manual mentions this...and both my 2010 and 2012 functioned this way.
  • I just bought a new 2012 Equinox and noticed that my exterior light sensor, located on top of the dashboard, flashes red every 4- 5 seconds when the vehicle is parked and when it is dark.
    Is this normal?
  • Yes this is normal. It is part of your security when car is off & locked :)
  • We just purchased a 2012 Nox on this past Thursday evening. The Nox is the first Chevy we have ever owned. This car was purchased for my wife. My wife drove the car to work and noticed noise coming from the engine. We took Nox back to the dealer to complain about the noise and of course the dealer convinced us that it was the Nox’s engine character in other words “the norm”. We listened to one of the other Nox the rough engine noise was the same.

    My wife did have a hard time explaining the noise. However, low and behold, I sided with the dealer saying “Maybe it is the engine general performance”, because it was the same in one of the other Nox.

    It wasn’t until Saturday night when my wife return from the hospital visiting her friend she asked me to hurry out to the garage and listen to the Nox. It was than I noticed what she was talking about. There was a vibration noise that could be heard inside the car. Vibration noise is the best way that I can describe the noise. The noise was the same sound heard when something is out of line. When the engine first starts the noise isn’t there. The noise start out low and increase as the engine becomes warmer if I can use this term.

    I’m at “Awh” for a few reasons, one when we took the car back, my wife decided she didn’t want the car, because it was purchased as a brand new vehicle. When something is purchased new the expectation is, you’re not buying a problem to be return to be repaired later. If we wanted this issue we would have gone to a used car dealer. Second, the dealer was more concern about keeping the car sold and not wanting us to return the vehicle vs., finding out if we were 100% satisfied with car we purchased. The noise is annoying especially when you’re use to a vehicle that has little to no outside engine noise.

    Have anyone else experienced or is experiencing this vibration noise issue? My concern is, it this noise is happening in a brand new vehicle, what is it going to sound after a few months of driving.
  • If you bought your Nox under the promotion of returning it if you did not like it and did not take the $500 discount in lieu of the ability to return it you have some leverage on your side. However, if you have the issue now, your bumper to bumper warranty will cover whatever needs to be done; the question is did you let the service dept go out with you on a test drive to duplicate noise? If not you need to do so in order to build your case with the dealer if the dealer is not responsive then switch to a dealer who is. These are great cars and I hope you get your questions answered quickly.

    Please let me know if I can be of further help. Good luck.
  • Good afternoon junejune1,

    Congratulations on your new Equinox! However, we're very sorry to hear that you're already experiencing some concerns with vibration noises.

    I see you've consulted your dealership on this noise already and would like to offer to follow up on this with your dealership. Please email us the following information at socialmedia@gm.com: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your involved dealership.

    All the best,
    Sarah
    GM Customer Service
  • I'd love to say I'm happy about my 2012 2LT AWD Equinox but after 3 months of ownership imagine my shock as I was driving down the highway at 65mph only to feel the vehicle reduce power and flash warnings at me. Abruptly and after cruise cut out I could hardly reach 45-50 mph on a busy highway during my morning commute to work. My vehicle flashed the warning to "Service Stabilitrak" and that I was now "Operating On Reduced Power" with the check engine light lit. Needless to say, I drove straight to the dealership!

    After reading these forums it appears to be a reoccuring issue with many GM vehicles and I can't believe it's ongoing! Covered under warranty or not, I'm saddened to be put through a situation where I have to worry over something of this nature when driving a brand new vehicle. I'm hoping the dealership will be able to correct the cause but again I'm concerned I'll be visiting the service department repeatedly for something which appears to be a defect arising in many models of GM vehicles.

    If you are reading this and have had similar issues - have any of you found a permanent solution? I've read replacement of the throttle body helps, avoiding car washes which could douse various sensors in the underbody and even gas pedal replacement to changing fuses and replacing an onboard computer. In any case, this is not a very positive first impression of owning my first brand new Chevrolet vehicle (I almost went with a Toyota!). :sick:
  • Service Dept just called. They said they couldn't even pull up codes for the issue that I'm experiencing and he test drove it and it didn't happen to him. It never happens to them! I guess I won't put much faith in my engine when it comes to passing on the highway and considering highway is all I drive I'm a little hesitant! And now winter will be on the way...AWD and Stabilitrak is supposed to make me feel more secure! :confuse:
  • ray80ray80 Posts: 1,240
    I believe the reduced power message is to allow you to limp it back to dealer without doing any potential damage (thats a good thing). Since the dealer is going to have trouble fixing something that they can't recreate or find a code for, I would look back a post or two and open a case with GM customer service (send Sarah an email with the info she always requests). They may be able to work with dealer (and perhaps others) to find a solution.
  • We're sorry that you're having these troubles with your new Equinox, waterviolet! It looks like you're already working with your dealership on this, but if you wanted for us to check into this further we're available to do so. Please email us at socialmedia@gm.com with more details (including your name and Edmunds username, phone and address, the last 8 digits of your VIN and current mileage, and the name of your involved dealership).

    Sarah, GM Customer Service
  • Thanks ray80. I didn't mean to be a Debbie Downer but it's an awfully hard pill to swallow when you purchase a new vehicle and with it having less than 4000 miles on it I'm having issues which could potentially spell disaster in the coming winter months. I will definately contact Customer Service as from what I've read of other occurances, this event is bound to happen again. :D
  • jpfjpf Posts: 496
    You may want to check out the Impala forums. This seems to be an issue with that model. There is an entire discussion dedicated to the issue under the Impala forums. Unfortunately, stability control is one of those mandatory government safety features now required on new vehicles. I purposely bought an 07 Uplander last year without the Stabilitrak to avoid this issue. Another silly government requirement that adds cost to new vehicles and additional headaches to car owners when it fails. Tires with decent tread life and driving the speed limit avoids the necessity of most stability control systems. My 2 cents worth. Good luck.
  • I have had my 2012 equinox 1lt since November 2011 and have 11800 miles on it. I was driving my car on the highway at about 65 miles an hour and almost instantly lost all power, warning lights galore were going off including the stabilitrack. This was Thursday. The dealership couldn't take my car until Tuesday. After 9 days without my car, they finally got it back to me saying they replaced parts within the high pressure fuel aystem. 5 days later it did it again. They weren't able to reproduce anything after having my car for another 5 days. They gave my car back to me. I had it for another five days and more warning lights. I am frustrated. I am scared to drive my car. I didn't invest in something to be terrified of it. I am at a loss!
  • Good morning jessicas6977,

    We're sorry that you are frustrated and frightened with your Equinox, and that it's been difficult to nail down the cause of this problem with the dealership. If we can check into this situation further with you, please contact us via email at socialmedia@gm.com (include your name and Edmunds username, phone and address, the last 8 of your VIN and approximate mileage, and the name of your dealership).

    Sarah, GM Customer Service
  • This morning it happened again. This time, I drove straight to the dealer WITHOUT shutting the car off thinking it needed to be reset. This time, I went from 68mph to 60mph in a drop of the hat on the highway. I was able to keep up that speed until waiting at a stop light on an exit ramp which from that point onward I could only accelerate to 20mph. I still had all the same lights and warnings as before, Operating on Reduced Power, Service Stabilitrak and Service Engine light. This came 2 days after receiving a call about my previous service for the same issue and being advised by the awesome Customer Service Rep she was going to research it some more. She understood my reservations on passing vehicles while driving my normal highway commute - so TWO big thumbs up to Customer Service! Fortunately, there was a cancellation and the Service Department was able to take a peek at my array of lights and warnings. I'm not sure what codes they came up with but they just called to tell me they will be replacing the High Pressure Fuel Pump. I have high hopes this will help but it's still concerning on a vehicle which now has about 4500 miles on it. Crossing my fingers and hoping for the best! :confuse:
  • You are not alone! I too am a bit frustrated but overall my reservations with this vehicle is the feeling I have driving it. I lack the sense of security I once had before these issues started to arise. It's very concerning especially when my daily commute involves highway driving with no passing lane and now winter will be upon us in a flash! The reason I purchased the vehicle was to have the security and power I need! These forums have been a priceless fountain of information on this issue when it comes to the exact problems we are experiencing. For now, I will go along with the High Pressure Fuel Pump replacement the Service Dept tells me I need but I will not trust 100% this will not happen again. Various other reasons have been sighted for this issue, including the accelerator pedal, on-board computer, etc. In fact, this very thing happened to my co-working on her 2005 equinox (they replaced the computer). In any case, log everything, take pictures if you have to and talk to your Customer Service Rep. Don't back down...this is how things get corrected and we need to provide them with all the feedback we can! :D
  • Hopefully the high pressure fuel pump replacement will do the trick, waterviolet. We're definitely available to you after the repair is completed as well to follow up on this.
    Have a great weekend, and we'll try to keep an eye out for any updates.
    Sarah, GM Customer Service
  • My car is back in the shop. This is time #4. I am getting the runaround from MJ Sullivan (Dealership) and Chevy and my District Specialist (Maria).

    Out of 45 days, my car has been in the shop for 18 of them. That is 40%!

    This time the incident happened when I was on the high way with my 8 year old god son in the back seat. My car is unsafe. And I am not getting help.
  • jessicas6977,

    If you would like to forward us either the last 8 digits of your VIN or the case number (or just contact Christina again as she should be able to locate the case if she set it up for you), we will check into the progress of the Service Request.

    Sarah, GM Customer Service
    socialmedia@gm.com
  • I sent the info on Friday
  • Hey everyone,
    I got a 2012 Chevy Equinox about 6 months about and it was perfect. Now I am experiencing a rough idle. I'm sitting in the car at a traffic light and feel the car vibrating. I put my head on my window and my head is vibrating. I've taken it back to the dealer 3 times and they can't seem to find what is wrong with it. I am just frustrated right now. They have the car right now for the 4 time to see what they can do. Anyone else have this problem?
  • gmcustsvcgmcustsvc Posts: 4,068
    Good morning bryan5589,

    We're sorry that your dealership has been unable to pinpoint the rough idle concern you're having. If you would like for us to follow up on this with them for you, please contact us at socialmedia@gm.com (include your name and contact information, a summary of the situation, the last 8 digits of your VIN and mileage, and the name of your dealership).

    All the best,
    Sarah
    Chevrolet Customer Service
  • I know your pain! as of today NOV 8,2012 my 2012 NOX is in for 4 issues that I have been experiencing, one being the noise coming from the engine compartment. It sounds like a pump. And like your NOX it's after the engine is hot and can beheard at idle when waiting at a stoplite or train. My dealer says that it probably is the fuel pump under the hood. The second pump in tank. Sorry I bought this vehicle. Too many issues for a new car! :mad:
  • gmcustsvcgmcustsvc Posts: 4,068
    mrdubious1,

    We're sorry to hear that these issues are taking away from your experience with your new Equinox. If you wanted for us to follow up on this visit with your dealership, please email us more information at socialmedia@gm.com (include your name and contact information, a summary of the situation, the last 8 digits of your VIN and mileage, and the name of your dealership).

    Sarah, GM Customer Service
  • Check your timing chain I had similar issues. Head gasket also blew due to chain
  • equinox_atxequinox_atx Posts: 1
    edited November 2012
    I recently purchased a *brand new* 2012 Equinox LT at the end of July. Since I purchased the car, the vehicle has died (completely lost all power, including interior lights) approx. 10 times. It has happened in all of the following situations: In Drive, Reverse, Idling, Park, Full Motion (50mph), day/night, flat/incline, EcoDrive and out of EcoDrive, remote started and w/out remote start.

    The problem is so intermittent that it has happened twice in one day and also gone a month in between happening. At first, I thought maybe it was just a "tuning" issue (not knowing that this is not how these computer operated cars work this day) because most of the time it happened I had just started rolling or driving. However, when it died at night while I was going nearly 50mph, it created a dangerous, unsafe situation and I had it towed to the dealer immediately.

    The dealership I purchased it from has now had it 2.5 weeks. They tried to return it to me after one week but I insisted that they keep testing it and that the car is unsafe to drive until the issue is found and remedied. The computer does not recognize any issues. (One would think that your car dying while in drive going 50mph would be logged somewhere!) They have put nearly 700 miles on it trying to duplicate the issues and have not yet been able to. They said they "may have fixed the car without even knowing it". They also said they have not been able to research and find any similar issues with any other Equinoxes.

    Any suggestions would be greatly appreciated. Thanks!
Sign In or Register to comment.