Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2012 Chevrolet Equinox

15681011

Comments

  • lch033lch033 Posts: 1
    I have had my 2012 Equinox in the shop at the Dealership twice now. When I go to give it gas it will hesitate and then the transmission kicks in real hard.....it even does it when I try to accelerate in traffic to change lanes. The first time they said the lines and filter were clogged and they cleaned it out and replaced some things.

    I got it back and a week later it started it again......it's at the Dealership now and they say they "can't get it to duplicate" so I can come pick it up.....I don't know what's going on with it however it's NOT RIGHT.

    I almost want to tell them to keep it and I'l get something else.....I've been loyal to Chevy for years and I just want someone to fix this!

    Anyone else having these issues??

    Lara in Terrell, Texas
  • gmcustsvcgmcustsvc Posts: 4,003
    Hi Lara,

    I know it can be frustrating experiencing vehicle problems and not being able to duplicate the situation at the dealership. Please continue working with your dealer to resolve this issue. If you have any other questions or concerns we are here to be of assistance.

    Amber N.
    GM Customer Care
  • ronwelronwel Posts: 57
    Hi Lara,

    I have the same issue with my 2012 Nox. It feels as though the transmission is slipping, then all of a sudden it grabs and jolts you forward. It feels like when you drop the clutch with a manual transmission. There have been several times where it felt like soemone hit me from behind. y 2010 Nox did this as well, and this seems to be an issue with this vehicle. this message board, as well as another popular Equinox message board is full of people with this issue.

    Dealerships are telling customers everything from, "this is normal for this type of transmission", "the cars computer is still trying to learn how you drive, and this will clear up over time", "can not fix as we can not duplicate the problem". I was told not to run the Nox in ECO mode, to see if it helped...which it did not.

    Not sure what else to do...
  • bigkritterbigkritter Posts: 30
    Hey Lara,

    I have had alot of problems too. Have you been told about a data link that they put on your car?
  • ccoreyccorey Posts: 2
    Add another one to the list of burning oil problems. I took it 2 months ago with a slugging response issue, engine light came on. The service invoice came back with very low oil, then apparently there was a recall (12312) done to the Equinox at that time. They adjusted the the computer settings for the oil life gauge. Guess what, two months later (today) it is back in another service center. I did check the oil before it was towed and there was not a drop on the dip stick. I noticed it was sluggish a few days before when turning but did not correlate it as i thought the problem was resolved.
  • twerkingtwerking Posts: 2
    edited May 2013
    Not sure if this issue has been resolved yet but the problem is your water pump chain. Its an internal chain driven water pump. When replacing you need to make sure all the links / chain are removed. The only way to do this is drop the oil pan. The water pump chain and timing chain on the NOX are junk. The water pump chain will correct your heat issue as it did mine but now I need to do the timing chain and tensioner. Hope all the valves are ok! You may want to look into doing this as well before your chain goes and/or jumps timing and messes up your motor. I will be getting rid of my girlfriends NOX as soon as I get it running properly again.
  • recall7recall7 Posts: 1
    I purchased a 2013 Chevy Equinox LTZ, V6,AWD with Nav. Last 8 of VIN D6175156. For some reason I do not have the overlay (guide Lines) on my 7 inch screen from the rear camera. GM customer service informs me that this feature is not available. Whoever at GM who made the decision to delete this feature should be looking for a job. On my last call to GM customer service I was told that I could solve the problem by buying another vehicle. Thank you GM.
  • bigkritterbigkritter Posts: 30
    where are you finding service bulletins
  • gmretiregmretire Posts: 2
    I also have a 2012 Equinox 6 cyl. that misses- vibs @ 1500 rpm have contacted Dealership and Chev. cust service, they have checked it out at least 4 times and say it is normal !, I asked them why it didn't do it till 6-8k miles on it, they don't know !, I have had Passengers in the car and ask what's wrong with it ? they did not know I was having issues with it ! G.M. has pretty much wrote me off, I have 2 more Years Lease with this Equinox and am Mad as you know what., I am a G.M. Retire and will probably never Buy a G.M. again ! Pretty sad they Take your Money and run, and say it is Normal, it's Crap !, they say they don't have any others like it.,which I know better by searching Interenet! You can feel miss in Neutral,Park or going down the road any gear when it reaches 1500 RPM, which is about 55mph with cruise ! Help !!
  • gmcustsvcgmcustsvc Posts: 4,003
    Hello gmretire,

    I'm sorry to see that you're experiencing these issues with your vehicle. I want to assist you in finding a resolution for this concern? If you would send your full name, address, telephone, name of dealer servicing the vehicle, current mileage and VIN number to socialmedia@gm.com, I would be glad to research some options that may be available to you.

    Marlea Wilson
    GM Customer Care
  • gmretiregmretire Posts: 2
    Marlea Wilson I sent an email with the info you requested, Thank You
  • It sounds like you are beginning to have drive train issues that are common in the Chevrolet Equinox. If you read the 2010 Equinox forum group discussion on Edmunds.com you will find innumerable postings on engine issues all beginning with rough running engines that stall out. I have gone through two GM drive trains on my Chevrolet Equinox 2010 LT2 AWD 4-cylinder. (0-62,000 miles). Engine issues for me began at 47,000 miles (drive train replaced at 47,000 mi), and continued to 62,000 miles when I received a new engine. At the first drive train replacement, I was told I had used the "wrong" type of oil, but I used synthetic blended oil recommended in GM manual. I had the oil changed at the dealership for the second drive train. At 62,000 miles the engine began running rough again, and threatening to stall out when idling at stop signs, stop lights, etc. I received a new engine at 62,000 miles with the help of my dealership service center. Now other things are going wrong - windshield wiper transmission blew at 69,000 mi during torrential rain storm and actuator in air/heat unit needs replaced. Contact Chevrolet Customer Service for assistance. Some dealerships claim they have not had any issues with Equinox engines, where others have replaced several engines. Do not accept the vehicle back if dealership cannot find issue. It is too dangerous if the problem is not corrected.
  • gmcustsvcgmcustsvc Posts: 4,003
    Thank you gmretire.

    Marlea Wilson
    GM Customer Service
  • stmyersstmyers Posts: 7
    I have a 2012 LTZ equinox with 14k miles, I can not count the times I have had to take it in for problems. This past week, my check engine light came on. Dealer said it has to do with the air filter we put in (k&n) we replaced the filter back to the orig. one and the light came on again. Called a different dealer and they said they were too busy to get my car in for at least two days... Do I just drive the car around with the check engine light on? Then, Today, I went to use my remote start and the remote start is not working. For as much as they cost, you think GM would get it right the first or second time... I'm very disappointed with GM and more so with the dealership I purchased the car from.
  • betersenbetersen Posts: 2
    I bought a 2012 Equinox LTZ last year--wanted a brand new car with all the bells and whistles that would be reliable as I travel nearly every other weekend to see my grandchildren. It is a five hour drive from my home on the central oregon coast north to Portland, Or and then east over the mountain pass to Warm Springs, OR. Well on June 15th I was making this trip, was 20 miles out of Sandy, Or going up the pass when a tone sounded and I got the message to service my stabilatrak system, shortly after there was a symbol of a car with swerve marks and the one of a battery. About a minute later my radio went out, the whole screen went black and I pulled out of the passing lane and into the right hand lane--I'm driving 55 mph. Then all of my instrumentation went black. I got on my cell phone--thank god I had a signal--called my daughter and told her something was wrong with the car and that I was going to drive until I found a service station or some people as I was in a primarily wooded area going up the pass. However, within a mile or so the car lost all power. I turned right, thank goodness the shoulders were paved and I had the incredible luck to make a turn right in front of a small town two bay fire station with a big paved driveway. I have to tell you I was terrified by the whole thing. I waited 2 hours for a tow truck and had it taken to a Chevy dealer in Sandy, OR about 20 mies away. Luckily the car was under warranty and the dealer paid for a rental so I could continue with my weekend trip (it was Friday) and actually ended up taking the rental back home as my car was not fixed until the following Wednesday. The dealer met me at the car rental about 15 miles from home and we exchanged vehicles. The dealership said the whole thing was a fluke--that the alternator had went out and it then affected the battery and then the computer. All three of these things were replace. If has been driving fine except for one instance where it died at the end of a long driveway when I braked before turning onto the road. I turned the key off and turned it over and it started back up. And, I continued on my 1 hour drive but I was really feeling nervous. Towards the end of this month I will be making that drive to see my grandkids and I am a little nervous. I don't feel 100% about this car anymore and I loved this car. I read all the posts by others about their equinoxes losing power and mentioned it to the dealer who said they had never heard of this. I am very skeptical about their response. I can say they did make everything on the car right, but they cannot fix my unease about driving this car. Not sure if I'm going to keep it. Will give it month and see if I can regain my confidence in this car.
  • gmcustsvcgmcustsvc Posts: 4,003
    betersen,

    I am sorry to hear that you have become uneasy about your vehicle. If you happen to have any concerns in the future, know we are here to be of assistance.

    Sincerely

    Amber N.
    GM Customer Care
  • rondhrondh Posts: 1
    I just bought a new 2013 Equinox LTZ 6cyl AWD, and have discovered a service bulletin for sticking torque converter clutch that was issued in April, I bought in May and nobody said anything about any open issues. Along with that it came with a damaged chrome wheel ($700+) that I found when I detailed the car. I would not have bought the thing had I known about the TC and only found out through a different dealer. Chevy and the dealer have dismissed both complaints and I haven't even made the first payment. I have always bought new GM cars. No More.
  • gmcustsvcgmcustsvc Posts: 4,003
    Hi rondh,

    If there is anything we can do to assist you with this situation please do not hesitate to ask. We want to make sure that you as a customer, have all of your concerns addressed.

    Sincerely

    Amber N.
    GM Customer Care
  • betersenbetersen Posts: 2
    On July 25th I'll be making another trip over the mountain to see my grandchildren. I really hope it is routine. Will post how it goes.
  • bigkritterbigkritter Posts: 30
    Ok GMC Customer Service and Service Centers why do you all continue to give us the run around. Giving us one lie after another. With dumb reasons why our vehicles are doing these things. I am not stupid or are most of the others complaining. I want to know what is going to be done about these cars. They are not safe. I can not go without a car, yet when I bring it in, you already nothing is going to be done. If I state that I want it to stay till something is done, I will not receive a loaner car due to I was able to drive it in to the shop. I am disabled and need a good car. I don't think GMC wants it to be known that not only are the customers dissatisfied but that they are allowing them to drive a unsafe vehicle around (knowing that it is not safe) Also the news might get it out that they are taken advantage of the disabled.
Sign In or Register to comment.