Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





97 legacy outback fuel system issue.

i have a 97 subaru legacy outback that just recently stalled out while driving. it seemed to not be getting fuel tho i had half a tank of gas. so after letting it sit for about 20 mins i gained access to the sending unit threw the trunk and tapped on the cover and the car would start but only run for a short time. so i replaced just the fuel pump and the fuel filter. the car ran for about a day then i got the same issue, car would die and after an hour or more i could tap on the cover of the sending unit and it would start. so i returned the pump and replaced it again... yet again its the same issue. im at a loss. the car when it runs it runs great. but it will only run for about an hour if im lucky.. any ideas? the car does have 300k miles on it but i dont wanna give up on it yet. it just took a inspection sticker and the garage told me they were blown away with the shape of the car for the miles. bums me out to see it sitting there for what could be a small issue.

Comments

  • This is just a thought, but it may be worth a try. Next time it stalls out on you, remove the gas cap and put it back on. If you hear a loud hissing when you open the cap, then you have a fuel venting problem. As the engine burns fuel from the tank, that fuel has to be replaced by air. With current emissions regulations, you just can't vent the tank to the atmosphere. There is a one-way valve which will allow air into the tank, but not allow fumes to escape into the atmosphere. If that vent malfunctions and does not let air into the tank, the fuel pump can't keep supplying fuel against the vacuum being created in the tank. Even if you don't hear anything when you remove the cap, try to start the engine again. If it starts and runs for another short time before stalling, then you have an issue with your tank venting system. Good luck.
  • ill give that a try. i never thought of that. makes sense tho since when the car does die off if i let it set for a few hours it will start up and run alright for a short time.
  • no luck =( ran fine for a day then did the same thing.. took another day for it to run alright enough to get it home. i think im going to try just replacing the whole unit. found the sending unit and pump at a pick a part for 50 bucks. is there anything else that could cause the pump to just randomly die off and be a pain in the..... and needing a day or so to smarten up so it will run good for a day or 2?
Sign In or Register to comment.