Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





A Mechanic's Life - Tales From Under the Hood

1157158159161163

Comments

  • roadburnerroadburner Posts: 6,574

    ATF fluid level? Loose oil pickup in the pan?

    2009 328i / 2004 X3 2.5/ 1995 318ti Club Sport/ 1975 2002A/ 2007 Mazdaspeed 3/ 1999 Wrangler/ 1996 Speed Triple Challenge Cup Replica

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043

    Oh, so you mean the jiggling of the car in an uneven field would slosh the fluid around enough to allow the transmission to engage, while on a smooth road it would not---that's an interesting theory, but I dunno...it's out there......

    MODERATOR --Need help with anything? Click on my name!

  • qbrozenqbrozen Posts: 17,432

    ok. So I have another mystery. Well, maybe not a mystery, but ... I dunno.

    The CEL came on the van on Sunday. I didn't have time to check it and figured it was probably just the gascap again anyway. Wife was then driving it Monday night. She was about a quarter mile from the daycare when, per her description, the traction light came on, steering got real stiff, brake pedal become hard and nonresponsive, and the car started to slow. She managed to get it to the side of the road before it completely stopped itself.

    She called me from the side of the road, car was still idling. I asked her to cycle the ignition off and on again. The TCS light went away and everything seemed to be functioning normally again. I told her to drive carefully to the daycare and she could call AAA from there. Well, she wound up driving it back home, too.

    I searched the ole interweb and found 2 similar reports (I think 1 was here on Edmunds) that supopsedly both led to a bad EGR valve. And, sure enough, when I got home that night and checked the CEL, it pointed to EGR valve.

    My problem is, how/why in the world does a bad EGR valve lead to TCS light and dead brakes and power steering?! I have ordered the part and gaskets and should have them tomorrow. I just worry that's not really the solution.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '14 Town&Country

  • xwesxxwesx Fairbanks, AlaskaPosts: 8,508

    @qbrozen - Well, I don't know on that vehicle how the EGR system would be linked to the power steering, but power brakes are controlled on vacuum, and if the EGR valve is not functioning properly, that could very well affect other vacuum-controlled systems.

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043

    If the car actually stalled while she was driving, that could replicate most of those symptoms.

    MODERATOR --Need help with anything? Click on my name!

  • xwesxxwesx Fairbanks, AlaskaPosts: 8,508

    @MrShift@Edmunds said: If the car actually stalled while she was driving, that could replicate most of those symptoms.

    That's what I thought initially, too, but Q said that the car was still idling when she came to rest on the side of the road...?

  • qbrozenqbrozen Posts: 17,432

    Right. No stalling. The TCS must have slowed the car. The steering concerns me...but maybe that's something to do with the TCS as well?? But why should the EGR affect the TCS?

    Vacuum was also my thought. Its about the only thing that KIND OF makes sense. But without being able to completely resolve it in my mind bothers me. It is an incomplete theory at best. Really not even a theory, just a WAG.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '14 Town&Country

  • explorerx4explorerx4 Central CTPosts: 9,730

    @qbrozen said: Right. No stalling. The TCS must have slowed the car. The steering concerns me...but maybe that's something to do with the TCS as well?? But why should the EGR affect the TCS?

    Vacuum was also my thought. Its about the only thing that KIND OF makes sense. But without being able to completely resolve it in my mind bothers me. It is an incomplete theory at best. Really not even a theory, just a WAG.

    I'm hesitant to say this, but 'cardoc' might be able to help.

  • roadburnerroadburner Posts: 6,574

    @explorex4

    He'd probably want to "have some fun" with the problem- and then blame gbrozen because he didn't take the car to a "professional technician"... :D :D :D

    2009 328i / 2004 X3 2.5/ 1995 318ti Club Sport/ 1975 2002A/ 2007 Mazdaspeed 3/ 1999 Wrangler/ 1996 Speed Triple Challenge Cup Replica

  • qbrozenqbrozen Posts: 17,432

    so far, so good. Van seems to be running smoother, shifting smoother, and the brake pedal is firmer. I just hate not understanding why a lousy EGR should cause so much havoc.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '14 Town&Country

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043
    edited December 2013

    Well if the bad EGR was sucking off a lot of vacuum, that could explain most of it---but you know, you weren't a witness to the event so maybe in the confusion of the moment some things were perhaps not simultaneous but sequential.

    MODERATOR --Need help with anything? Click on my name!

  • qbrozenqbrozen Posts: 17,432
    edited December 2013

    yes, that's usually a problem. the first thing she said was "a yellow light with squiggly lines came on."

    palm-->forehead.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '14 Town&Country

  • steverstever Viva Las CrucesPosts: 40,845
    edited January 16

    Had Subaru problems this week. My '97 has a dealer installed OEM alarm that has always caused grief. I pulled the actual siren in '04 or so and turned it "off" with the dip switches a year or two after that. The key fob is tied in with it so I never wanted to completely pull it out.

    Last week the passenger side rear door wouldn't open unless I unlocked all the doors a second time with the fob. After unlocking all the doors with the fob; seems like I had to open the driver's door and then fob the rear one open or use the switch on the dash. All the other doors and the hatch worked normally.

    We drove it Monday and parked it. Tried to drive it Tuesday and nothing. The lights worked but there was no click. Hooked up the trickle charger and let it charge most of the day and overnight.

    Wednesday it still wouldn't start. Tried to jump start it and nothing. The alarm seemed to be acting up though and when I'd put the key in the ignition, the dash lights would momentarily flash. So I'm thinking either the alarm is flaky or there's some other "ground" issue going on or the battery has a bad cell. Maybe the starter.

    Checked my notes and my last battery was installed in 2005. Okay, should get a new one anyway after 9 years. The counter guy "load tested" the old battery and nothing registered. Funny thing was that my mechanic was at the counter too picking up a part and asked me if the Quest had died. He was in a bit of a hurry and I didn't get the chance to quiz him on the no start. Or maybe he ran to avoid the free advice, LOL.

    So $90 later, I swapped out the old $40 Walmart Exide for a Carquest (JCI?) one. Nothing changed. Tapped on the starter a little but not aggressively. Time for some sleep engineering.

    This morning I had the epiphany - try cranking it in neutral. D'oh, cranked right up. Turn off, put in Park, cranks right up.

    I probably could have gotten another year out of that $40, 9 year old battery. :D

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043

    So you have a wonky neutral safety switch? You'd best get under there and see if it's loose, or the linkage is falling apart or some such. Your battery was overdue anyway. Chalk that one up in the "proactive" column.

    MODERATOR --Need help with anything? Click on my name!

  • steverstever Viva Las CrucesPosts: 40,845

    Could be. The several weeks of cold (zeroish) weather is just hard on stuff.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • isellhondasisellhondas Issaquah WashingtonPosts: 17,744

    After NINE years, did you really want to try coaxing that battery another year?

    I think Shifty has this nailed!

  • xwesxxwesx Fairbanks, AlaskaPosts: 8,508

    @Stever@Edmunds said: Could be. The several weeks of cold (zeroish) weather is just hard on stuff.

    What?! Bah. You're going soft, Steve!

  • steverstever Viva Las CrucesPosts: 40,845
    edited January 16

    @isellhondas, I was surprised when I looked at my logs to see that the battery was that old. Hunted down my receipts to see if I forgot to write one replacement down, but apparently it was getting up there.

    And yeah, if I had managed to get it started before replacing the battery, I'd try for a few more months. :)

    My previous best as I recall was 8 years. This guy has me beat. On an OEM battery to boot.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043

    I'm sure there's a Guinness Book of Records entry for this, if you feel so inclined to go for it, Steve.

    MODERATOR --Need help with anything? Click on my name!

  • isellhondasisellhondas Issaquah WashingtonPosts: 17,744

    The battery in our 2003 CRV is five years old. If it even gives the SLIGHTEST hint of impending doom I'll replace it. I like replacing car batteries on MY terms rather than getting stranded somewhere on a dark rainy night!

  • explorerx4explorerx4 Central CTPosts: 9,730

    @Stever@Edmunds said:

    My previous best as I recall was 8 years. This guy has me beat. On an OEM battery to boot.

    I'll have to check my records. I think I'm on my 2nd 100 month Motorcraft battery. The last one made it pretty close. The car sits from at least October to May and I try to start it at least once during that time period.

  • steverstever Viva Las CrucesPosts: 40,845

    Now that we're in Michigan, the rust will win before the new battery dies I'm afraid. Drove it an hour out of town and back tonight, and it did fine. All the electrical gremlins are gone and that rear door opens just fine.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • steverstever Viva Las CrucesPosts: 40,845

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043

    Yes but will mechanics consent to look like dorks? :) I could see this working in a limited way, but replacing technicians---I don't think so. Right now it looks like an R&R tool.

    MODERATOR --Need help with anything? Click on my name!

  • steverstever Viva Las CrucesPosts: 40,845

    Seems like half the stuff "fixed" now (i.e., replaced) could only be repaired with a soldering gun and high powered glasses.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • roadburnerroadburner Posts: 6,574

    I found a great local guy who can work on the Mazda. Factory trained and he charges either the shop rate or actual time spent- whichever is shorter. He also prefers that I obtain the parts(!) I had him R&R the front sway bar bushings and it was a quick and painless procedure.

    2009 328i / 2004 X3 2.5/ 1995 318ti Club Sport/ 1975 2002A/ 2007 Mazdaspeed 3/ 1999 Wrangler/ 1996 Speed Triple Challenge Cup Replica

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043

    This fellow working out of home?

    MODERATOR --Need help with anything? Click on my name!

  • roadburnerroadburner Posts: 6,574

    Yes, but he has a lift and is possibly more obsessive-compulsive than me...

    2009 328i / 2004 X3 2.5/ 1995 318ti Club Sport/ 1975 2002A/ 2007 Mazdaspeed 3/ 1999 Wrangler/ 1996 Speed Triple Challenge Cup Replica

  • qbrozenqbrozen Posts: 17,432

    oh boy. I feel bad for people like that only because they are so naive. I hope he at least knows the folks he does work for very very well and has at least some glimmer of trust that they won't sue him into oblivion the moment something fails that causes inconvenience or an incident.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '14 Town&Country

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,043

    It's risky not having the protection of a corporation or errors and omissions insurance.

    MODERATOR --Need help with anything? Click on my name!

Sign In or Register to comment.