Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





94 3.0 jerking and really rough idle 203,000 miles

hakesakhakesak Posts: 1
The problem started happening on the way to work one morning. It just started jerking really bad as I was going down the interstate and I couldn't even make it up a hill. Since it happened I have replaced plug wires (because they weren't motorcraft) and the fuel pump. A couple weeks before it happened, I did a tune up: distributor cap, rotor button, plugs, wires, fuel filter, air filter, and oil change.

I took it to a garage and they guessed it was a fuel pump or the timing was off, but said they were leaning towards the pump. I changed the fuel pump and absolutely nothing changed (the old pump and strainer looked clean actually). In fact it is running even worse than before I took it to NTB. They did a coolant flush, installed a new thermostat, and did a pressure test to see if maybe I had a blown head gasket. They said at 20psi everything showed to be ok except I have a crack in the bottom seam of my radiator. That's my next project.

I refuse to take it back to NTB because they did a bad job and seems like all they did was guess and flood the engine. Does anyone have any idea as to what direction I should go from here? I checked the voltage on the MAF and it seemed to be fine and I cleaned the IAC and that didn't seem to make a change either. I'm clueless and any help would be beneficial. Thanks!

Comments

  • My 89 ford ranger is having the same problems it will loose speed up hills and gain going down? And it is very slow on take offs and it will not go over 3000 Rpms I replaced the fuel filter and it ran great for about an hour and now I can hardly make if to work it's so bad but what was the problem?
  • My 89 ford ranger is having the same problems it will loose speed up hills and gain going down? And it is very slow on take offs and it will not go over 3000 Rpms I replaced the fuel filter and it ran great for about an hour and now I can hardly make if to work it's so bad but I ran out of ideas to fix my problem it will go 5mph up a hill in first gear I need help plz if you know the problem let me know plz
Sign In or Register to comment.