Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2010 Town and Country-spark plugs

We bought a 2010 Town and Country new in 2010 and have had nothing but trouble.

The transmission went out at 84,000 miles without any warning or any error code/light coming on at all.

The dealership replaced the ignition key because of a recall when ours was completely fine. The new one that they installed literally tore my keys a part.

Then, last week the van just stopped AGAIN without any warning light, signal, etc. The dealership called and said that before they could move forward they need to do a tune up and replace the spark plugs because they are completely worn down and not working at all. Hmmmmmm, isn't some kind of warning light or something supposed to tell you this stuff?!!!! They are saying that it's not covered under warranty and it's a minimal of $350.00

I am so frustrated with this van!!!!

Comments

  • tsu670tsu670 Posts: 293
    Ahercules, you don't say how many miles are currently on your vehicle, but plugs should be replaced at 102k miles. Also need to flush and replace the engine coolant at that mileage. If you have the 4.0L engine, you should also replace the timing belt.

    Regarding warning lights to replace the spark plugs, I imagine if they get bad enough they might affect the emissions system and kick out a check-engine light.

    You don't say how exactly your vehicle "just stopped," but I seriously doubt the spark plugs would be the singular problem.
  • aherculesahercules Posts: 2
    The van has 97,700 miles on it. I never received any kind of a warning light or anything. It just suddenly stalling and stopped without any warning or lights. I tried to start it again and it acted as if it were trying to start, but wouldn't turn over.
    I had to have it towed to the dealership as it is still under warranty. They called today saying that to get it even to try to start they needed to replace the spark plugs as they were completely worn out. Once they replaced the plugs and tried to start it a major engine miss happened. The service guy (who was very professional, kind, and helpful) said that so far they have discovered that there is 0 compression with one of the cylinders so only 5 are working. He said that this is what they know as of now, but it looks like there are other major engine problems.

    This is very frustrating because we bought this van new with less than 30 miles on it. It's the Touring edition and we've had so many problems. It's scary to me that I could have had my three small children with me when this happened. Luckily, I didn't, but I was 2 hours away from home. I did have my children with me the last time that the van just stopped while driving without any warning.

    I am now paying for a rental until it is fixed. The warranty only covers 5 days for a rental and the service department couldn't look at it until Friday and then the holiday was this weekend so the 5 days were up yesterday. I am thankful that this is still under warranty so everything should be covered minus the spark plugs, but it's frightening to think that the warranty runs out at 100,000 miles. If I am experiencing this many problems what am I in for when the van reaches 100,000 miles?
    The room is great, but the quality of the van is very poor. This is all frustrating. I thought this van was going to be great for our family.
  • tsu670tsu670 Posts: 293
    Once you get a clear explanation of what was wrong and what was done to fix the problem, I wonder if you would do us all a favor and file a report with the National Highway Traffic Safety Administration's Office of Defects Investigation at NHTSA ODI. It would help if you would provide very specific details as to your vehicle model (include engine size such as 3.8 or 4.0), symptoms and what the dealer said was done to fix it.

    We also have a 2010 T&C. To date we have had one episode where the vehicle quit at a stop light, would not restart and had to be towed to dealer. It had only 2,000 miles on it. Turned out to be a bad wiring harness. Since then it has performed flawlessly. Currently have 32,000 miles.

    I filed a report with NHTSA at the time. There are others who have complained of stalling. If enough folks file reports, maybe the Feds can put pressure on Chrysler to issue a recall. Thanks.
Sign In or Register to comment.