Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Ranger Maintenance and Repair

1117118120122123147

Comments

  • I don't know about the interior light but the "door ajar" dummy light has a tendency to stick during cold weather...I had same issue and just used wd 40 on the latches....and it is now gone. I previously had to remove my interior bulb because when the dummy light came on, the interior light stayed on also....
  • I just had a tranny diag done for $70 and an engine diag for $30
  • I will tell you right now you can do all of that yourself and save yourself a bunch of money. Everything you listed there is easy to do. You can order that TCC solenoid from any autoparts store, but its probably goin to be around $100 or more. The harness, converter, and pan you can should be able to get at the salvage yard. If you dont have one local here is a site that lists parts from thousands of salvage yars around the country. http://www.car-part.com/ I did a search for the pan, converter, and harness. I came up with 3 possibles on the converter, 5pages for a harness (most were engine harnesses), and got a quote request page for the pan.

    What I am most curious about is why they said you needed a whole new trans wiring harness. Usually if there is a wiring problem they can overlay wires and replace pigtails instead of replacing the WHOLE harness. If the pan was just bent, straighten it out. The converter can be rebuilt, I would see if you can find one of those, but I cant help ya out on that TCC solenoid. Those ya should buy new.

    Hope this helps.
  • Recently my emerg brake warning dash light stays on. The brake releases fine. Any solutions?

    Thks
  • Check your fluid level in your Master Cylinder resevoir.

    That light has 3 uses that I can think of off the top of my head.

    1. Notification that the parking brake is set.

    2. Notification there is problem in the service brake system.

    3. When this light is actived by a low fluid level or service brake problem then the abs system is INACTIVE or doesn't work.

    First step when the red "Brake" light is on, is to check the "P" brake is not on. Second, check the fluid level in the main resevoir on the Master Cylinder. Third, verify no leaks from hoses or rear brake cylinders. That should help diagnose your problem.

    IF all of the above are satisfied, and you can't find a leak or low fluid level, I would use a simple test light to see if you can get a ground through the wire leading to the "P" brake, while it is disconnected from the switch. If you can do that, then the wire has chafed and found an alternate path to ground. Trace the wire back up to the cluster.

    Ford Tech
  • Will a aod trans work with a 2.3l. The aod trans is out of a 89 mustang.
  • les7les7 Posts: 1
    I had the same problem on my 94 ranger. It may be an air bubble trapped in the clutch master cylinder inside the cab. I could not get my clutch to work until I removed retaining clip and bled fluid from top of master cyl. inside the cab. Messy but worked great.
  • redbusredbus Posts: 4
    Thanks for the reply Ford tech. I took delivery 12/30/06 and have been in shops 3 times so far for this problem. Finally a experienced tech installed a Ford band aid solution which is a vibration damper, pn 5G209 on the exhaust pipe aft of the converter. The damper is a weight clamped to the pipe. Apparently the exhaust gas produces a harmonic frequency that generates
    a viberation in the exhaust system that is felt through out the vehicle at various speeds. Does it work? I'm not sure yet.
  • I HAVE A 1999 RANGER THAT PING TOO i DID EVEING THING TO IT IT STILL PING .WHAT DID FORD DO YO FIX IT ?
  • Well according to a TSB for my 2000 3.0L Flex Fuel ranger, they replaced the PCM and did a recalibration. I havent changed out my PCM though, I just run higher octane (89) fuel in my truck and it gets rid of the ping.
  • That has been a problem with alot of Fords. Sometimes they catch it in the design phase and install the exhuast dampners at the factory. Somtimes they dont. Just like the 04-07 Lincoln Mk LT and the F-150's, they have a bad vibration in the bed going down the road. So much that it looks like the bed is going to come off in the rearview mirrors, but its an illusion. It is due to the stiffening of the frame, and so Ford installs a Frame dampner at the factory for all the Lincoln Mk LT's to keep them from complaining at all, and if the F-150 customer complains of this to the dealer, they have to install a frame dampner at the dealer.

    So its not really a band-aid as you say. It just wasnt caught at the design or manufacturing level, so this part could be installed without your knowledge.

    So, its very possible that it could fix your problem all together.

    Ford Tech
  • what about the knock sensor
  • What about it? Your engine has to ping for about 20-30sec before the engine will retard the timing to get rid of the ping. I dont know about you, but as much as I have heard my engine ping going down the road, eventually its got to do something bad to the engine. As for what the PCM does to get rid of ping, I dont know about you, but I would prefer to keep the power output of my engine, and not have the PCM retard my timing and kill my power.

    Now if you are refering to the TSB, I didnt see anything about changing out the knock sensor, just change the PCM with a new part# and put in the recal. I have the as-built data for my PCM, so if I ever do the upgrade (I pray it will fix the problem) then I have the info already. I am planning sometime this spring to hook my truck up to the WDS out at the University and put the as-built in and see if can get away without putting a new pcm in.
  • Guess what... You should be using Mercon ATF in that powersteering system.. LOL NOT Prestone PS fluid, and why would you want to? I mean you can Mercon III at any autoparts store and it only costs $1 at Wal-Mart for a quart.. Oh, and I have a 2000 3.0L as well, with 111,828mi and I still havent replaced my PS fluid.
  • Glad you found the source of your problems. If you don't mind me asking, what is the name of the tech book and where did you purchase it?
    I have a similar issue with my '98 Ranger XLT, auto trans with O/D, 4.0L V6, 2WD. The O/D light in my cluster panel usually starts blinking about 5 minutes into every daily drive. When it is blinking, my transmission still performs correctly except that it shifts gears very hard. When I shut off the ignition, the system re-sets itself and the vehicle runs correctly again. Then, 5 minutes later while driving, the overdrive light begins to flash and the condition (problem) returns. Changing gears on the column or pressing the O/D button on the end of the column will not stop the O/D light from flashing. Any thoughts?
  • I have a '98 Ranger XLT, auto trans with O/D, 4.0L V6, 2WD. The O/D light in my cluster panel usually starts flashing about 5 minutes into each morning commute. While it is flashing, my transmission still performs correctly except that it shifts gears very hard. When I shut off the ignition, the system always will re-set itself and the vehicle runs correctly again with no flashing O/D light. Then, 5 minutes later while driving, the overdrive light begins to flash again and the condition (problem) returns. Changing gears on the column or pressing the O/D button on the end of the column gear shifter will not stop the O/D light from flashing. I feel strongly that it's a sensor issue, but I do not know which one to check. Any thoughts?
  • wookie1wookie1 Posts: 98
    i have a 97 my od light was flashing the problem was my speed sensor
  • I took my truck into a shop for diagnostics and they told me that I needed a new torque converter, solenoid and wiring harness. I sold my truck as this was about a thousand dollar repair.
Sign In or Register to comment.