Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Ranger Maintenance and Repair

17071737576147

Comments

  • Thanks for reading.

    Here is the scenario: 97 Ranger XLT, Big 6-cyl. . Neither headlight comes on when you turn on the headlight switch. All related fuses check OK in side panel and under the hood. No problems with any other lights. Can "flash" high beams OK by pulling back on turn signal stick, but cannot "lock" high beams by pushing turn signal stick forward. Prior to this problem with the headlights, on rare occasions the windshield wipers would randomly turn themselves on "high" for no reason, but could be turned off by turning the wiper switch forward (on) and then back to the off position. Possibly related to a common switch in the turn signal stick? If so, are there any know service bulletins or defects regarding this so that I might get if covered by Ford?

    Thanks for any help !
  • I have a 1989 ford ranger, its almost perfect, it has a small exhaust leak, and the gas gauge doesnt work, im sick of adding up the milliage to find out when i need to fill it up, any ideas on what to do? im sick of having to deal with it
  • mrartmrart Posts: 2
    David: I'm haveing fuel problem and it maybe the crank sensor. Could you tell me where the crank sensor is located on the Ranger 1994 4.0L V6 . mr art
  • helpless1helpless1 Posts: 2
    How do you replace the electric shift motor on a 4x4 Ranger. I have removed the bolts but it still doesn't budge. I believe that the shift motor is shot on my 94 Ranger 4x4 as it will not go into 4wd when the push button is depressed. (Nor do the LEDs light up denoting that the 4wd is engaged; do hear the relays clicking though.)
    Any advice on removing the shift motor would be helpful.
    thanks,
  • Here we go, my daughter has a 91 2.3L 4 cyl. that we just replace the fuel pump on. It ran well for about a week and a half. It is now doing the same thing as before, starter is turning and no gas to the throttle body. I can spray starting fluid in there and it will run until that is gone. I have just replaced the fuel filter relay(I think). Not sure which one it was.
    When the key is turned, the pump does not prime. no noise, nothing, nada. What else needs to be checked?
    Not a mechanic at all either. I am lost right now.
  • You got screwed by Ford too huh? Got a 99 Ranger 3.0 Flexi Fuel 4x4. Was driving around and the same thing happened to me at 62,xxx miles. Before I could even get off the road it was ruined. I called Ford and there had been no recall or service bullentin about this problem but now I REALLY wonder if there should be.

    Repair shop said they think it was the cam postition sensor or something along those lines that failed. Cost me over $3k. Try American Engine Installations. They are a national chain. The dealership wanted over $4k as well but it was 500 for the engine and 1500 for labor and AEI. The rest I went ahead and got new hoses, belt, water pump, sensor, tax and so on since it was being worked on. They were not only over $1k cheaper but gave a 50K warranty over the crappy 36K Ford one. Really stand behind their work at Ford huh!

    Oh, let's see what else has gone wrong. Well at 58,000 the spider gears in the differential went our costing $1100. The tranny went out 3 months ago at 72,000 costing over $2500.

    I take VERY good care of my behicles and I will NEVER buy a Ford again. I'm solid Toyota now. While US auto makers are heading out of the country, foreign ones are building plants here.

    Hope you get it worked out.
  • dgoodwindgoodwin Posts: 1
    Did you ever find out what the problem was with this Ranger?! We have a similar situation. The dealership replaced the alternator...well, they replaced it twice (!) but that's a different story....but after the replacement several weeks ago, this now sounds VERY similar to our problem. I'm wondernig if they did something while working on the alternator! Thanks!
  • bird1036bird1036 Posts: 2
    We are having trouble with our Ranger. Sometimes it will start and other times it won't . It is supose to have a reset switch for the fuel pump but we don't know where it is located. We have replaced just about everthing paid over a thousand dollars at garage and it still does this please help!! :cry: :sick:
  • ianchasianchas Posts: 2
    I have the same problem with my 94 Ranger splash-- just this monday had to have it towed cause it won't start for over four hours. As soon as I rolled it off the tow truck, it turned over a long time the first crank with no result, then started right up on the second try. I'm also frustrated... I've found suggestions to replay the fuel pump relay and replace a sticking idle air control valve. Don't know if either will help.

    This seems to be a common problem with older Rangers,

    Anyone else please help?
    John
  • ianchasianchas Posts: 2
    Hello,

    An update to _my_ version of this problem... Could not get it to start again tonight, fortunately at home this time. Swapping the fuel pump relay with the AC relay as suggested by someone had no effect. It DID start after I put it into reverse and let the truck "rock" a bit as I tried starting.

    Then after one or two tries, it started right up... Help, I'm as lost as the guy with the 91.

    Also, for reference, my clutch is starting to go, and is hard to shift into 1st or reverse, don't know if this is part of the problem or not,

    Ideas?
  • semlersemler Posts: 1
    had a blown head gasket, replaced gasket ran fine for awhile. My number 2 and 4 sparks both would foul out, replaced the intake gasket. stated fine idled good but had no power. Couldnt even spin the tires in a gravel drive! or go up a hill. Check the fuel pressure, only 30PSI at idle, replaced the fuel filter and fuel pump, no has over 40 PSI, but still no power. getting spark at all six plugs. Checks for vacuum leaks found none. Receiving no error codes. Any ideas???????
  • red721red721 Posts: 1
    I just bought my 16 year old a 98 extended cab 4x4 with 93000 miles on it. It idles rough and bogs down at stop lights. What bothers me is we filled up with gas and went to pull out from the station and she had her foot to the floor and the truck wouldn't go. Like it wasn't getting gas at all. It finally caught and started going, but scared us to death. Have had oxygen sensor replaced already. This scares me as a 16 year old is not real experienced. Please help. It doesn't happen all the time but periodically.
  • jvbcjvbc Posts: 1
    My 16 year old son just got a 1995 2.3L Ford Ranger std trans given to him as his first car. Only 38k miles but it has sat idle for over 2 years. After a new battery, new plugs and wires, a new solenoid relay, and a new clutch it is working pretty good. However the airbag light and engine light is on. The 10 amp fuse for the airbag in the power distribution box was blown out. When it was replaced it blew out instantly. Its done that twice and I don;t want to ruin any more fuses. It won't pass inspection with the check engine light on. Any ideas on what is causing the airbag fuse to blow? Maybe the same reason the check engine light is on? Thanks for any help.
  • jmo4jmo4 Posts: 3
    I had this exact same problem with my 96 4.0 Ranger 4x4. It's hard to describe how I fixed it without a diagram, but I'll try.

    The problem is one of the terminals in the headlight dimmer switch (the one controlled by the turn signal arm) gets hot, melting the plastic around it enough so the spring-loaded contact sticks. So, you have to unstick that contact.

    First remove the turn-signal/headlight dimmer assembly by removing the covers above and below the steering wheel (three phillips screws under the steering wheel). The switch comes out via 2 or 3 star bit screws that thread in from the back (front of vehicle, if I remember right). Take apart the switch, I think it just snaps apart (careful, lots of little parts to keep track of inside, you might want to take a few pictures before you take itr all apart.). Clean all the contacts as best you can, and put a few dabs of dielevtric grease in there when you're done. Look for a white plastic peice that slides up and down in a slot of sorts against another part with with diagonally oriented copper contacts. This is the dimmer switch .... there should be 2 spring loaded contacts on the moving plate, one or both will likely have blackened plastic around it, and wont move freely when you press on it. Pop the contact out and use a small drill bit to ream out the hole so the contact can move freely again. Put everything back together (easier said than done, especially with large fumble fingers). Reinstall, plug in, cross your fingers, and try it!
  • timmymacktimmymack Posts: 2
    I have a 99 Ranger and usd to have the same problem at times. The front brake calipers are prone to rusting causing the brakes to not release. I remember times driving in 5th on flat grades, with the gas to the floor, and not being azble to do 55 mph. (My wife got stuck once in mud while in 4 wheel drive due to the same reason.) Ford has known about this brake problem, but won't do a recall because it affects virtually every one of their trucks, but have come up with a solution that Ford dealers service centers know about. I had mine done and have no more problems.
  • gbhosleygbhosley Posts: 2
    The engine light stays on continually.
    Replaced oxygen sensors - light went off(I disconnected the battery).
    Drove for about two hours with no light then put in park, put the air on and now the engine light is back on.
    Checked vacuum hoses for damage. New air filter,spark plugs and wires.
  • I have a '88 4 wheel drive and need help unhooking the linkage to the transmission. All help would be appreciated. thank you, Tom :confuse:
  • bolivarbolivar Posts: 2,316
    Have the code/s pulled that are causing the check engine light to be turned on.

    Stop throwing parts at an unknown problem.
  • bird1036bird1036 Posts: 2
    Can anyone else help for #1482? Please :confuse:
  • lcortonlcorton Posts: 1
    I am trying to find out what kind of transmission I have and the sticker on the door panel is not helping me. According to the Autozone website there are 3 types of trans. My truck is a 99 Ford Ranger stepside and the only letters I see on the sticker are TPR T A3 and these do not fit the Autozone numbers. Cn Anyone tell me if I am looking at the right numbers.

    Thank you.
Sign In or Register to comment.