Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Blazer Warning Lights and Gauges

12346»

Comments

  • hello im a newbe so please be patient,anyway,im sure you guys have answered this question a 100 times,all the gauges in my dash come on -abs,security,seatbelt,airbag,batteryand the gas gauge goes dead,also temp gauge,and gear selector light goes dead but the truck runs fine during these episodes,if i press the door lock button and hold for a minute then lock and unlock,lock and unlock a few times they return to normal. please help!!!!! its driving my wife nuts..... thank you in advance, dave.
  • jlflemmonsjlflemmons Posts: 2,240
    Okay, since you are a "newbie" we will cut you some slack. ;)

    It would help to know the year model?

    Jim
  • yeah oops, its a 2000 chevy blazer ls 4 door 4x4,sorry!! :sick:
  • hey there,i had my fuel pump changed had the same problem as you,it was the evap canester vacum hose connection on the fuel pump,had my buddy fix it,problem solved. ;) ;)
  • doc03doc03 Posts: 1
    Anyone know of any recalls for speedometer and fuel gauge going awry? I've been using my GPS to tell how fast I'm going and re-setting my mileage each time I fill up to figure out my fuel needs. I hear it might cost me upwards of a 1000.00 to fix them both.
  • bevmbevm Posts: 1
    Ok never done this but in need of help!! Bought a 99 Blazer a week ago. Trying to figure out a few problems. First i found to line under hood not connected to anything and cant seem to see anywhere for them to go even though I have followed other line connected with them. Second on the air conditioner the wheel on front the belt goes around will kick in and kick out is that normal even if air isnt on? She is running rough so I am assuming a tune up. HELP!
  • dp2226dp2226 Posts: 28
    I picked up an ABS code reader. The light comes on more and more frequently on my 1999 Blazer. Code comes back each of the wheel sensor circuits are open. They are both very new, few thousand miles tops, new hub and all. I bleed the brakes numerous times and in the correct order.

    I do have the bigger the tires. I am out of ideas. All calipers are new as well
  • dp2226dp2226 Posts: 28
    Does the wheel you are talking about look like it turns then slips. I fortunately have not had that problem on my blazer but on my VW did the same thing and was the A/C clutch. There are some grooves may be stripped. This is just something to look at. I cannot say this is 100% your problem but sounds like what you are describing.
  • I just bought a 96 blazer LT. It has 134000 and overall cant really complain for $1100. Runs great and feels solid when it comes to tranny/suspension. Pretty good as far as cosmetics also.(owned by old guy from new, had nothing else to do but clean it) One thing that bothers me is the temperature gauge never moves. all the other gauges seem to work fine. I had a major short the day i bought it. The starter cable ground out against the motor mount. Idiot that replaced it didn't put it through the wire loops. Anyway would there be any reason that just that gauge doesn't work? Fan kicks on and engine doesn't seems to run too hot. Im just paranoid and want to get it fixed but dont want to pay the shops to do it. Would a new thermostat do the trick?
  • jlflemmonsjlflemmons Posts: 2,240
    There is a sending unit in the left side head near the rear, close to the steering shaft. Check to see if it is connected.
  • I have an 01 blazer 4.3 4WD. I have recently had an engine code for Evap Pressure High, found out the Fuel Tank Pressure Switch was bad. Replaced it, I was told to disconnect the battery to clear the codes. Upon reconnecting yes the engine light is out, but I have 2 monitors that will not set. I have drove it 500+ miles at night because the inspection and emissions expired last month! Thats how long I have been trying to figure it out! Took it to the ins station, on the emission machine it came back as "NOT READY"! Can anybody please tell me why? What could cause this? There are no codes in the computer! Please HELP! :confuse: Thank you for reading!
    Arine
  • For the past two months my truck has been jerking (as if it's not getting its gas) no matter what speed I'm driving. When it is idling, it sounds like it is going to stall, but hasn't...yet. I've recently put STP and fuel injection cleaner in...neither worked. Also, I've had the air and fuel filter changed...didn't work. I purposely go to different gas stations to make sure it's not bad gas. Can anyone help?
  • steverstever Viva Las CrucesPosts: 40,862
    A reporter is looking to interview anyone with a GM vehicle that doesn't seem to accurately read fuel levels.

    Please email pr@edmunds.com Friday, April 29, 2011 to share your story.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • i have a 2000 2wd chevy blazer my fuel guage i have figured out how many miles i can get off a tank of gas but i want the the gauge to work i have tried everything. :(
  • niceguy4niceguy4 Posts: 2
    It started with rear hatch and wiper quit working from dash,then passenger seat heat,door locks from drivers side,then remote mirrors.I get no codes can not find any bare wires.Thanks for any help
  • niceguy4niceguy4 Posts: 2
    I had same problem with 99 blazer and jimmy 99 both need new fuel pump which has asending unit built in.I kept putting off fixing fuel pump went out 160 miles away.They say at parts house when gauge goes not long for fuel pump.
  • My 2000 Chevy Blazer ZR2 began jerking as you described. However, I had no issues at idle--only when accelerating, whether it be from a dead start or going up hill. And only when turning to the right, never the left. Stumped the auto mechanic. Well, it turned out to be both motor mounts were completely shot, and the engine was apparently flopping around. Replaced the motor mounts and the problem was gone.
  • tspierstspiers Posts: 1
    Have a 2000 blazer and just put a new battery in. But when I'm on cruise control and it gives itself gas to go uphill or pass someone my voltage drops and th battery light comes on. Voltage meter reads on the outside that it is charging but inside gage reads very low. HELP !!!!
12346»
Sign In or Register to comment.